Progress Thread 2.3L - Won't Stay Running issue

So I double checked the wiring/connections and everything is going where it's supposed to and all the connections are good. The starter solenoid is working like it's supposed to and as far as I can tell the ignition switch is working properly. Battery is fully charged and good. Battery/starter cables are new and test good. Grounds are all clean and testing good. Starter is operating properly. Where/what else should I be checking?
  • Sponsors (?)

I think I figured out the problem, I'm missing the battery warning light and the inline resistor for the green alternator wire. It's not on the wiring diagrams as far as I can tell, but I've been reading in forum posts that it is required to have the alternator function properly. Does anyone have a part number or more info on what the specs for the resistor is? Thanks!
On a side Note: I [think] your account has [Official Member] status. You should have the ability to edit your thread title to reflect your current issue.

You can find that control here:


It will say [Edit Thread] and from there you can edit the title.

You will see my example reflected in the current title. :D

Oh, and I turned this into a Progress Thread. :)
  • Like
Reactions: 1 user
If this is the one that's supposed to be in the cluster, I think maybe @Mustang5L5 might have some info on this. I think he has a thread comparing available clusters etc...

jrichtker has it as a 500 ohm resistor.

I think my later year EVTM's list it out but I only have the '88 one in front of me so i'll need to check later

  • Like
Reactions: 1 user
Ok so I have a led battery warning light but the measured resistance is about 4.97M ohms (reading fluctuated about +/- .03 and never settled) by itself. Will that prevent the alternator from working properly or does it just need to be at least 500 ohms for it to work?
Decided to just hook it up and see what happened. The battery light comes on with everything else, stays on untill the key is turned to start, then goes out, and comes back on once engine is off. Engine cranks and starts until key is released then it dies still. Sometimes immediately like if you intentionally turned off the engine, sometimes like its not getting enough fuel. Tried using starter fluid, it didn't change anything. Will take readings probably tomorrow night, got an early day tomorrow. Any thoughts would be appreciated! Thanks!
Why not try a factory style incandescent light bulb and see what happens. Most people that change all the dash lights to LED leave the battery light alone due to charging problems.

I still think the EEC is not getting the run 12V+ when the key is released from the crank position. Have you verified the wiring on the ignition switch and verified that the rod off the ignition cylinder is correctly placed in the ignition switch?
I will see if I can get a factory incandescent bulb and give it a try.

As far as I understand, the ignition switch is working how it's supposed to. I will get readings off it again, post them and what I have wired at each terminal. I'm also 99.9% sure I have the post right as well but I will double check that also.

Thanks guys!
Here's the pin out of my ign switch. Battery was low so it's charging but once it's done I'll get the readings posted.


  • IMG_20230831_190220984.jpg
    348.8 KB · Views: 12
Here are the readings during koeo/cranking/release. Cranking readings are the lowest readings recorded by my dmm and release readings are the first reading I could read on the screen. I did the koeo and release readings first then did the cranking readings since I had to use the min/max setting and my dmm isn't a fluke lol. Maybe one day. Back to the more important issue, am I missing a significant voltage drop? I still think these readings are fine but I've been wrong before.


  • IMG_20230831_215431908.jpg
    571.4 KB · Views: 13
Would my tps having 1.177V on the middle wire be causing an issue? I've read conflicting posts across the web saying it has to be under 1V and others saying it's fine as long as it's close to 1V.
I went back and reread the entire thread. Have you at any point replaced the ignition switch? When you had the original harness in the buggy did you have all the grounds going to the battery or just ground them where they fell so to speak? So to further clarify grounded them on the frame.
I have replaced the ignition switch 2x, the original was separating and the replacement sat for several years and ended up having the same issue. The one that's currently on is the one I got the readings I posted, it's still together.

The "original harness" that it had when I got it was already modified by the previous owner but the grounds were not all run to the battery. I tried running the almost all the grounds to the battery to see if I was having an issue with the frame not grounding properly, nothing changed so I routed them as follows:

Battery - cable to lower left starter bolt

Ecc relay and ckps lone single terminal to battery - post

HO2S/MAF/Ecc 40/60 to battery -post

Fan relay/Killswitch/acc switches to lower right bolt on intake (nothing to attach to on the back of head). I have a ground strap going from here to the frame

Where the above ground strap attaches ecc 20/horn ground are connected

Cable going from frame to block under exhaust manifold

Usb charger/vss/headlight switch/gauges/turn indicators/mil to frame

I was doing diagnostics right before you posted and I found that I'm getting 12.20V to all 6 of the wires coming out of the coils (koeo, dmm connected to batt -, back probing the connectors) . Going to make sure it's connected properly and do some testing, but that seems like it could be an issue.