Progress Thread 95 2-Top Cobra Build Thread- Proving Grounds

  • Sponsors (?)


Essn95

5 Year Member
Jun 21, 2017
713
524
113
In the meantime of Speedo diagnosis, I picked up one of those AC Pro kits as I got tired of the “cool” ac I was having. I would have it on max cool and temp and it would barely be enough to keep you from sweating in this florida heat. After the recharge she is back to freezing up the cabin like when I first got the car!
 
  • Hell Yeah!
Reactions: 1 user

Essn95

5 Year Member
Jun 21, 2017
713
524
113
Here’s how my gears looked after my DIY install with about 25 miles on them. Wonder if they’re good to resell since the pattern on them should be super light (just the coating)
730993D2-8FB1-4CAF-B5D6-3A422A82972F.jpeg
533BD9BF-CA50-42DF-B3DA-D4E1AA79DA24.jpeg
1E1C42FB-76A3-4285-ADF1-EAC2AD6764E4.jpeg
 

bird_dog0347

still married haven't seen testicles in years
10 Year Member
Jun 7, 2012
1,670
1,467
164
Little Elm, TX
You will be able to sell them, and a competent mechanic should be able to set them up correctly... That said, don't lie about the miles or condition in the for sale ad (for ANY part), even if it costs you $50-100... integrity is worth more than that.
 
  • Like
Reactions: 1 user

Essn95

5 Year Member
Jun 21, 2017
713
524
113
Was pretty confident this wasn’t the issue but gave it a try, threw in a good cluster and issue persisted. Next I will look into the wiring from sensor to cluster because I know each of those “destinations” are good. If I’m not mistaken it’s AC signal that is sent to the ECM. Any guidance in troubleshooting is
723ACEF8-3BFB-4B4F-9EBD-2407DE36766D.jpeg
5804903F-D349-4C0F-B019-42F9DE6861BA.jpeg
appreciate
 

Essn95

5 Year Member
Jun 21, 2017
713
524
113
So I went ahead and bypassed the speed cal for now to eliminate variables for now. No change
replaced the VSS sensor connector and the leads running up to it, about 4 inches worth. At this point I now had cruise control work so my suspicions turned towards the cluster again. Hooked up my voltmeter to the connector that plugs into the cluster and sure enough, I was getting an AC reading between 0-10V increasing with speed. About 7.5V at 50mph would be my estimate. I’m going to get some rebuilt components for my gauge cluster and I am fairly confident that will do it. The connector was definitely half of the issue. On another note there is absolutely no 94-95 clusters for sale, these cars and parts are getting much more rare, might need to start collecting more spares. Hopefully she will be fully operational next week when the new speedo donor parts come in!
 
  • Like
Reactions: 1 user

WhiteCobra95

Mod Dude
May 2, 2006
515
121
74
The components look pretty straight forward to test aside from the IC. Does anyone offer replacements? If you can't isolate anything during debug, it might be worth contacting a shop that rebuilds clusters. Good luck, I hope it's something simple!
 

Essn95

5 Year Member
Jun 21, 2017
713
524
113
So I went ahead and replaced the tach and speedo components with the rebuilt ones. Speedo and odometer now work, however, they are not fluid at all. The speed has about 20mph of delay and it doesn’t rotate in real time. The tach sits at 3k for idle and then stays frozen for about 30sec before updating. I will have to take it back apart to investigate but I’m thinking there might be some bind in the needles. Any other ideas are welcome. New vs old unit pictured
530408C5-3392-46C4-90FF-CCEED373194A.jpeg
 
  • Like
Reactions: 1 user

Essn95

5 Year Member
Jun 21, 2017
713
524
113
Finally got everything sorted! Took a few tries to get the tach needle aligned properly but now she is dead on. Once I got everything back working, I wired back in the speedcal box and now the speed is dead on, GPS verified. I am glad I went this route over the driven gear for the VSS because this allows me to get precise results and the ability to change the calibration if I change ratios, or more likely, switch to a taller tire. The issue I was having above was because the needles were pressed on too far and were making contact with the gauge face. Very excited to get back to daily driving the Cobra after having it parked for two weeks waiting on parts and for free time
 
  • Like
Reactions: 3 users

Essn95

5 Year Member
Jun 21, 2017
713
524
113
Back to commuting to/from UCF, little parking garage pic. Speedo seems to be stuck a little when “cold” until I get above 20mph or so. Not big enough of a deal for me to pull it again. Will get around to it if it doesn’t fix itself. Could just be the fresh paint in the needle making it stick to the stop
615FC66F-74C4-4A90-A0F1-B439E1C028C3.jpeg
 
Last edited:
  • Haha
Reactions: 1 user

WhiteCobra95

Mod Dude
May 2, 2006
515
121
74
Where did you find the rebuilt cluster parts to fix it?

About two years after I bought my Cobra, the temp sensor in the cluster went bad and read cold all the time. After replacing the sensor, the gauge was still dead. I was lucky at the time because I could still get a new replacement from the dealer. Some day I'm gong to go back and try to fix the original.
 

Essn95

5 Year Member
Jun 21, 2017
713
524
113
Where did you find the rebuilt cluster parts to fix it?

About two years after I bought my Cobra, the temp sensor in the cluster went bad and read cold all the time. After replacing the sensor, the gauge was still dead. I was lucky at the time because I could still get a new replacement from the dealer. Some day I'm gong to go back and try to fix the original.
Pro Rebuild on eBay. I reached out to them to pick up the one component I needed without having to buy an entire cluster to part-out. The 94-95 Cobra clusters are nearly impossible to find now but luckily all the guts can be swapped for the GT items.
 
  • Useful
Reactions: 1 user

Essn95

5 Year Member
Jun 21, 2017
713
524
113
With my obsession of having the “ideal” build I made the decision to run meth injection on my build. Will be going with the Snow Stage 2 kit with VC-50 controller. I designed up a gauge pod that replaces the driver side AC vent as my dual pillar pod is already filled with boost/wideband. This gauge for the snow kit shows the progressive injection and doubles with a boost reading. The pod is on my printer right now and pictured is the rendering of my design
2CD52E1D-335A-4D60-B305-D14604E87DC1.jpeg
BF01D778-D259-4223-82BC-8EFF1EACFA41.jpeg
 
  • Like
Reactions: 1 user

Essn95

5 Year Member
Jun 21, 2017
713
524
113
That being said I plan on running primarily distilled water, maybe just 10-20 percent methanol. I’m not going to push the car by leaning it out and more timing. I will have a slightly more aggressive timing table with low IATS but otherwise I will have it setup like there is no water meth injection that way if something in the system fails no harm will be done. With a primarily water mixture, I will get the cooler charge temps without making the car run rich from the methanol.
 

Essn95

5 Year Member
Jun 21, 2017
713
524
113
Test fit! Fits the gauge very snug and I used stock clips to mount in the car. Planning to get some real saddle tan paint as the one I have from SEM featured earlier in this thread is too army-green looking. I just changed my design to incorporate the mounting clips so I won’t have to transfer stock clips over.
64FAF9D4-E75B-49BB-B206-9B256815C1CE.jpeg
 
  • Like
Reactions: 1 users