Engine After 8+ months of sitting and no crank

opihinalu

Active Member
Feb 10, 2021
165
19
28
19
Florida
I recently went down my list and fixed almost everything that needed attention on my 86. I replaced the radiator, added an electric fan, thermostat, hoses, water pump, AC clutch, brake proportioning valve, air intake, transmission cooler, and serpentine belt.

I went to start it today and it won’t crank. I have power. My battery is getting 11-12 volts, there is power at the starter relay. What could be the problem here?
 
  • Sponsors(?)


Mustang5L5

Put lubricant all over the balls
Mod Dude
Feb 18, 2001
38,934
14,837
224
Massachusetts
Do you have 12v on the blue/red trigger wire on the relay when you turn ignition to start? The top small post?
 

7991LXnSHO

wanna catch the space herp
10 Year Member
Sep 1, 2010
7,122
2,933
194
Kearney, NE
If that’s all you missed, don’t feel too bad. Forgetting the big vacuum cap under the top half of the intake was a more time consuming oversight.
 

limp

wrap a little cheese around it and its a done
Oct 4, 2020
2,285
1,471
133
67
Florida
No floor heat in my new truck... I guess that little picture on the button I was pressing meant Windshield....LOL I can play my Gray hair card though...
 

opihinalu

Active Member
Feb 10, 2021
165
19
28
19
Florida
No floor heat in my new truck... I guess that little picture on the button I was pressing meant Windshield....LOL I can play my Gray hair card though...
Haha, ive done that. Was convinced my AC was broken but i just turned it off, lol
 

limp

wrap a little cheese around it and its a done
Oct 4, 2020
2,285
1,471
133
67
Florida
Haha, ive done that. Was convinced my AC was broken but i just turned it off, lol
Like my Radio.. If you press the " OFF " button once it only mutes it, have to hold the 'OFF" button down to turn it off... I would get it "locked up" in mute mode... Glad I am old, the world is going to leave me behind soon...