Progress Thread Anyone run these cobra seats, debating on getting these.

Reddevil91

10 Year Member
Mar 3, 2010
1,320
548
153
After all you have been through hope all is well. Its a bad feeling to have the car sitting , and it wont run. Mine had a pip problem that took a month to figure. I would come home from work and see my baby just sitting there dead . it eats at you.
For sure my man, hope this is the problem. According to them that ecu was pretty bad. I will at some point install that dizzy
 
  • Like
Reactions: Potomus Pete
  • Sponsors(?)


fox racer v2

Active Member
Jun 2, 2019
91
48
28
32
Brooklyn
For sure my man, hope this is the problem. According to them that ecu was pretty bad. I will at some point install that dizzy

Think I had those same folks rebuild my A9L. I caught them during a sale (was like $90, but just lucky on the timing I needed and ECM) and was really happy with what I got back. I’m going to send my fried A9P that was previously rebuilt at some point, just to see if they can salvage it. Think you made the right choice here
 

Reddevil91

10 Year Member
Mar 3, 2010
1,320
548
153
Think I had those same folks rebuild my A9L. I caught them during a sale (was like $90, but just lucky on the timing I needed and ECM) and was really happy with what I got back. I’m going to send my fried A9P that was previously rebuilt at some point, just to see if they can salvage it. Think you made the right choice here
Yeah I went to eBay and they have multiple bid offers up, I offered 90 bucks and they accepted. I’m sure they can fix that one up for you unless it’s severely damaged.
 

Reddevil91

10 Year Member
Mar 3, 2010
1,320
548
153
So let me get this straight here, current situation is weather strip is out on passenger side. Both doors had no striker bushings so I installed one on the passenger side, again no weather strip in currently. Replaced striker back to where it was, closed the door and this is where I am. Now at this point the door is latched and way in. Am I suppose to adjust the whole striker bolt further back so when I close the door it’s flush? As it is right now I can not open the door unless I get inside and pull the handle and shove the door open. Now for my drivers door, this one doesn’t stay open which I’m taking is the bushing, so unfortunately as I stated in the other thread I already have the new WS installed, tried adding the striker bushing and well everything was off. Here is what I noticed which is my sweet rendering I added just to make sense of what I’m trying to spit out make sense so the door of open and I push and pull there is no play, if I lift it or up and down there is slight play, being when I lift the door up or moves up just a little. I’ve never had to close the door with the lift procedure though it’s just always closed nicely.
86C292BE-2B85-4114-81C2-E4C8229BE2A9.jpeg
8BA55A5A-9B36-47E7-9B13-133E247544AC.jpeg
E063CEA4-61DB-486E-8F8E-43F664824375.jpeg
 

General karthief

wonder how much it would cost to ship you a pair
Mod Dude
Aug 25, 2016
17,470
5,628
193
polk county florida
Adjust the striker so the door is flush with the quarter panel. In this case you will move the striker out.
Is the door square in opening? Even gaps bottom and back of door at quarter panel.
 
  • Like
Reactions: 90sickfox

Reddevil91

10 Year Member
Mar 3, 2010
1,320
548
153
Been contemplating pulling the s550 seats, like them great comfort etc just I am missing my red seats. So I got a buddy that comes and goes to Dubai a bit. He said he could get me some recaros since I was looking around at some recovered in my color liking for 1500. That’s not bad since I’ve found a bunch that were beat and ppl wanted 1000. So I started thinking about that retro look and the closest I could find would have to be the corbeau gts2. I follow a guy on IG suicidekings2 and he has a nasty 4eye, but he redid some corbeau seats kinda how I was thinking. Well a little different but similar! Don’t mind my lazy attempt with a cheap photo editor but what do you guys think? I like it, I’d even like to see what it looks like all covered but that will take some playing around but I like this look currently.
478107ED-CEF9-489D-AD43-8679E12B3DD8.jpeg
5C3E7E5E-D1C6-4CCC-A9E2-3DAD01BB5807.png
 
  • Hell Yeah!
Reactions: General karthief

Reddevil91

10 Year Member
Mar 3, 2010
1,320
548
153
Gotta have red because you got the Reddevil. Top five on Stangnet. Be picky it has to be perfect.
Thanks man, and yes I surely will be. When I make this change I want it to be the last time. The s550 set up I have looks nice but I think I’m over the all black, every one is going for it and I want something that looks different and stands out. I also sit to high currently, I’m 6’1” and feel like my head is in the liner. I’m sure the track extenders aren’t helping with that either. I’m in no rush but if I could do that corbeau deal like that I will or maybe some recaros.
 

Mustang5L5

i'm familiar with penetration
Mod Dude
Feb 18, 2001
33,610
9,896
224
Massachusetts
The thing about the corbeaus, specifically the GTSII is quality. Do your homework and ask around, but I read a number of posts/comments about their quality after a few years. Biggest one was the material on the gts2 fading to purple or breaking them down. If you are going to recover them, then that’s not an issue...but if you are buying a seat to recover, at least get a Recaro or Flofit. Should you change your mind down the road you can probably sell them for what you have into them.

Also, if getting a seat that sits lower is your goal, the GTS2 sits high. You have to custom order them from corbeau with a shaved foam option and then use low seat tracks and that still doesn’t get you low enough IMHO.

Hopefully that doesn’t come across as a “seat snob”
 
Last edited:
  • Like
Reactions: Reddevil91

Reddevil91

10 Year Member
Mar 3, 2010
1,320
548
153
The thing about the corbeaus, specifically the GTSII is quality. Do your homework and ask around, but I read a number of posts/comments about their quality after a few years. Biggest one was the material fading or breaking them down. If you are going to recover them, then that’s not an issue...but if you are buying a seat to recover, at least get a Recaro or Flofit. Should you change your mind down the road you can probably sell them for what you have into them.

Also, if getting a seat that sits lower is your goal, the GTS2 sits high. You have to custom order them from corbeau with a shaved foam option and then use low seat tracks and that still doesn’t get you low enough IMHO.

Hopefully that doesn’t come across as a “seat snob”
Nope not at all my goal is to try and get back to original seat height if possible. I do like the s550 seats and I got them where I wanted but I feel as though I just sit so high and I just really want to go back to either full red seats or inserted how I edited. I’ll have to talk to my buddy and see what he can do with the recaros and which type they are. For 1500 fully recovered in my choice I’m tempted. Thanks for the input bc that’s something I needed to know.
 

bird_dog0347

still married haven't seen testicles in years
5 Year Member
Jun 7, 2012
1,107
934
154
40
Little Elm, TX
I had the SVE S1 seats and while the quality was pretty good, they did sit too high in the front for me. I sold them and got the Corbeau Sportline Evolution seats now which sit nice and low! The quality on them is great, but they are certainly not "period correct" for the car. Maybe one day I'll find some Recaro's and get them all fixed up like @Mustang5L5 did but for now I'm very happy with what I have.
 
  • Like
Reactions: Reddevil91

Reddevil91

10 Year Member
Mar 3, 2010
1,320
548
153
I had the SVE S1 seats and while the quality was pretty good, they did sit too high in the front for me. I sold them and got the Corbeau Sportline Evolution seats now which sit nice and low! The quality on them is great, but they are certainly not "period correct" for the car. Maybe one day I'll find some Recaro's and get them all fixed up like @Mustang5L5 did but for now I'm very happy with what I have.
Yeah I talked to my friend and he said they could surely do like what I did with the corbeau rendering no problem , so nicely Re done Recaro LX seats for 1500 but that would have to be a little bit later for sure.
 

Reddevil91

10 Year Member
Mar 3, 2010
1,320
548
153
Ok well finally got the car out for a good cruise yesterday. Ran good, took it through some curvy roads, stopped at place to shoot some photos of it since they had a mural out front. Got in to reposition didn’t want to crank and then fired up, so left it running snapped some shots and cruised home. Left it parked outside for a few hours, it cranked up so I was decide run to the gas station and filler up. Backed out the drive and it shut off! Then just kept cranking but not firing up as it was doing previously, which I discussed. Just cranks and sounds like it going to turn over and nothing. Tried for a bit, let it sit for 30 minutes or so and tried again nothing, had to push it back into the garage. So now what!! ECU has been repaired as stated previously. I have a new distributor, not installed though. So I’m thinking of tossing it in, since as mentioned that cap and rotor currently on looked pretty bad. Now I don’t feel like my car gets very hot at all, but could it be the TFI module heat soaking and causing issues? I have seen those relocation kits for the module, is that worth a try or any good?
 

Black1987

my wife Bedazzled my input shaft
5 Year Member
Jan 9, 2011
1,041
584
164
NC
Ok well finally got the car out for a good cruise yesterday. Ran good, took it through some curvy roads, stopped at place to shoot some photos of it since they had a mural out front. Got in to reposition didn’t want to crank and then fired up, so left it running snapped some shots and cruised home. Left it parked outside for a few hours, it cranked up so I was decide run to the gas station and filler up. Backed out the drive and it shut off! Then just kept cranking but not firing up as it was doing previously, which I discussed. Just cranks and sounds like it going to turn over and nothing. Tried for a bit, let it sit for 30 minutes or so and tried again nothing, had to push it back into the garage. So now what!! ECU has been repaired as stated previously. I have a new distributor, not installed though. So I’m thinking of tossing it in, since as mentioned that cap and rotor currently on looked pretty bad. Now I don’t feel like my car gets very hot at all, but could it be the TFI module heat soaking and causing issues? I have seen those relocation kits for the module, is that worth a try or any good?
Might be a dumb question, but is your timing set at?

I had mine bumped up and after a good run, I would have to hold the gas pedal to the floor on cranking.

Turned out the distributor hold down was tight but was advancing slightly. I could grab it and turn it slowly.

Also,
FatFoxx’s kits were good quality
 

Reddevil91

10 Year Member
Mar 3, 2010
1,320
548
153
Haven’t done much to the car lately but finally swapped the fast & furious pedals out from the early 2000s, to these little bad boys from blue oval industries. Easily and extra 5hp!!
7365EEC1-BB0C-4430-B65D-15DAF2FF4952.jpeg
 
  • Like
Reactions: Olivethefet

Reddevil91

10 Year Member
Mar 3, 2010
1,320
548
153
What’s up everyone! I have been having this issue with my car now for a little while. Discussed in here a bit and tried some things and I got a point where I did what I could and this car was just so unreliable to drive that I didn’t. Issue was I would start the car, runs fine, drive it for a little drive and stop some where shut it off and when I would go to restart it it would crank and sound like it was gonna kick over and nothing. I finally said screw it and I took it to a shop that is reputable idk about a month ago or so and left it with them for a couple of weeks, told them what was happening. Shop calls me said hey we drove it, blah blah blah and we got the car to do what you were talking about on the crank and we adjusted the fuel pressure up from 30 to 38psi seems to be running great. Hmm ok well cool can’t believe that was it. Go pick up the car, it’s hot out, probably a good 20-30 minute drive back home and car is running good, idling fine at stop lights, I’m coming into my neighborhood and I give it a 1st / 2nd gear run and as I’m coming up to another stop light I need to turn at I toss it in neutral and let it coast and then it just shuts off. Coast through the light and tried to restart it and it nothing. Pulled over and cranked it, and it’s doing that exact same thing I took it in for. Tried for a good while and nothing. I am pissed! I walk home and of course call the shop and they act like they are shocked, it’s a Friday and they are closing not open on weekends and aren’t real quick to be like bring it back. Anyways go back to the car about an hour later, get in crank it and it struggles, I hold pedal down and keep cranking and it fires up, and I get it home. So what I noticed the next few days is I would crank it up and let it run for idk 5-10 minutes and shut it off, and maybe a minute later I would try and re start it and it would flop, just start cranking and sounding as though it was gonna then over but nothing. Almost as though it was flooded, then it really wouldn’t start u til the next day. I would start it up shut it off and go for the restart and same thing. I decided will idk at this point. I’ve had this DUI distributor I bought new a long time ago just sitting in the cabinet and I thought wtf do I have to lose by swapping it bc I thought well maybe the autozone 60 dollar one took a dump or the tfi was bad on it. Swapped it out, made some markings so I could time it back to what they did at the tuner which was at 10*, locked it down and tossed the pip back in. This was about two weeks ago and car has been running great. I have been taking it out for a good drive, come back home and shut it off in the driveway, give a few minutes and restart it and it fires right up. Idk but hopefully I solved my issue!! So question for you guys is the yellow mark is my 10* is and where I locked it down at in the video, is this a good spot timing wise with the marker or do I need to back it up? I’m talking about the yellow line with the timing marker. Only thing I’ve noticed now the other day was I rev’d it and it seemed to want to stay idling around 1100-1200 rpms which I know is to high. Then the other day it stayed around 1k. Do I need to back it down or mess with the IAC? I have a new IAC bc the one that on now is the original and I was told when I had it tuned that I should replace eventually. Long story, thanks for reading and appreciate any input as usual
View: https://youtu.be/8Z90TODI0_Y
 

Potomus Pete

Gretchen Whitmer is eating at me
Mar 7, 2019
1,196
408
93
56
Sarasota Florida
This story has been repeated a few times here on StangNet. When all else fails change the distributor. Glad to see Reddevil is back and running again. My car was down for a month once, and after the endless checklist it was the PIP.
 
  • Like
Reactions: Reddevil91

KRUISR

5 Year Member
Apr 16, 2015
339
117
63
50
So question for you guys is the yellow mark is my 10* is and where I locked it down at in the video, is this a good spot timing wise with the marker or do I need to back it up? I’m talking about the yellow line with the timing marker.


I would leave it at the 10* mark as that was where the tuner put it. Changing it could have impact on effectiveness of the tune (depending what they did).