Complete shut down w/code C-18

91AOD5.0LX

I have a slight sag in my rear
Feb 20, 2021
280
133
53
North East
You might have already covered this but check the power and ground wires on the 60 pin ECU connector. Mine had a issue where you could just touch one of them and the car would shut off. I ended up buying a new 60 pin connector and swapped them, tightening each physical connection as I moved it to the new connector.
Thanks Dan
I feel that at this point there is a list a mile long of what this can be and much of it is out of my range of knowledge or skill and with the winter basically here already in my area with no garage to work inside of, I made the decision yesterday to stop driving my mind wild in trying to figure this out by reading all night my Google searches and playing with things randomly that I honestly don’t know 100% what I’m doing. I am going to sit tight and wait until my December appointment with the shop I picked out and leave it in their hands. I’d hate to start running out as the general says buying parts and switching things more than they have been already and then still have to hand over the car to the shop and explain what I messed with and wires I pulled etc. I’m just frustrated at this point so I’m going to take this off my plate and leave it to the professionals. It’s going to cost me but when it’s fixed I will be super happy and will have information to share with you all. If it were warmer outside it would probably be a different story but my hands were going numb yesterday just doing an oil change and rear shocks/quads. I can’t imagine working in the cold when I’m just guessing and don’t know what I’m doing or looking for. Hopefully I will have solid info for you all by the end of December. Thanks everyone for trying to help me!
 
  • Sponsors(?)


General karthief

wonder how much it would cost to ship you a pair
Mod Dude
Aug 25, 2016
20,667
7,088
203
polk county florida
I had the same problem with that 89 f150, everybody kept changing stuff and when it still acted the same they didn't change it back and that created more problems, I had to change everything back and test one thing at a time. I finally got it to run fine with the exception of a sudden ruff running, then run good situation, that truck has a problem that was there before the engine change so I gave it back to the mechanic that installed the engine. Now he is back to changing a bunch of stuff that has nothing to do with what the issues are. He just called a little while ago, my first question was 'did you check codes?' His answer was 'those computers don't tell you nothin'. He has worked on newer stuff that basically tell you how to fix it.
I hope that shop gets it straightened out for ya, Keep us posted.
 

91AOD5.0LX

I have a slight sag in my rear
Feb 20, 2021
280
133
53
North East
I had the same problem with that 89 f150, everybody kept changing stuff and when it still acted the same they didn't change it back and that created more problems, I had to change everything back and test one thing at a time. I finally got it to run fine with the exception of a sudden ruff running, then run good situation, that truck has a problem that was there before the engine change so I gave it back to the mechanic that installed the engine. Now he is back to changing a bunch of stuff that has nothing to do with what the issues are. He just called a little while ago, my first question was 'did you check codes?' His answer was 'those computers don't tell you nothin'. He has worked on newer stuff that basically tell you how to fix it.
I hope that shop gets it straightened out for ya, Keep us posted.
Thanks General! I hope they figure it out as well. I have confidence. That’s an unfortunate story about your F150. Sorry to hear about that. I know what your saying about nobody wanting to pay attention to the codes. It’s frustrating. Wish I knew how to address some of this stuff myself but I’m glad this place is going to take me
In and do their best. I will keep you posted. Thanks for your help with this this and my other past issues!
 

Mustang5L5

Put lubricant all over the balls
Mod Dude
Feb 18, 2001
36,871
12,761
224
Massachusetts
I had the same problem with that 89 f150, everybody kept changing stuff and when it still acted the same they didn't change it back and that created more problems, I had to change everything back and test one thing at a time. I finally got it to run fine with the exception of a sudden ruff running, then run good situation, that truck has a problem that was there before the engine change so I gave it back to the mechanic that installed the engine. Now he is back to changing a bunch of stuff that has nothing to do with what the issues are. He just called a little while ago, my first question was 'did you check codes?' His answer was 'those computers don't tell you nothin'. He has worked on newer stuff that basically tell you how to fix it.
I hope that shop gets it straightened out for ya, Keep us posted.

That’s because troubleshooting is a dying art and most folks just fire the parts cannon at a problem until it gets fixed.
 
  • Agree
  • Like
Reactions: 1 users