Build Thread Dusty's Got A New Home

CarMichael Angelo

clearly, I’ve got something going on in that hole
SN Certified Technician
Nov 29, 1999
12,487
13,609
234
62
Birmingham, al
m.imdb.com
This DEI Easy Loom is becoming my favorite thing. Ordered from Summit and couldn't be happier. Now I have 3/8, 1/2, and 1 inch. They even included a wine voucher for 100 bucks. They ole lady will love that.

20200416_181556.jpg


I want to put this in place of the coupler for the rear brakes in the upper right corner. With AC and my booster vacuum pump being over there I just don't know how feasible that is.

20200416_181725.jpg


Glad I checked Summit. They had these 4 gaskets for my Systemax for about 24 bucks. The gasket I usually order is about 40 bucks each. LMR is taking care of my current order. Can't wait till next weekend, Dusty, will be driving again.

20200416_181111.jpg
You could’ve put the whole proportioning valve, and bias adjuster in one place if you intended to use a wilwood solution...
ad80bc04-6272-4bff-a593-68ea7ef2f475-jpeg.jpg
 
  • Like
Reactions: 90sickfox
  • Sponsors(?)


90sickfox

I didn't really have an issue with the stink...
SN Certified Technician
Mar 2, 2015
5,213
4,284
203
42
You could’ve put the whole proportioning valve, and bias adjuster in one place if you intended to use a wilwood solution...
ad80bc04-6272-4bff-a593-68ea7ef2f475-jpeg.jpg
I like that idea. I don't know how I missed it when I checked in on your thread. Nice catch can !
 

90sickfox

I didn't really have an issue with the stink...
SN Certified Technician
Mar 2, 2015
5,213
4,284
203
42
This thing is back together and a little cleaner and tidier.

The manual proportion valve fits perfect above the vacuum pump. No need to reinvent the wheel on this one. Now the engine bay is balanced with the wiper motor and bunch of wiring harnesses in the other corner.

20200419_094642.jpg


Still need to fill the coolant, put the car on stands, and bleed the brakes. Waiting for LMR to deliver the plug and a couple other goodies.

20200419_150749.jpg


Gotta run. It's time to cut the other half of the yard...wash the vehicles ( 4 ) and sit down to watch Netflix. Oh...and fix the tire on the Taurus. I don't know where this woman finds nails at. If there's one out there she's guaranteed to run over it. Every tire on that thing has at least one plug in it. Plugs aren't the best thing for a tire but this car sees 45mph max...and a 2 mile commute.

Tree guy was supposed to come today to trim some stuff and take down a dead ash tree. The guy never showed up. The tree has bark peeling and a hole in it about 20ft up. He said he was nervous about it...maybe his nerves got the best of him. We've got to find a way to get it down 'cause its leaning towards the house. If it goes there will be a new sky light in the kitchen ceiling.

Do y'all think it would be a bad idea to put a 5.0 and an aode in the 49 ? I've got a spare engine and the transmission is easy to come across. It'll have a Ford Explorer disc brake rear in it anyway so it won't be all Mopar as it is. This is the wife's car and she wants to cruise without shifting gears.
 
  • Like
Reactions: Monkeybutt2000

General karthief

wonder how much it would cost to ship you a pair
Mod Dude
Aug 25, 2016
16,320
5,202
193
polk county florida
Sure you could stick the 5.0 in there but my feeling is it needs a few more cubes to get that tub moving.
a 351 or better yet a 360 mopar is what it needs. That and a aod with a 373 gear will make it peppy enough.
 
  • Like
Reactions: 90sickfox

90sickfox

I didn't really have an issue with the stink...
SN Certified Technician
Mar 2, 2015
5,213
4,284
203
42
Sure you could stick the 5.0 in there but my feeling is it needs a few more cubes to get that tub moving.
a 351 or better yet a 360 mopar is what it needs. That and a aod with a 373 gear will make it peppy enough.
The old flathead runs but the PO thinks it needs a timing chain. He is including a 360. The 302 is narrower and fits in without having to modify the firewall for the distributor or serious modification to the steering shaft. I like column shifted cars but the wife isn't entertained by it. I was thinking I'll refresh and bag the original stuff. I could build the 302 and put a dual plane intake, RV cam, and a edelbrock 500. I could buy a AOD with the AODE upgrades.( don't know why I was thinking AODE...nothing in this car will be electronically controlled ). 373 gears would be nice. I've got to find out what gears were in the straight axle Explorers. She doesn't want it fast....just reliable and simple.
 

90sickfox

I didn't really have an issue with the stink...
SN Certified Technician
Mar 2, 2015
5,213
4,284
203
42
Oh yay !!! The joy of redoing battery cables. I found a little corrosion at a cable splice to the main battery cable. It came with a little screw that clamped the cable in....that thing sucked. I found a battery post clamp that I had laying around. If my MAP gas torch wasn't empty and the stores didn't close at 7 this would be done already. Looks like more unplanned work on Dusty. My partial tuck puts most stuff behind the drivers fender. That's a good thing 'cause I've got to pull the wheels to bleed the brakes anyway. I'll stop after work and grab a bottle...and a self lighting torch. I'm getting lazy in my later years ( 42 haha ). Tired of having to find a lighter or a spark box.

20200420_211002.jpg


That little plastic strap is going to get removed. Most of them are broken on most cars. I was proud of my washer bottle lid strap...oh well...its in the dang way.
 

90sickfox

I didn't really have an issue with the stink...
SN Certified Technician
Mar 2, 2015
5,213
4,284
203
42
This whole working on the car thing always turns into more stuff.

Had some fun with some battery cable ends.

Add some solder

20200421_230509.jpg


Insert cable

20200421_230711.jpg


Add heat shrink

20200421_190838.jpg


Finally did something about the alternator fuse that kind of just floated around between the battery and the coil.

20200421_212646.jpg


The cap for the 98 prop valve came in today. Got the o ring GB swapped over and the thing installed.

20200421_212637.jpg


Picked up some caliper paint to paint these Cobra front and rear calipers. I was going to paint them something other than red but the are 04 calipers and came red from the factory. They will probably get changed over the winter for ATS fronts and taurus rears. I think I can live with the red for a little while.

I went to price a self starting torch and they want way too much. Just a cylinder of MAP gas was 14 bucks. They wanted almost 50 bucks just for a self lighting torch head. Guess I'll keep my flash pan...and a co UK please lighters laying around. There's no way I can justify spending that on a click button torch head.
 

CarMichael Angelo

clearly, I’ve got something going on in that hole
SN Certified Technician
Nov 29, 1999
12,487
13,609
234
62
Birmingham, al
m.imdb.com
This whole working on the car thing always turns into more stuff.

Had some fun with some battery cable ends.

Add some solder



Insert cable



Add heat shrink

20200421_190838.jpg


Finally did something about the alternator fuse that kind of just floated around between the battery and the coil.



The cap for the 98 prop valve came in today. Got the o ring GB swapped over and the thing installed.



Picked up some caliper paint to paint these Cobra front and rear calipers. I was going to paint them something other than red but the are 04 calipers and came red from the factory. They will probably get changed over the winter for ATS fronts and taurus rears. I think I can live with the red for a little while.

I went to price a self starting torch and they want way too much. Just a cylinder of MAP gas was 14 bucks. They wanted almost 50 bucks just for a self lighting torch head. Guess I'll keep my flash pan...and a co UK please lighters laying around. There's no way I can justify spending that on a click button torch head.
I hope you disinfected your battery cable end before you touched it...It came from China after all, and according to the big giant orange head, so did the virus. ;)
 

90sickfox

I didn't really have an issue with the stink...
SN Certified Technician
Mar 2, 2015
5,213
4,284
203
42
I hope you disinfected your battery cable end before you touched it...It came from China after all, and according to the big giant orange head, so did the virus. ;)
I hate that it says CHINA big as day on the flat of the cable ends.

I purified them with the torch.
 

90sickfox

I didn't really have an issue with the stink...
SN Certified Technician
Mar 2, 2015
5,213
4,284
203
42
When I did this half wire tuck I was outside in my driveway. I said I was going to straighten it out so today was the day. All of this from trying to wire in the vacuum pump.

Had help....my 13yr old removed the drivers fender and installed the little triangle mirror covers. The guy did an excellent job.

20200422_111625.jpg


This is the aftermath.

20200422_204522.jpg


What happened was....I got to the harness and had no idea what I was looking at. I had a mysterious green wire that was unplugged from somewhere. Didn't know what it was for or where it went. Traced it and found it was the tach signal wire to my Autometer. Then remembered that I had just stuck it in the ground connector of the coil and never wired it in. That had to change.

Another quest that started as a gingerly walk down wiring and solder road ended up being an all day thing. Rerouted all the wires. They look a little bunched up because the factory wiring and connectors are still there. I refuse to remove any of it. The four added things are the vacuum pump, cooling fans, fog lights, and the line lock. I had no fuse going to the fog light relay...just straight wired. I know I thou thought it was temporary but I must've been drinking something really good.

Everything is now labeled ( green masking tape made into a tab that has what the circuit is on it ) and the fuse holders are color coded to the harnesses they relate to.

White for vacuum pump....blue for the fans...yellow for the fog lights.

20200422_205022.jpg


All the added circuits are on one post of my GM truck power distribution block. The harnesses have been organized, taped, labeled, and secured. Got it all done....except the ignition power wire for the vacuum pump relay. Yup...still gotta do it. All my circuits are ground triggered so no obvious wires behind the fender. I'll find one tomorrow or run the wire into the car and tap in there.

Still didn't bleed the brakes....or paint the calipers. I want to tidy up the rear brake line junction at the IRS. At this rate I'll be done with this sometime this year. :doh:
 
Last edited:

90sickfox

I didn't really have an issue with the stink...
SN Certified Technician
Mar 2, 2015
5,213
4,284
203
42
No pics today ( I'm pulling a Mike ). I got the vacuum pump wired up. It works great. This little endeavor has again raised my OCD level. The wiring is ridiculous under my dash. Stuff is going everywhere. I attempted to route everything the simplest neatest way....but it looks like pure *$$.

Due to the fact that I need to get the brake calipers and bracket painted and rear line redone ( just 'cause it looks wonky ), I'm not digging in to this now. To do it correctly I'd have to remove the drivers seat and lay in there on my back. All those wires need to be labeled, put in a loom, and ran like a real harness. I also need to wire in a fuse box or two. I popped the mini fuse in my multimeter doing an amp draw test a couple months ago. Can't find them in the store so I gotta order a few. Then I can properly size everything and do it the " right " way.
 
  • Like
Reactions: Olivethefet

90sickfox

I didn't really have an issue with the stink...
SN Certified Technician
Mar 2, 2015
5,213
4,284
203
42
Still no pics. For people that follow my build you know I put a subaru forester Gentex gntx ghshl4 12 pin rear view camera mirror in Dusty. I wired it in but the two power leads were wired in to ignition 12v. That kept the garage genie from working ( it needs constant 12v ). There is almost no info on the interwebs about this. Since I was already in the wiring I figured I'd fix it. The blue wire is switched 12v...the gray wire is constant 12v. I can't get a mirror tab to stay on the windshield no matter what I try. It doesn't really matter because I need a new one anyways. This one has a few chips in it.

I don't have pics because the inside of the car looks like a bomb went off. Tomorrow I'm going to pick up a fuse box for the switched 12v source. There's way too much going on under there. I'm going to add a couple constant 12v sources in the box as well. With all the gauges, WB, stereo, ECU, and other stuff going on it's getting crazy.

I had an exhaust leak at the drivers side header to crossover pipe connection. Removed the V band and added some high temp sealant. That's the only connection that I didn't put any on when I put it together. I have no idea why....maybe I forgot.

My neighbor across the street just bought in to the Matco truck business. I spent about 2 hrs on there today. Theres a hydraulic brake line flaring tool that almkst has my name on it. Reminded me of when I was working flat rate and spending my check on the tool trucks. I'm glad he's there though...just in case.

The plan was to fire the car up tomorrow, set the timing, and paint the calipers. The wife has other plans. We're going out of state to take her Dad a present for his 60th birthday. That will take all day. I'll be lucky if I get to stop at a parts store.

We'll see how it all plays out. We were also supposed to go pic up the 49 tomorrow. Guess that's pushed back too. She's in no rush because I'm taking up the garage at the moment. The guy that has the car told me today that he's giving me a spare flat head engine....along with the fresh 360 and a good 727 transmission. The car already has a 8 3/4 rear. He says there should be a disc brake kit available for it. He's really trying to keep me from powering it by Ford.
 

CarMichael Angelo

clearly, I’ve got something going on in that hole
SN Certified Technician
Nov 29, 1999
12,487
13,609
234
62
Birmingham, al
m.imdb.com
Still no pics. For people that follow my build you know I put a subaru forester Gentex gntx ghshl4 12 pin rear view camera mirror in Dusty. I wired it in but the two power leads were wired in to ignition 12v. That kept the garage genie from working ( it needs constant 12v ). There is almost no info on the interwebs about this. Since I was already in the wiring I figured I'd fix it. The blue wire is switched 12v...the gray wire is constant 12v. I can't get a mirror tab to stay on the windshield no matter what I try. It doesn't really matter because I need a new one anyways. This one has a few chips in it.

I don't have pics because the inside of the car looks like a bomb went off. Tomorrow I'm going to pick up a fuse box for the switched 12v source. There's way too much going on under there. I'm going to add a couple constant 12v sources in the box as well. With all the gauges, WB, stereo, ECU, and other stuff going on it's getting crazy.

I had an exhaust leak at the drivers side header to crossover pipe connection. Removed the V band and added some high temp sealant. That's the only connection that I didn't put any on when I put it together. I have no idea why....maybe I forgot.

My neighbor across the street just bought in to the Matco truck business. I spent about 2 hrs on there today. Theres a hydraulic brake line flaring tool that almkst has my name on it. Reminded me of when I was working flat rate and spending my check on the tool trucks. I'm glad he's there though...just in case.

The plan was to fire the car up tomorrow, set the timing, and paint the calipers. The wife has other plans. We're going out of state to take her Dad a present for his 60th birthday. That will take all day. I'll be lucky if I get to stop at a parts store.

We'll see how it all plays out. We were also supposed to go pic up the 49 tomorrow. Guess that's pushed back too. She's in no rush because I'm taking up the garage at the moment. The guy that has the car told me today that he's giving me a spare flat head engine....along with the fresh 360 and a good 727 transmission. The car already has a 8 3/4 rear. He says there should be a disc brake kit available for it. He's really trying to keep me from powering it by Ford.
Think of it this way.
If you’ve ever been to a rod run in the past, EVERY freakin Model A/Deuce cpe that had ever been “ rodded”, had a sorry assed SBC in it. ( And I’m not talking LS). It always griped my ass to think that one of the first cars to ever successfully feature a true v8, and was the “Go To” for power mods, lost that status to Chevrolet, just as soon as 1955 rolled around, and the first SBC started showing up in those cars instead.
One one hand I get it, It was hotrodding. If you could make something way faster with a drivetrain swap, it didn’t take an engineering degree to figure that out.
But these guys are still doing it today. Only now with an LS. ( Which is mind boggling when you consider how good a 4v mod engine looks in one of these cars.)
If you ever intend to go to these shows with that car, consider the make of the thing, and the fact that you can keep the car all Chrysler w/o any additional out of pocket expense to do it. You’ll find that you’ll get less sneers from the purists if it has a 360 under the hood.


* The preceding editorial brought to you by the guy that doesnt just have a different make engine in the car he owns, but has a different make engine from a completely different country ( literally). Any commentary about “ keeping the purists happy” should be immediately disregarded. :rolleyes:
 

droopie85gt

Hookers and Beer for life!
Dec 26, 2016
1,154
821
143
Cordova, TN
Put a late model 5.7 Hemi in it. It will look cool and I think they make carb intakes and ignition controllers for it. Can probably adapt a non computer controlled trans of any make behind it or put a 4L80E (I think Microsquirt can control it now).
 
  • Like
Reactions: 90sickfox

90sickfox

I didn't really have an issue with the stink...
SN Certified Technician
Mar 2, 2015
5,213
4,284
203
42
Think of it this way.
If you’ve ever been to a rod run in the past, EVERY freakin Model A/Deuce cpe that had ever been “ rodded”, had a sorry assed SBC in it. ( And I’m not talking LS). It always griped my ass to think that one of the first cars to ever successfully feature a true v8, and was the “Go To” for power mods, lost that status to Chevrolet, just as soon as 1955 rolled around, and the first SBC started showing up in those cars instead.
One one hand I get it, It was hotrodding. If you could make something way faster with a drivetrain swap, it didn’t take an engineering degree to figure that out.
But these guys are still doing it today. Only now with an LS. ( Which is mind boggling when you consider how good a 4v mod engine looks in one of these cars.)
If you ever intend to go to these shows with that car, consider the make of the thing, and the fact that you can keep the car all Chrysler w/o any additional out of pocket expense to do it. You’ll find that you’ll get less sneers from the purists if it has a 360 under the hood.


* The preceding editorial brought to you by the guy that doesnt just have a different make engine in the car he owns, but has a different make engine from a completely different country ( literally). Any commentary about “ keeping the purists happy” should be immediately disregarded. :rolleyes:
I like keeping things brand specific...but in this case it will cost me more to do a late model v8 swap. That would be more in money, time, and parts. I already have a good 306 that doesn't require nearly as much to get in the 49. I even have an original carbereted cobra intake for it. That will really make folks hate me at the shows and meets. But hey...all publicity is good publicity.

Put a late model 5.7 Hemi in it. It will look cool and I think they make carb intakes and ignition controllers for it. Can probably adapt a non computer controlled trans of any make behind it or put a 4L80E (I think Microsquirt can control it now).
Too expensive. It would take me 5 years to hack the car up enough to get a Mopar v8 in it. I like the idea of the 306...with cobra intake...and " Powered by Ford " valve covers. That way I can give the finger to all the folks that swap 350s in their hot rods.
 

90sickfox

I didn't really have an issue with the stink...
SN Certified Technician
Mar 2, 2015
5,213
4,284
203
42
Yippee !!! Got Dusty running today. Had to call Steve and pluck his nerves. I ended up finding that my IAC valve is bad. I had timing issues and the IAC had the car running at 1600+ rpm. After freaking out I unplugged and plugged it back up, that didn't work...so I banged on it. Sure as $hit the idle came down. I never removed it with the work that was just done. Don't know why it happened but it's running again.

I also did this. Not a huge fan of red brakes. These were originally red before I stripped them ( powder coat was terrible and the aluminum was oxidizing under it ).

Here's a before...

20200425_133950.jpg


Here's the during...

20200425_143510.jpg


There would be an after today but I had to order a new hardware kit. The pins were pitted with rust. $7.62 later and O'Reilly's should have it in store by 11:30 tomorrow. Gives me time to remove and paint the rear.

That's almost it for today. Went on a TP run with the wife ( toilet paper ). We had some but needed more, apparently. That turned into wine slushies.

20200425_165324.jpg


I caught her a prince but she wouldn't kiss'em. Told me to do it...but I ain't kissin' a guy. She lost her ability to ever complain about money again.

20200425_165226.jpg
 

Mstng93SSP

You have a nice rear end there Dave.
15 Year Member
Nov 29, 1999
1,860
2,111
174
Mililani, Hawaii
Glad you got it running and the brakes look great. I just did up a pair I have in red as well. I know red calipers are overplayed but I still think they look. If you need an IAC I will give you one...or two. I literally have 6 or 7 of them. Let me know.

Chris
 

90sickfox

I didn't really have an issue with the stink...
SN Certified Technician
Mar 2, 2015
5,213
4,284
203
42
Glad you got it running and the brakes look great. I just did up a pair I have in red as well. I know red calipers are overplayed but I still think they look. If you need an IAC I will give you one...or two. I literally have 6 or 7 of them. Let me know.

Chris
Thanx man I really appreciate it. I have a few of them myself. I grabbed them off every Ford I found in the yard almost. I even have a couple escort ones.
 
  • Like
Reactions: Mstng93SSP

90sickfox

I didn't really have an issue with the stink...
SN Certified Technician
Mar 2, 2015
5,213
4,284
203
42
Added a 250amp mega fuse to the main battery cable. I went through all types of ideas to do this. Was going to order a mega fuse box like the alternator one, that thing is too big. Then I bought more cable ends to cut the cable and add it behind the fender, that defeated the purpose and put it after the metal it passes through. So...I came up with this. Coulda saved myself 5 bucks...no cable cutting required.

20200426_145905.jpg


Got the calipers mounted and bled the brakes with my mighty vac. Haven't started the car yet. Pedal travel feels a little weird. There are no leaks but feels like air is still somewhere in there. I'll find out tomorrow.

20200426_211840.jpg


20200426_211824.jpg


Tried to paint the " Cobra " script with some touch up paint I have for the 19....yeah don't try that. It had a bad reaction with the caliper paint and wrinkled the " C " up. Luckily, I was still in the process of doing that first letter. I wiped it off, red paint too. When the paint fully cures I'll sand the red off the top of all the letters and see how the bare aluminum letters look. If I like it I'll clear them and call it a day....if not then I'll paint them black with different paint that's the same ceramic paint as the caliper paint.

Jeeesh I'm tired...time to go to bed.
 

pats91

Active Member
Mar 6, 2007
79
46
38
46
Gladstone, MO
What did that battery terminal come off of? I could use something like that on my car to get a few terminals off of my starter solenoid.

When I painted my cobra calipers, I did just what you are talking about on the lettering. I think makes a good contract between the black calipers and the aluminum colored letters.
 
  • Like
Reactions: 90sickfox
Thread starter Similar threads Forum Replies Date
90sickfox DUSTY'S New Start After Intake Replacement Digital Self-tuning Forum 3
T Dusty engine bay 2005 - 2014 S-197 Mustang -General/Talk- 13
N Bought a unfinished 5.4 dohc into 97 gt project. I)ve got lots of questions. The Welcome Wagon 2
C Hi guys i just got a 2003 mustang gt 4.6 how do check kow it the car has pi heads SN95 4.6L Mustang Tech 6
M Progress Thread .351 roller, cam bearing cracks, I've got em #2 & #4 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 1
C Just got a 1990 lx notchback. I need help please 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 10
DudeStang Progress Thread Finally got my first Fox Body - 1988 GT 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 323
Twitch'n Twitcht4life My P.M.S. got stolen from my car. Hey 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 1
mattbaker302 Gots me a 351 Cleveland 1965 - 1973 Classic Mustangs -General/Talk- 12
R Have I got two faults SN95 V6 Mustang Tech 28
J Electrical finally got my head lights SN95 4.6L Mustang Tech 0
joetrainer31 Progress Thread Got Another One! Pics Fox 5.0 Mustang Tech 90
79 Fox Fox Got a problem... What is going on? 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 7
79 Fox Fox Finally got my Fox running! 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 0
S Engine Got a 93 mustang gt overheat on idle Fox 5.0 Mustang Tech 2
1970machwon Engine A couple MAF questions (Finally got my donor engine!) Fox 5.0 Mustang Tech 6
RangerJoe Fox New PB, finally got into the 10's! 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 20
C Finally got this horse to pass NJ inspection !!! SN95 4.6L Mustang Tech 3
J Cheap fix for front bumper that broke off when I got the car stuck in a ditch. 2015+ (S550) Mustang -General/Talk 4
R 04 GT. JUST GOT IT. The Welcome Wagon 1
C Engine 88 got oil question Fox 5.0 Mustang Tech 11
CarMichael Angelo Well, I just got poked in the heart... 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 18
R Please Help has anyone got image of wires The Welcome Wagon 0
John Dirks Jr What you got? 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 6
W Hi All, Just got a 2002 mustang. It has 16 inch wheels and tires on it. Thinking about buying 18x9 front and 18x10 rear, any advice? 1996 - 2004 SN95 Mustang -General/Talk- 2
8 Just got my 2nd fox!! The Welcome Wagon 3
tessatrolo Got a wiring problem SN guys please help! 1996 - 2004 SN95 Mustang -General/Talk- 0
TNAVY Finally got a Cobra (my dream car!) The Welcome Wagon 1
C Hello from Texas. I am an old Street Rod builder who got serious about Mustangs years ago. The Welcome Wagon 5
R Finally Got to Mustang Week 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 1
mpeach1976 I got popped by police for my exhaust 2005 - 2014 S-197 Mustang -General/Talk- 2
J Engine 1994 GT not sure what I got here ... SN95 4.6L Mustang Tech 1
H 1986 got some turbo questions. 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 5
S After 20 years, I got my Mustang. The Welcome Wagon 1
S Just got 18 GT. Ambient Light/ Primary/ Secondary color settings do not save when turned off. 2015+ (S550) Mustang -General/Talk 5
Steel1 Got myself a Fathers Day present 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 3
Z Just got stanged 2005 - 2014 S-197 Mustang -General/Talk- 1
65-Fstbk Rebuilt the 5.0 but it's got an oil leak 1965 - 1973 Classic Mustangs -General/Talk- 6
G Paint and Body Spring is finally here and got the car cleaned up. 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 2
Justin Fetalvero Just Got A Free 1994 Mustang V6! The Welcome Wagon 3
Mustang Yawie Wow, It’s Been A While But Finally Got A Mustang Back 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 6
E Just Got A 74 Mach1 1974 - 1978 Mustang II Talk & Tech 11
FastDriver Finally Got To Drive A '16 Gt 2015+ (S550) Mustang -General/Talk 14
Chythar Interior and Upholstery Got Myself An Early Xmas Gift 1994 - 1995 Specific Tech 7
B I Think I Got Ripped Off Need Help! 1996 - 2004 SN95 Mustang -General/Talk- 4
IIGood Think I'm About To Go Broke...got A Polisher Mustang Sound & Shine All 0
Street Renegade Finally Got Headers And A Tune 2015+ (S550) Mustang -General/Talk 2
Davedacarpainter Who's Got The Best Eclipse View? 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 25
mikestang63 Got The Latest Mm&ff Fox 5.0 Mustang Tech 3
9 How Warped Is This Cylinder Head? (just Got "resurfaced") 1996 - 2004 SN95 Mustang -General/Talk- 3
Similar threads