Lost oil in my 2001 Mustang Bullitt 4.6

Bullitt4248

New Member
May 22, 2021
6
0
1
67
Lancaster, NY
I went to a "Pinto Stampede" in Detroit last week ! As I coasted off the on ramp - the engine shut down. No over heating - no knock or bangs - just shut down. I coasted to the side of the road - turned the key and nothing at all happened ! It was locked solid so we trailered it the rest of the way.
There was oil all over the drivers side from the front wheel well back. The hose from the dual oil filter in side had a hole rubbed in it from the tire/rim rubbing it.
We let it sit - removed the dual canisters (both full of oil) - removed oil lines (also had oil in them ! Replaced stock single filter and replaced oil - it started up with a scraping sound and what sounded like lifter knock. As the oil filled the engine it sounded better/quieter.
We shut it down - two hours later put in some motor honey and started it again - it slowly returned to sounding "normal".
Trailered it back to Buffalo NY and now here I sit ! Is there a chance no major damage was done ? Whats a logical next step - ? Never happened before - 2001 factory Bullitt - 38 thousand miles on drive train. Thanks for any suggestions - anyone know a good 4.6 mechanic in the Buffalo NY area ?

Thanks
Bullitt4248 :cry:
 
  • Sponsors(?)


HemiRick

I'd be looking at jacking under the house
Jun 28, 2020
764
288
73
58
Memphis TN
Damage was done for sure....start it and run it, the sounds it makes or doen't make will tell the tale. Tells us what it does now.
 

Bullitt4248

New Member
May 22, 2021
6
0
1
67
Lancaster, NY
It sounds as it always did - I drove it about 3 miles and it sounds OK ! Thats the part that gets me - after all the noise - i put 10W40 in and some motor honey and it sounds normal.
What kind of tests will tell if I damaged it ?

- I will most likely have it pulled out and checked for bearing damage.

I dont want to drive around waiting to throw a rod or worse !