Marcelo tuning adventure

marcelo

Active Member
Feb 25, 2018
127
18
28
58
Quepos, Costa Rica, Central America
all done.. tubular upper and lowers poly bushings, Trick Springs, Air bag in right spring, Stange shocks .. its just doing the hop with track bite..but it was very hot yesterday and tire pressure raised from 14 cold to 18 hot..
 
  • Sponsors(?)


marcelo

Active Member
Feb 25, 2018
127
18
28
58
Quepos, Costa Rica, Central America
october and done something ..went back to my 331 Nitrous engine with flat tops but 64 cc chamber heads and less comp rate ..has a TF stage 1 cam. just in since 3 Days ..have a little idle hunt when cold but when warm engine runs stable ...still needs to be adjusted ..had no chance to drive due to the heavy rains for the last days here in Costa Rica ..but next sunday ill try to go to a 1/4 mile event and also using a little Nitrous to Test.... here my tables maybe you have some ideas to improove ??!.. never drove with this, just sitting idle and reving up a bit.... I have seen the spark tables here and some are very agressive ..should i go higher at lower Rpm?
 

Attachments

a91what

SendMeUrDataLog
Mod Dude
Apr 6, 2011
9,311
5,500
204
30
Hillsborough county
Sorry I never got the post above for the nitrous tuning.

The timing tables you see from any tunes I post (or alter) are not that aggressive, all the timing you see that's very high is in the cruise range of the tune. I used a factory ignition map and altered it to suit a modified engine with a slightly more aggressive cam profile and 9-10:1 comp.

I have to say I dont agree with your AFR or IGN tables... I can PM you something that will work much better IMO. I dont want to see your car go boom when you lay the nitrous on.
 

marcelo

Active Member
Feb 25, 2018
127
18
28
58
Quepos, Costa Rica, Central America
perfect
as I said ..never drove like this just sitting and mostly Ideling..any help is welcome..!! my max Nitrous will be around 100 extra ..thanks ..the other thing is ..I have to go to Inspection and the Gas settings are very strictly here!! they messure at idle speed and 2500 rpm also Lamda has to be at 1.0..right now I have an Exhaust system with 4 cats and 2" tubes...after inspecton I change Exhaust to a no Cats 2.5 " H-Pipe... but right now i run the "Cat Version" thanks
 

a91what

SendMeUrDataLog
Mod Dude
Apr 6, 2011
9,311
5,500
204
30
Hillsborough county
oh... well thats going to be tricky... do they do a visual inspection for the factory smog equipment??? is the EGR still hooked up??
 

a91what

SendMeUrDataLog
Mod Dude
Apr 6, 2011
9,311
5,500
204
30
Hillsborough county
lambada 1.15 is almost 17AFR!!!! thats super lean. assuming that the fuel is not cut with e85... now you can change the fuel tables in TS to reflect lambda if that works better for you. I can show you how to do that, you will need your wideband to read lambda as well
 

marcelo

Active Member
Feb 25, 2018
127
18
28
58
Quepos, Costa Rica, Central America
yes very lean.. but now with MS it should be easy to ajust close to 1.0 .... i think a Spread from 0.95 to 1.05 is accepted ..they change rules every Year ... thanks for your tables.. need to try it out ...
 

a91what

SendMeUrDataLog
Mod Dude
Apr 6, 2011
9,311
5,500
204
30
Hillsborough county
OK so what is the cold idle AFR? it will not idle lean cold. what idle algorithm are you using? Closed loop or Warmup?? any idle advance? does the MAP signal wonder up and down? all of these things will have an solution to them.
 

marcelo

Active Member
Feb 25, 2018
127
18
28
58
Quepos, Costa Rica, Central America
good day !!! set the cold timing advance a little higher and adjusted the VE table a bit and now cold Idle is stable like a rock at 1000 rpm..... ok here its never "cold" the coldest here is like 24- 25deg Celsius (77 Fahrenheit) ..never had cooler temps here in 18 years ...
 

marcelo

Active Member
Feb 25, 2018
127
18
28
58
Quepos, Costa Rica, Central America
yesterday went to the Race Track ..public Drag Races ..150km one way and no problems so far ... when staging at Light.. on the Brakes reving up to 2400 (converter Stall ) then loosing brakes and Pedal to the Floor ... and this happens .... when recovered RPMs engine revs up nice without any problems ....never did this befor and I have no clue why this happens ...??? any Ideas ???
 

Attachments