Engine '02 GT - Poor Accel in Closed Loop

DoHxBoY

New Member
Mar 25, 2021
3
0
1
33
Florida
Hey all,

Posted prior about some issues but no dice, here is an update as I further try to figure out what the issue is.

Again, no DTC or CEL have ever occurres.

I noticed that my accelleration and bogging issues occurred after warm up, thus in Closed Loop.. after reading some other experiences with this possibly being caused by bad O2s or clogged cats, I decided to pull the O2 sensors and see how it goes.

The car def runs richer for a bit on start up and at times (you can smell it), but it overall seems the performance is better forcing it to remain OL this way.

Oddly, I still have not had any CEL or DTC show up, even with all 4 (2 up, 2 down) O2 sensors disconnected. It's been about 3 or 4 drive cycles and a total of 15 miles so far.

Another thing I noticed is that with the O2 sensors disconnected and the car forced into an Open Loop, the EGR valve stays closed too..

So, My question is now, what is the culprit robbing my performance in closed loop?

Could my O2 sensors be bad?
Clogged cats?
EGR causing issues in CL?

How should I proceed from here?
 
  • Sponsors(?)


McFly2

Member
Nov 21, 2020
68
10
18
64
Cincinnati
Im thinking............closed-loop system has the ability to self-correct while the open-loop system doesn't; meaning that none of your sensors are read by the PCM in open loop. Once in closed loop your computer is adjusting for all the inputs it receives after warm up. I would suggest a OBD2 scanner for $35 to read your fuel trims: fuel pressure, MAF, o2 sensor voltages etc. Fuel trims should be checked at idle and at 2500 rpm. You then can check for codes and reset as needed. If you cant interpret OBD2 readings, you will have to learn or pay for a diagnosis via shop scanner for $100.
I educated my self on scanner fuel trims etc. You can get scanner and take photos or (video) of your scanner live data and post here for interpretation. It might sound like a lot. - Start with o2 sensor voltages and work your way through the live data. You just plug scanner in and get live data while engine running and look at scanner screen. The data will indicate if you have bad o2 sensor voltages (should fluctuate between .1 - .9 volts each. Fuel trim live data can be interpreted to indicate if you have a rich or lean conditions on bank 1 or 2. That will narrow down your issue. Fuel trim % at live data can indicate vacuum or exhaust leaks on bank one or 2 or both. ----------
-------- I have seen IAC cause intermittent lean conditions / that will cause you PCM to adjust fuel trims to add fuel [ you will then smell fuel ( that is a cheap and easy part to change) to get that possibility off the list. Your problem might not send a code for 100 miles or 500 miles depending how severe your problem is. Check your check engine light at start up to make sure you CIL is working.

Amazon productView: https://www.amazon.com/thinkcar-THINKOBD-Functions-Readiness-Retrieve/dp/B08G15N9SD/ref=asc_df_B08G15N9SD/?tag=hyprod-20&linkCode=df0&hvadid=459657529872&hvpos=&hvnetw=g&hvrand=7591678168974843221&hvpone=&hvptwo=&hvqmt=&hvdev=c&hvdvcmdl=&hvlocint=&hvlocphy=9015635&hvtargid=pla-960204598006&psc=1