2012 electrical problems

Pintostang

Member
Oct 18, 2020
2
2
13
36
Western NC
I recently acquired a 2012 v6 and have been having some electrical issues. First,
No brake lights, Hazards, parking lights and turn signals work but no brake lights. New brake light switch, all fuses check out.

Second there is no heat/ac and cooling fan won't turn on, again, all fuses and relays are good. Whoever owned the car before me had bypassed the cooling fan relays and had it hotwired to an empty fuse block, running into the ac compressor. Everything worked but the ac compressor and cooling fan was always running, even with the heat full blast. After undoing all that I see why they ran it like that, you can fiddle with the climate control , the lights come on but no blower motor and the compressor/cooling fan will not cycle on when you press ac or max ac. This whole thing has me stumped.

Are these cars prone to the dreaded smart junction box problem the 05-09 has? I checked it but no signs of corrosion. Thanks in advance for any help you can give.
 
Last edited:
  • Sponsors(?)


Pintostang

Member
Oct 18, 2020
2
2
13
36
Western NC
For future reference in case anyone else ever has strange electrical problems like mine, like brake lights, ac,power steering and traction control issues etc.

Check your wiring harness that runs underneath the driver side fender well. It apparently l dropped down a little and the front tire had worn through on tight turns. Spliced the wires back together and zip tied the harness back up and she runs like a champ.
 
  • Like
Reactions: 1 users