Forced Induction Goodies...

  • Sponsors(?)


usaf_branham

10 Year Member
Oct 30, 2008
925
134
74
Vegas
Almost. It was getting as low as 300. Throttle input didn't have any effect on it. I tried reloading the tunes twice, tried it with AC on and off, tried restarting. No luck... Load the baseline tune and it fires right up like stock. I dunno.


Sent from my iPhone using Tapatalk
 

usaf_branham

10 Year Member
Oct 30, 2008
925
134
74
Vegas
Yeah. I just loaded another revision and it fired right up. I guess something got messed up on his end with the second two revisions.


Sent from my iPhone using Tapatalk
 
  • Like
Reactions: 15GTrob

15GTrob

Advanced Member
Aug 23, 2015
450
124
73
34
Lol is that the in he driveway revs where you hold rpm for like 15 seconds?
 

usaf_branham

10 Year Member
Oct 30, 2008
925
134
74
Vegas
Sure is. Between the exhaust and the race valve, I had to plug my ears. Lol


Sent from my iPhone using Tapatalk
 

15GTrob

Advanced Member
Aug 23, 2015
450
124
73
34
Yeah that race valve screams wait till your perched up around 75-80 on the interstate. :)
 

15GTrob

Advanced Member
Aug 23, 2015
450
124
73
34
Lol an amazing feeling. I haven't drove mine in a couple weeks. Took her out for a little test drive after tightening axle bolts. It impresses me every time. 3rd and 4th pull stupid hard. Lund has an add on for the n gauge that shows boost.
 

usaf_branham

10 Year Member
Oct 30, 2008
925
134
74
Vegas
That's probably what I'm going to do since I don't see any feasible places to put a gauge.


Sent from my iPhone using Tapatalk