Fuel New fuel pump = low pressure

Espo720

Member
May 4, 2016
55
3
8
Alright guys, I’m looking for some ideas to throw at this issue. When I got this car car in the fall before the snow flew, I’d have to cycle the key several times to get the car to start. Classic fuel pump death no?
This spring I took it out of storage to mess with, drove nicely but still needed to build pressure. I dropped the tank after the car died down the road from my house, found the baffle was bouncing around. Picked up a new tank for $50 local, new walbro 155 pump kit, sending unit and filler neck seal. Got it all back together and it has :poo: for fuel pressure.

It will eventually start and idle roughly if you crank long enough, but then it dies. Pressure at the rail is piss poor and you don’t hear the pump come to a typical whining stop when you cycle the key, just a smooth sound as if it hasn’t built up to a threshold. I’ve followed JRichker’s lists, everything electrical checks out, new filter going in today but I have my doubts. FPR doesn’t seem to piss gas out of the vacuum line, but I also can’t keep it running long enough to really check it. Hoping a brand new walbro pump isn’t shot, never had an issue with their pumps before...

Any ideas???
 
  • Sponsors (?)


Espo720

Member
May 4, 2016
55
3
8
Did the fuel pump kit come with a new S hose? They are prone to splitting and causing this type of issue.
Yep took it all back apart today and double check things, also changed the fuel filter. Definitely better flow at the rail but it’s not holding pressure. I’m able to hear gurgling at the fuel rail, so my suspect is the regulator. The car started right up when I put the new pump in, but died after a few minutes. I’m thinking the pressure from a fresh pump vs. the 30 yr old regulator may have won a battle.
 

jrichker

StangNet's favorite TOOL
In Remembrance. Thank you for your contributions
Mar 10, 2000
27,513
2,853
234
Alright guys, I’m looking for some ideas to throw at this issue. When I got this car car in the fall before the snow flew, I’d have to cycle the key several times to get the car to start. Classic fuel pump death no?
This spring I took it out of storage to mess with, drove nicely but still needed to build pressure. I dropped the tank after the car died down the road from my house, found the baffle was bouncing around. Picked up a new tank for $50 local, new walbro 155 pump kit, sending unit and filler neck seal. Got it all back together and it has :poo: for fuel pressure.

It will eventually start and idle roughly if you crank long enough, but then it dies. Pressure at the rail is piss poor and you don’t hear the pump come to a typical whining stop when you cycle the key, just a smooth sound as if it hasn’t built up to a threshold. I’ve followed JRichker’s lists, everything electrical checks out, new filter going in today but I have my doubts. FPR doesn’t seem to piss gas out of the vacuum line, but I also can’t keep it running long enough to really check it. Hoping a brand new walbro pump isn’t shot, never had an issue with their pumps before...

Any ideas???
Fuel pump pressure & regulator test

Check fuel pressure:


The local auto parts store may rent or loan a fuel pressure test gauge if you don't have one.

Disconnect the vacuum line from the fuel pressure regulator. Check it for evidence of fuel present in the line by removing it and blowing air through it. If you find fuel, the fuel pressure regulator has failed. Reinstall the line; leave the fuel pressure regulator end of the vacuum line disconnected. Then cap or plug the open end of the vacuum line and stow it out of the way.

Connect the fuel pressure test gauge to the Schrader port located just behind the alternator.

Turn the ignition switch on & start the engine. Observe the pressure: you should see 37-41 PSI at idle.

Turn the ignition off; reconnect the vacuum line to the fuel pressure regulator. Then disconnect the fuel pressure test gauge. Watch out for squirting gas when you do this.

Fuel pump pressure test

Disconnect the larger of the two fuel lines up by the Schrader valve. It is the return line and does not have the Schrader valve on it. Find a piece of rubber fuel hose and clamp it on the return line coming from the regulator. Stick a bolt in the other end of the hose and make sure that all your connections are tight and leak proof as possible. When this powers up, you don't want fuel squirting everywhere. Hook up the fuel pressure test gauge. Turn the ignition switch on and watch for leaks. You may want to use a helper inside the car to cut the switch off quickly if you have a leak. To trick the fuel pump into running, find the EEC test connector and jump the connector in the Upper RH corner to ground.

attachments\68357


Caution!!! You have blocked the return line for the fuel pump! Pressure will rise very quickly past safe levels with a good pump

If the pressure goes up past 55 PSI, the pump is good and the fuel pressure regulator is bad. If the fuel pressure does not hit 55 PSI or more in a few seconds, the pump is bad or you have electrical problems.
 
  • Like
  • Useful
Reactions: 1 users

Espo720

Member
May 4, 2016
55
3
8
Alright. Hadda chunk of time to chase this down. I had new valve cover gaskets to install so I snagged a new Walker FPR to swap in. At first pressure was bleeding down almost instantly with key on. I clamped the return line to check if pressure held and it shot to 90 psi then held steady at 39 psi.

I unclamped the return line thinking pressure would drop... it held steady. Released pressure on my gauge and had my helper turn the key on, pressure went right to 40 or so and held fine. No start though.

I checked spark from the coil to the cap and cap to plugs, all good.

Backing up a bit to when we first got the car, I had to cycle the key a few times for it to start quickly, Otherwise it’d take a while. Also, my helper pointed out that the rpm gauge goes nuts when she turns the key... if I remember right, that’s a TFI issue no?

I don’t mind changing out 31 year old parts for fresh stuff that won’t leave me stranded, but I’m beginning to think I’m bouncing all over the place here.
 

Espo720

Member
May 4, 2016
55
3
8
Popped the distributor open and its like brand new inside. The distributor, cap, rotor and wires were done by previous owner before I got the car.

Tried starting the car with ether and it wouldn’t even pop, fuel pressure is holding perfect as well now.
 

jrichker

StangNet's favorite TOOL
In Remembrance. Thank you for your contributions
Mar 10, 2000
27,513
2,853
234
Popped the distributor open and its like brand new inside. The distributor, cap, rotor and wires were done by previous owner before I got the car.

Tried starting the car with ether and it wouldn’t even pop, fuel pressure is holding perfect as well now.
It’s Decision Tree time:

No spark = go to step #1 & 2.
Good spark - what is a good spark can be a subjective judgment. If you have any doubts, borrow a known good coil from another pre 1996 Ford.
If you do have good spark = go to step # 3

Engine fires off and then dies = go to step # 4
Make sure that you have fuel pressure when the engine fires off. Leave the fuel pressure gauge connected while testing so that you can observe what the fuel pressure is doing.

Fuel pressure OK while cranking
Go to step # 5
Be sure to use a noid light to see if the injectors are pulsing. Use the most accessible fuel injector connector for the noid test.

Noid light pulses and fuel pressure is good.
Go to step #6


Cranks OK, but No Start Checklist for Fuel Injected 5.0 Mustangs model years 1986-1995

A word about this checklist before you start: it is arranged in a specific order to put the most likely failure items first. That will save you time, energy and money. Start at the top of the list and work your way down. Jumping around will possibly cause you to miss just what you need to see to find and fix the problem. Don’t skip any steps because the next step depends on the last step working correctly.

Revised 27-Oct-2020 to add need for good PIP signal to keep the fuel pump running after initial 1-3 second prime.

All text applies to all models unless stated otherwise.

Note: 94-95 specific changes are in red

1.) Remove push on connector (small red/blue wire) from starter solenoid and turn ignition switch to the Run position. Place car in neutral or Park and set the parking brake. Remove the coil wire from distributor & and hold it 3/8” away from the engine block. Jumper the screw to the big bolt on the starter solenoid that has the battery wire connected to it. You should get a nice fat blue spark.

Most of the items are electrical in nature, so a test light, or even better, a voltmeter, is helpful to be sure they have power to them.

No spark, possible failed items in order of their probability:
A.) MSD, Crane, or other ignition box if present - Bypass it and return to stock configuration if possible. Do this as a temporary measure to eliminate it as a possible problem source.
B.) PIP sensor in distributor. The PIP sensor supplies the timing pulse to trigger the TFI, fuel pump, and injectors. The computer looks for a continuous stream of PIP pulses to keep the fuel pump constantly running. A failing PIP sensor will sometimes let the engine start if the SPOUT is removed. See paragraph 5A – Using a noid light will tell if the PIP is working by flashing when the engine is cranking.
C.) TFI module: use a test light to check the TFI module. Place one lead of the test light on the red/green wire on the ignition coil connector and the other lead on the dark green/yellow wire on the ignition coil connector. If the TFI is working properly, the test light will flash when the engine is cranked using the ignition switch.
D.) Coil
E.) No EEC or computer power - EEC or computer relay failure
86-93 models only: EEC relay next to computer - look for 12 volts at the fuel injector red wires.
94-95 models only: EEC or PCM power relay in the constant control relay module. Look for 12 volts at the fuel injector red wires.
Both 86-93 and 94-95 models: No 12 volts with the ignition switch in the run position on the fuel injector red wires. The relay has failed or there is no power coming from the ignition switch. Make sure that there is 12 volts on the red/green wire on the coil before replacing the relay.
F.) No EEC or computer power - fuse or fuse link failure
86-93 models only: Fuse links in wiring harness - look for 12 volts at the fuel injector red wires. All the fuse links live in a bundle up near the starter solenoid. Look for a 20 gauge blue fuse link connected to 2 black/orange 14 gauge wires.
94-95 models only: 20 amp EEC fuse in the engine compartment fuse box. Look for 12 volts at the fuel injector red wires.
G.) Ignition switch - look for 12 volts at the ignition coil red/lt green wire. No 12 volts, blown fuse link or faulty ignition switch. Remove the plastic from around the ignition switch and look for 12 volts on the red/green wire on the ignition switch with it in the Run position. No 12 volts and the ignition switch is faulty. If 12 volts is present in the Run position at the ignition switch but not at the coil, then the fuse or fuse link is blown.
Note: fuses or fuse links blow for a reason. Don’t replace either a fuse or fuse link with one with a larger rating than stock. Doing so invites an electrical fire.
Ignition fuse links may be replaced with an inline fuse holder and 5 amp fuse for troubleshooting purposes.
94-95 models only: Check inside fuse panel for fuse #18 blown – 20 amp fuse
H.) Missing or loose computer power ground. The computer has its own dedicated power ground that comes off the ground pigtail on the battery ground wire. Due to it's proximity to the battery, it may become corroded by acid fumes from the battery.
In 86-90 model cars, it is a black cylinder about 2 1/2" long by 1" diameter with a black/lt green wire.
In 91-95 model cars it is a black cylinder about 2 1/2" long by 1" diameter with a black/white wire.
You'll find it up next to the starter solenoid where the wire goes into the wiring harness
I.) Computer. Don’t replace the computer just because you don’t understand how it works. Computers seldom fail, it usually is a sensor or wiring problem that causes the problems.
J.) Bad or missing secondary power ground. It is located between the back of the intake manifold and the driver's side firewall. It supplies ground for the alternator, A/C compressor clutch and other electrical accessories such as the gauges.
K.) Engine fires briefly, but dies immediately when the key is released to the Run position. Crank the engine & when it fires off, pull the small push on connector (red/blue wire) off the starter relay (Looks like it is stuck on a screw). Hold the switch in the crank position: if it continues to run there is a problem with either the ignition switch or TFI module. Check for 12 volts at the red/green wire on the coil with the switch in the Run position. Good 12 volts, then replace the TFI.
See the Ignition switch wiring diagram for more information on the ignition wiring fuse link because it is the next thing to be tested. You will need a Multimeter or DVM and know how to use the Ohms function to check continuity between the red/green wire on the ignition coil and the red/green wire on the ignition switch. Make sure that the ignition switch is in the off position when you do the check. You should see less than 1 Ω (Ohm) between the red/green wire on the coil and the red/green wire on the ignition switch. More than 1 Ω means that the fuse link may have blown open and needs to be replaced. If you get 1 Ω or less means the fuse link is OK and the ignition switch is bad.

Wiring Diagrams:
See the following website for some help from Tmoss (diagram designer) & Stang&2Birds (website host) for help on 88-95 wiring Mustang FAQ - Engine Information Everyone should bookmark this site.


Ignition switch wiring
http://www.veryuseful.com/mustang/tech/engine/images/IgnitionSwitchWiring.gif

Fuel, alternator, A/C and ignition wiring
http://www.veryuseful.com/mustang/tech/engine/images/fuel-alt-links-ign-ac.gif

Complete computer, actuator & sensor wiring diagram for 88-91 Mass Air Mustangs
http://www.veryuseful.com/mustang/tech/engine/images/88-91_5.0_EEC_Wiring_Diagram.gif

Complete computer, actuator & sensor wiring diagram for 91-93 Mass Air Mustangs
http://www.veryuseful.com/mustang/tech/engine/images/91-93_5.0_EEC_Wiring_Diagram.gif

Complete computer, actuator & sensor wiring diagram for 94-95 Mass Air Mustangs
http://www.veryuseful.com/mustang/tech/engine/images/94-95_5.0_EEC_Wiring_Diagram.gif

AutoZone wiring diagrams: You can navigate to the diagrams yourself via Repair Info | AutoZone.com and select the car year, make, model and engine. That will enable you to bring up the wiring diagram for your particular car.

2.) Spark at coil wire, pull #1 plug wire off at the spark plug and check to see spark. No spark, possible failed items in order of their probability: [/b]
A.) Moisture inside distributor – remove cap, dry off & spray with WD40
B.) Distributor cap
C.) Rotor
D.) Spark Plug wires
E.) Coil weak or intermittent - you should see 3/8" fat blue spark with a good coil

3.) Spark at spark plug, but no start.
Next, get a can of starting fluid (ether) from your local auto parts store: costs a $1.30 or so. Then pull the air duct off at the throttle body elbow, open the throttle, and spray the ether in it. Reconnect the air duct and try to start the car. Do not try to start the car without reconnecting the air duct.

Two reasons:
1.) If it backfires, the chance for a serious fire is increased.
2.) On Mass Air cars, the computer needs to measure the MAF flow once the engine starts.

If it starts then, you have a fuel management issue. Continue the checklist with emphasis of fuel related items that follow. If it doesn’t, then it is a computer or timing issue: see Step 4.

Clue – listen for the fuel pump to prime when you first turn the ignition switch on. It should run for 2-4 seconds and shut off. To trick the fuel pump into running, find the EEC test connector and jump the connector in the Upper RH corner to ground. The EEC connector is near the wiper motor and LH hood hinge.

attachments\68357


If the relay & inertia switch are OK, you will have power to the pump. Check fuel pressure – remove the cap from the Schrader valve behind the alternator and depress the core. Fuel should squirt out, catch it in a rag. Beware of fire hazard when you do this. In a pinch, you can use a tire pressure gauge to measure the fuel pressure. It may not be completely accurate, but you will have some clue as to how much pressure you have. If you have any doubts about having sufficient fuel flow/pressure, rent a fuel pressure test gauge from the auto parts store. That will tell you for sure if you have adequate fuel pressure.

4.) No fuel pressure, possible failed items in order of their probability:

A.) Tripped inertia switch – Coupe & hatch cars hide it under the plastic trim covering the driver's side taillight. Use the voltmeter or test light to make sure you have power to both sides of the switch
B.) Fuel pump power relay – located under the driver’s seat in most stangs built before 92. On 92 and later model cars it is located below the Mass Air Flow meter. Look for 12 volts at the Pink/Black wire on the fuel pump relay.
C.) Clogged fuel filter
D.) Failed fuel pump

E.) 86-90 models only: Blown fuse link in wiring harness. Look for 12 volts at the Orange/Lt Blue wire on the fuel pump relay.
91-93 models only Blown fuse link in wiring harness. Look for 12 volts at the Pink/Black wire on the fuel pump relay.

The fuse links for all model years 86-93 live in the wiring harness near the starter solenoid.



64326.gif




94-95 models only: 20 amp fuel pump fuse in the engine compartment fuse box. Look for 12 volts at the Dark green/yellow wire on the constant control relay module.

F.) Engine seem to load up on fuel and may have black smoke at the tailpipe. Fuel pressure regulator failed. Remove the vacuum line from the regulator and inspect for fuel escaping while the pump is running. If fuel is coming out the vacuum port, the regulator has failed. Check the regulator vacuum line for fuel too. Disconnect it from the engine and blow air though it. If you find gas, the regulator has failed.

5.) Fuel pressure OK, the injectors are not firing.
A.) The PIP sensor in the distributor tells the computer when to fire the injectors. A failing PIP sensor will sometimes let the engine start if the SPOUT is removed.
A noid light available from any auto parts store, is one way to test the injector circuit to see if the injectors are firing. The noid light plugs into the fuel injector harness in place of any easily accessible injector. Plug it in and try to start the engine: it will flash if the injector is firing.
I like to use an old injector with compressed air applied to the injector where the fuel rail would normally connect. I hook the whole thing up, apply compressed air to the injector and stick it in a paper cup of soapy water. When the engine cranks with the ignition switch on, if the injector fires, it makes bubbles. Cheap if you have the stuff laying around, and works good too.
B.) Pull an injector wire connector off and look for 12 volts on the red wire when the ignition switch is on.
C.) No power, then look for problems with the 10 pin connecter (salt & pepper shakers at the rear of the upper manifold).

See the graphic for the 10 pin connector circuit layout.
attachments\610738


The injector power pin is the VPWR pin in the black 10 pin connector.

D.) No power and the 10 pin connections are good: look for broken wiring between the orange/black wire on the EEC relay and the red wire for the 10 pin connectors.
E.) TPS voltage exceeds 3.7 volts with the throttle closed. This will shut off the injectors, since the computer uses this strategy to clear a flooded engine. Use a DVM, a pair of safety pins, and probe the black/white and green wires to measure the TPS voltage.

On a 94-95 Mustang, probe the black/white and grey/white wires to measure the TPS voltage.

It should be .5-.1.0 volts with the key on, engine not running. Note that if the black/white wire (signal ground) has a bad connection, you will get some strange readings. Make a second measurement using the battery post as the ground to eliminate any ground problems. If the readings are different by more than 5%, you may have a high resistance condition in the black/white signal ground circuit.

6.) Spark & fuel pressure OK.
A.) Failed IAB or improperly set base idle (no airflow to start engine). Press the throttle ¼ way down and try to start the car. See the "Surging Idle Checklist for help with all your idle/stall problems.
B.) Failed computer (not very likely)
C.) Engine ignition or cam timing off: only likely if the engine has been worked on recently. If you removed the distributor, there is a good probability that you installed it 180 degrees out of time.
D.) Firing order off: HO & 351 use a different firing order from the non HO engines.

HO & 351W 1-3-7-2-6-5-4-8

Non HO 1-5-4-2-6-3-7-8

E.) No start when hot - Press the throttle to the floor & try starting it, if you get this far. If it starts, replace the ECT.

F. ) Engine that has had the heads off or valves adjusted. Do a compression test to make sure the valves are not adjusted too tight. You should have a minimum of 90 PSI on a cold engine.
 
  • Useful
Reactions: 1 user

Ptstew

Member
Sep 21, 2017
33
2
18
Fuel pump pressure & regulator test

Check fuel pressure:


The local auto parts store may rent or loan a fuel pressure test gauge if you don't have one.

Disconnect the vacuum line from the fuel pressure regulator. Check it for evidence of fuel present in the line by removing it and blowing air through it. If you find fuel, the fuel pressure regulator has failed. Reinstall the line; leave the fuel pressure regulator end of the vacuum line disconnected. Then cap or plug the open end of the vacuum line and stow it out of the way.

Connect the fuel pressure test gauge to the Schrader port located just behind the alternator.

Turn the ignition switch on & start the engine. Observe the pressure: you should see 37-41 PSI at idle.

Turn the ignition off; reconnect the vacuum line to the fuel pressure regulator. Then disconnect the fuel pressure test gauge. Watch out for squirting gas when you do this.

Fuel pump pressure test

Disconnect the larger of the two fuel lines up by the Schrader valve. It is the return line and does not have the Schrader valve on it. Find a piece of rubber fuel hose and clamp it on the return line coming from the regulator. Stick a bolt in the other end of the hose and make sure that all your connections are tight and leak proof as possible. When this powers up, you don't want fuel squirting everywhere. Hook up the fuel pressure test gauge. Turn the ignition switch on and watch for leaks. You may want to use a helper inside the car to cut the switch off quickly if you have a leak. To trick the fuel pump into running, find the EEC test connector and jump the connector in the Upper RH corner to ground.

attachments\68357


Caution!!! You have blocked the return line for the fuel pump! Pressure will rise very quickly past safe levels with a good pump

If the pressure goes up past 55 PSI, the pump is good and the fuel pressure regulator is bad. If the fuel pressure does not hit 55 PSI or more in a few seconds, the pump is bad or you have electrical problems.
Just to clarify, if both the pump and regulator are good the pressure reading in this Fuel Pump Pressure Test with the return blocked would go to and stay at 55PSI. Is that right? Thanks.
 

Ptstew

Member
Sep 21, 2017
33
2
18
Yep thats right. I ended up having a bad tfi module on a crappy spectra replacement distributor
Thanks. My issue with 1991 is that engine bogs down at 5500 rpm and won’t rev to 6200 limit. New fuel filter and coil nor switch to spare good ECU make a difference. Next step is to follow Jrichker guide to checking fuel pressure.
 

Espo720

Member
May 4, 2016
55
3
8
Thanks. My issue with 1991 is that engine bogs down at 5500 rpm and won’t rev to 6200 limit. New fuel filter and coil nor switch to spare good ECU make a difference. Next step is to follow Jrichker guide to checking fuel pressure.

Could also be the pip sensor failing in the distributor if my understanding of how it works is correct. @jrichker would be the authority here though
 
  • Agree
Reactions: 1 user

jrichker

StangNet's favorite TOOL
In Remembrance. Thank you for your contributions
Mar 10, 2000
27,513
2,853
234
PIP Sensor functionality, testing and replacement:

Revised 17-Jul-2014 to add check for loose PIP mounting screws

The PIP is a Hall Effect magnetic sensor that triggers the TFI and injectors. There is a shutter wheel alternately covers and uncovers a fixed magnet as it rotates. The change in the magnetic field triggers the sensor. A failing PIP sensor will often set code 14 in the computer. They are often heat sensitive, increasing the failure rate as the temperature increases.

Some simple checks to do before replacing the PIP sensor or distributor:
You will need a Multimeter or DVM with good batteries: test or replace them before you get started.. You may also need some extra 16-18 gauge wire to extend the length of the meter’s test leads.
Visual check first: look for chaffed or damaged wiring and loose connector pins in the TFI harness connector.
Check the PIP mounting screws to see if they are loose.
Check the IDM wiring – dark green/yellow wire from the TFI module to pin 4 on the computer. There is a 22K Ohm resistor in the wiring between the TFI and the computer. Use an ohmmeter to measure the wire resistance from the TFI to the computer. You should see 22,000 ohms +/- 10%.

b]Resistor location: A big thanks to liljoe07 for this information:[/b]

Check over by the brake booster. It’s not in the harness on the TFI, it’s on the main part of the harness over by the plugs that connect to the dash harness. About 6" or so from that, going back toward the EEC.

If I remember right, the resistor is covered in a shrink tubing that is sealed to the wires. So, you won’t be able see any markings. The shrink tubing is labeled though. It's a 22 KΩ, 1/2 watt resistor.

Here is the location.

attachments\532446


Check the PIP wiring - dark blue from the TFI module to pin 56 on the computer. Use an ohmmeter to measure the wire resistance from the TFI to the computer. You should see 0.2-1.5 ohms.
Check the SPOUT wiring – yellow/lt green from the TFI module to pin 36 on the computer. Use an ohmmeter to measure the wire resistance from the TFI to the computer. You should see 0.2-1.5 ohms.
Check the black/orange wire from the TFI module to pin 16 on the computer. Use an ohmmeter to measure the wire resistance from the TFI to the computer. You should see 0.2-1.5 ohms.
Check the red/green wire; it should have a steady 12-13 volts with the ignition switch on and the engine not running.
Check the red/blue wire; it should have a steady 12-13 volts with the ignition switch in Start and the engine not running. Watch out for the fan blades when you do this test, since the engine will be cranking.
If you do not find any chaffed or broken wires, high resistance connections or loose pins in the wiring harness, replace the PIP sensor or the distributor.

The PIP sensor is mounted in the bottom of the distributor under the shutter wheel. In stock Ford distributors, you must press the gear off the distributor shaft to get access to it to replace it.

To remove the gear, first you drive out the roll pin that secures the gear to the shaft. Then you get to press the gear off with a hydraulic press or puller. When you go to press the gear back on, it has to be perfectly lined up with the hole in the gear and shaft. I have been told that the hole for the pin is offset slightly from center and may require some extra examination to get it lined up correctly.

Most guys just end up replacing the distributor with a remanufactured unit for about $75 exchange
PIP problems & diagnostic info
Spark with the SPOUT out, but not with the SPOUT in suggests a PIP problem. The PIP signal level needs to be above 6.5 volts to trigger the computer, but only needs to be 5.75 volts to trigger the TFI module. Hence with a weak PIP signal, you could get spark but no injector pulse. You will need an oscilloscope or graphing DVM to measure the output voltage since it is not a straight DC voltage.
 
Last edited: