charging issues

  1. 1

    2g alternator issues during idle.

    Just recently replaced my 1989 lx 5.0 alternator with a new 75 Amp 2g alternator. Had to crimp in the white wire and two black with range striped wires to the vehicles harness. I've noticed while idling the battery stays around 12v. When accelerating the voltage goes up as if the alternator...
  2. L

    Electrical Need Help

    Simple check spark plugs on a rainy Sunday. Look great for a 101k mile car. Re-gapped and replaced. Start car and my volt meter is now reading just above first white hash mark, normally rides at center or just above center. The only other thing I did related to wiring was clean the grime off of...
  3. R

    5Volts reference putting out 12 volts with key on 18 volts with car on(overcharge)

    I noticed my tps and other sensors like iac and others are giving a 12 volts read on my multimeter with key-on instead of the usual 5 volts it goes as high as 18.5 volts with car on! I'm guessing those ("missing") 5 volts show up eventually when I turn the car on? But wait , how can that be... I...
  4. C

    Electrical Car not recharging !!!!!

    MUSTANG GT 1995 5.0 automatic Yes I’ve seen a lot of similar problems being posted but mine is insane and can not fix the problem!!! This all happened not too long ago as soon as I stopped on the first red light after exiting freeway my car died, before any of this happened I had previously...
  5. 95 mustang gt 5.0

    95 mustang Gt alterntor problems!

    Hello, recently I got into a rear end accident and the engine wise was fine but the body got messed up a little bit it’s been about a month or so and I’ve fixed it up but one of my main problems is the alterntor doesn’t seem to be charging my battery. I’ve checked the fuses and it’s all good and...
  6. PakstinN

    fox body running rough after see 130 amp alternator conversion

    alright so I am having a weird issue I cannot get to the bottom of. A couple of weeks ago, I went to take my mustang on a cruise and as the cruise progressed, the car became almost undriveable, I took it back to my shop and after a few minutes of looking things over, I discovered I had a bad...
  7. THEUNDERCOATER

    Ribbon On Back Of Instrument Cluster?

    hey guys I pulled the dash apart and removed the instrument cluster to check the bulb for my alternator light and the wiring because I've beenchasing a charging problem. The previous owner had just installed an autometer speedometer and had "wedged/cut" it into the existing cluster. When I...