2002 mustang gt. Crank no start new pump

Fastback1014

New Member
Jun 17, 2018
3
0
1
30
Alabama
Ok so I bought a 2002 mustang gt for $200 from a good friend. Wouldn’t start. I test all fuses and switch in trunk no pressure on fuel pressure gauge. Can’t hear pump running so I replaced the pump and filter. And yes filte is going the right way arrow pointing towards the engine. I can run the engine for a second with starting fuel sprayed into air filter. So apark is good. I was then only getting 10 psi. I know it should be around 40 psi. Today I got new battery which was needed anyway now i get nothing no psi can’t hear the pump engage. But now after the battery I think the anti theft is engaging. When I try to click it over it everything dies for about 15 min then I can crank etc.
 
  • Sponsors(?)


wmburns

SN Certified Technician
Aug 14, 2009
5,842
505
194
Houston Texas
I really suspect that you now have a POWER problem from the recent work done on your car. Suggest double checking your work especially the ground wire that runs around the battery.

Here's a recent thread with some information from someone else with a power problem.

https://www.stangnet.com/mustang-forums/threads/2000-gt-pats-issue-no-start.904245/#post-9123054

Here's some more information that may be of help.

1996+ Crank with no start check list
http://www.allfordmustangs.com/forums/4-6l-tech/336452-1997-mustang-wont-ignite.html#2984838

Again. note the part in the check list about checking the ground that goes around the battery towards the radiator core support.

Finally here's some advanced information on how to fully test and find problems in the battery and charging system.

Howto perform charging system voltage drop test
https://www.stangnet.com/mustang-fo...perform-charging-system-voltage-drop-test.56/