CCRM

Rupert1871

New Member
Dec 5, 2019
2
0
1
18
Florida
Hey everyone, I’ve been working on my 93 lx 2.3 for a month now and I’ve been running to a lot of electrical issues. My latest find after replacing my CCRM is that it seems I’m missing prongs from the pigtail connector itself. I don’t hear the BRRR sound from the engine bay that you should hear when you turn the key and the car only cranks. I think that these missing connections might have something to do with it. Any help would be very appreciated.
 

Attachments

  • Sponsors(?)


Reckless_b

Member
Nov 1, 2019
36
3
18
61
South Yorkshire U.K.
When I was having issues with my ccrm (on a 3.8 sn95) I noticed several prongs missing, but that was quite normal as the ccrm didn’t have provision for them they would have been unused, I suspect yours are missing for the same reason
Bill
 

junkyardwarrior

Active Member
Jan 10, 2011
227
43
38
Fox body cars do not have a CCRM.

They have an IRCM, which is a little different.

Missing pins-that could be normal. All the IRCM is, is a PCB with several relays on it....EEC relay, a/c relay, fan relay, etc. Some cars used the same exact IRCM "box" (housing) and connector, but some had HEDF (high speed fan), or EDF only (low speed fan only and no high speed fan), that sort of thing. Thus, some of the IRCM's do not have the relay-and the pin-for that particular feature, so it will be missing from the connector.

If you suspect that maybe a pin or two is broken, look inside the male connector (harness end) with a magnifying glass. Also look closely at the IRCM's pins; down inside the connector. You may spot one that's broken off. Or better yet take the box apart. On the 4 corners there are some little brads that have holes in the centers. You can drill those out and separate the IRCM box, such that you can see inside of it.