Engine Intermittent Drivability Issue Please Help!

ekelt95gt

New Member
Apr 2, 2015
7
0
1
28
Okay so I am the proud owner of a 94 gt, I have owned the car for about three years now and have had the same issue since day one although it has evolved some,here is my isse.. My car drives great in the spring and winter and later half of fall but summer time is a nightmare.. Car runs great until temps hit the 70-80° range and up. Will be running fine stop at a stop light car will idle fine until it all a sudden just starts running very rough, will not excelerate, almost acts starved, and will die soon after. 9 times out of ten after sitting for a minute I can start it right back up still running like crap just reve it a few times and as if a magical switch was flipped it comes right out of it until next red light. On the hottest days of the year it will do this while driving, I also note at this winter when cold starts apoun first take offs it bogs down and some times dies

Any suggestions or helpful hints would be greatly appreciated

(Parts replaced in last two years: dizzy,coil, plugs, wires, cranck case breather, a few vac lines, ect, PCM, fuel pump, fuel filter and a few others I'm forgetting at the moment)

Sorry I wrote a book just desprat for a solution here thanks again!
 
  • Sponsors(?)


ekelt95gt

New Member
Apr 2, 2015
7
0
1
28
Would you be referring to the intake air sensor? This was going to be the next thing I looked into but am getting tired of throwing money at this problem and wanted another opinion
 

ekelt95gt

New Member
Apr 2, 2015
7
0
1
28
Not all of them I plan on running a few new ones to rule them out, the car is mostly stock, I have not done any engine modifications yet and timing is at 12°, no tunes, and I run 92 octane
 

ekelt95gt

New Member
Apr 2, 2015
7
0
1
28
Yeah I will be installing a new IAT sensor and connector, as well as checking the rest of the grounds sometime this week and see if that helps
 

ekelt95gt

New Member
Apr 2, 2015
7
0
1
28
Changed IAT sensor and there is a slightly noticeable difference but did not seem to help my problem still waiting for a nice day to clean the remaining grounds and maybe run a few new ones. Could the maf sensor have anything to do with this its one of the few sensors that have yet to be replaced i did clean it a month or two ago though
 

toyman

SN Certified Technician
Jul 19, 2007
1,944
53
79
Vernon BC
Did I miss a reference to pulling the trouble codes (DTCs)? Buying a code reader will likely be the best $25 spent to help diagnose the issue. You need to know what the ECU is logging.