New here from Florida.Looking for some advice on a new cat system for a 2001 Gt Mustang.

Nov 8, 2018
3
0
1
44
Palm bay, Fl.
#1
Really want to make this car run good again and need to get a new cat system. At a loss as to which one to get. Looking for a mid priced one with the best quality for that price range. Something better than stock. Can anyone suggest the best one for my 2001 Mustang Gt?
 
  • Sponsors (?)

Nov 8, 2018
3
0
1
44
Palm bay, Fl.
#3
No other modifications?

What state do you live in? What are the smog requirements there? How many miles are on the car? Is there anything wrong with it?
I live in Florida. No inspections or tests done here. Motor just rebuilt, so that runs good. About 150,000 miles on the car. No other modifications besides flowmaster exhaust.
 
Nov 8, 2018
3
0
1
44
Palm bay, Fl.
#4
I live in Florida. No inspections or tests done here. Motor just rebuilt, so that runs good. About 150,000 miles on the car. No other modifications besides flowmaster exhaust.
I'll add a little bit more background info. Car will run about 5-10 minutes, then quit. Wait a little bit and it would start back up. We pulled it in driveway and seen one of the cats glowing bright orange and smoking. Car had the strong rotten egg type smell from exhaust. We removed all cats and ran the car for a little bit with open exhaust, and no more stalling. Any more insight on this would be appreciated.
 

Noobz347

Stangnet Facilities Maint Tech... Er... Janitor
Admin Dude
Jan 4, 1985
25,368
8,260
224
Box behind Walmart
www.stangnet.com
#5
I'll add a little bit more background info. Car will run about 5-10 minutes, then quit. Wait a little bit and it would start back up. We pulled it in driveway and seen one of the cats glowing bright orange and smoking. Car had the strong rotten egg type smell from exhaust. We removed all cats and ran the car for a little bit with open exhaust, and no more stalling. Any more insight on this would be appreciated.
You likely have a vacuum leak somewhere in the engine bay. Either a vacuum line is disconnected, improperly routed, or cracked/broken, or you have a gasket that is not seated or improperly installed. You said you just had the engine rebuilt. How long ago was that? Did it ever run right after the rebuild?

You need to provide us with a set of trouble codes. Are you able to pull those codes from your car's computer and list them here?