Please help, vibration issue (lots of details)

blackyote_317

New Member
Jan 16, 2019
13
0
1
31
Indiana
Hey all,

I'm hoping you can point me down the right path on this issue as I don't want to just throw parts at it. I will likely take it to a pro to diagnose and hopefully solve my issue at this point but I'm hoping something sticks out to someone here. I have a really annoying vibration starting just before 30 mph and ending about 40. It comes back around 80 at a higher frequency. This seems to be speed dependent and not RPM dependent. I also still get the vibration when I put the car in neutral at those speeds so I don't think it is transmission or torque converter related. I can't quite pinpoint where it is coming from when I'm in the driver's seat unfortunately but it doesn't seem to just be in the wheel. I did just buy brand new wheels/tires since I was told I had a bent wheel. It helped the general vibration I was getting but not in the main problem speed zone.

Here is everything that either I've done or had a shop do since I bought the car in January (besides fluid changes, etc):
-New wheels/tires
-Alignment
-Brakes: F/R rotors and pads, front calipers
-Driveshaft U-joints
-Front wheel hub assemblies
-F/R shocks
-Front lower ball joints
-sway bar end links
-inner/outer tie rods
-had entire rear end rebuilt w/ 3.55s
-transmission drained/filled 3x and new filter

629661
 
  • Sponsors (?)


blackyote_317

New Member
Jan 16, 2019
13
0
1
31
Indiana
Yeah I had my wheels balanced and was told one was bent. So I ordered all new wheels and tires. Just put them on the other day and the vibration is more or less the same. Don't think it's a wheel or tire issue at this point.
 

Similar threads