Windshield wipers stuck on low intermittent. Washer fluid pump also in the mix!

en4cer1133

Member
Feb 28, 2019
3
1
13
35
United States - MO
Hello all!

I am hoping someone can help me! This is my first Mustang, and I absolutely love it. It is a 2012 3.7L V6 with 6 speed manual transmission. When I test drove it, there wasn't any problems, however, recently it has developed a little issue. My wiper fluid pump was going crazy and throwing fluid on my windshield without me pushing the button. When that isn't happening it seems that my wipers are stuck on intermittent low regardless if the multifunction switch is in the off position. I just replaced the MF Switch as I heard that was usually the culprit. I thought it fixed it, however it started freaking out again. Would it be a reasonable assumption to check the electrical connections from the wiper motor as well as the fluid pump and clean the contacts on them? Since the MF Switch was replaced does it seem like an electrical issue? Is there anything else I should check? The internet has been largely unhelpful as it seems no one has ever had this situation before.

I really don't want to take it to the dealer, and I would rather fix it myself. Any ideas would be really helpful! Thanks in advance!
 
  • Sponsors(?)


en4cer1133

Member
Feb 28, 2019
3
1
13
35
United States - MO
Finally got some time to take out the wiper motor and look at the electrical connection. There was some water in the plug, and one of the pins had some blue-ish green fuzz on it. Possible corrosion. I cleaned it with electrical contact cleaner and put some dielectric grease to prevent further water contamination. I may end up having to replace the wiper motor as the issue is less now, but still present. I will keep everyone updated just in case this happens to someone else.