2005 GT Failsafe Mode

Apr 18, 2005
86
3
9
Valencia, CA
Just sharing an easy fix. My 2005 GT went into failsafe mode yesterday. Searched for possible causes on line first, and everything points to the TPS or throttle body. Turns out it was a bad battery.

That was the short answer. Here is the longer story. It's a 2005 GT with an Edelbrock E-Force supercharger. It has 225,000 miles and is extremely well taken care of. Yesterday I went to start it, and it fired up for a second, then immediately hit failsafe mode and stalled before even idling. I turned it off and tried a few more times. Same result. Everything on-line points to the TPS. So I checked a few things. Multi-meter on the battery showed 12.2v. Pulled the CAI tube, and cleaned the throttle body. Turned the key on, and watched the blade open as close when the gas pedal was pushed. I tried disconnecting and re-connecting the battery, but got the same result. Thinking it was still the battery, I plugged in my tuner to look at the stats. It said it was at 11.4V. So I hooked up jumper cables, and it fired right up. Charging at 14.3v. Took the battery in, had it checked. Yup. It was bad. Apparently it had enough juice to crank the engine, but the computer didn't like it. A new battery cleared it right up. I'm not sure why it was showing 12.2v with my multi-meter, but maybe I need to invest in a better one!

Hopefully this info helps someone else in the same situation.
 
  • Sponsors(?)


EmmJay

Member
Jun 16, 2019
88
22
18
121
USA
Thanks for adding to the documented fixes here. I am sure it will help many people as time passes.