Crank no start

Dec 30, 2018
85
11
18
32
Medford, OR
2000 GT battery was disconnected for about a week to week and a half while replacing throttle body and upper intake.

Double checked all connections so everything is hooked back up right.

Its not the pats system because the theft light goes out after key is in on position. All dash lights, door chime, radio all light up and work. The dome light dims as you crank so I assume that means its applying power to starter.

Any ideas???
 
  • Sponsors(?)


08GT500

Active Member
Jul 12, 2018
875
136
53
49
Massachusetts
2000 GT battery was disconnected for about a week to week and a half while replacing throttle body and upper intake.

Double checked all connections so everything is hooked back up right.

Its not the pats system because the theft light goes out after key is in on position. All dash lights, door chime, radio all light up and work. The dome light dims as you crank so I assume that means its applying power to starter.

Any ideas???
Hi,
Yikes, lots of 2000 Mustangs are not liking this specific season.
Did you pull any DTCodes?
If PATS is proving out with 3 flashes of the Sec light, I’d be checking Grounds to the block and elsewhere from the battery that may be pigtailed on that that appear as solid, but may not be.
Battery voltage stays strong above 12VDC while cranking?
What is your TPS Voltage when in the idle position, below 1 DCV?
If it’s cranking..
1) Fuel pump priming?
2) Strong apart tested and present to plugs?
3) Check your fuses, fuse lock connections, circuits for the ignition and similar circuits?
4) Verify fuel pressure at the rail?
5) Are the injectors firing? Have someone crank it while your fingers ore on the injector harness & check for clicking if the injectors are firing, or test with a NOID light.
No issues prior to this?
Best!
John
 
Dec 30, 2018
85
11
18
32
Medford, OR
I assume the fuel pump is priming because I have fuel at the rail. I did the Schrader valve check since I don't have a pressure kit. I checked the engine bay and under dash fuses with a basic ground based light and showed up fine. Work just made mandatory extra work for managers so I lost my free time and had to have it towed to a shop. I'll post here once they find out what's going on.
 
  • Like
Reactions: 08GT500