Engine ECU issues


New Member
Apr 25, 2023
hey guys, really stumped on this one. 91 gt 5.0

A little backstory, my car caught on fire from the battery. I replaced everything that was damaged, wiring etc. the ecm than had an issue that the fuel pump wouldn't kick on unless jumped so I sent out the ECM to get repaired. it came back and had a new issue where it would crank on the quarter turn so I sent it back and it came back still not fixed. So I decided just to buy a new one. I bought a mega squirt with the base 5.0 maps, I put it in, ran the vacuum line and it worked great besides not being able to idle without some throttle. As i was figuring that out I go to turn it on and then all of sudden it cranks great but no spark. If I take out the spout that disconnects the computer it does have spark. it gets fuel and everything else work's. I than put the old ECM back in and it has spark when I turn the key and it cranks. So my conclusion is somehow the new ECM went bad? I'm stumped really any help is appreciated
  • Sponsors (?)

Can I ask what you mean by quarter turn? Assuming it's the ignition cylinder that you are referring to. Positions are accessory, stop/lock, run, and start. To go from the stop/lock position it is about a quarter of a turn or it could be that you are calling a quarter turn one position as it is one our of four possible positions thus a quarter. I am only going to this level of detail as the more detailed you are and the better terminology you use the more we can help.

My guess here is you are saying it was cranking when in the run position and not the start position. This to me means one of two things:

1) The ignition switch has an issue and internally it is allowing the white/pink wire to have 12V+ with the ignition in the run position
2) Somewhere in the wiring in-between the ignition switch to the inner fender starter solenoid the starter wire is being exposed to 12V+ but only in the key run position.


Is the car a manual trans or automatic? If its an automatic then there is a neutral safety switch and if it is a manual then there is a clutch safety switch. Either way that switch has to be closed (auto trans in neutral or clutch depressed in a manual car) for the car to start.

If the starter is engaging and quarter turn means the key is in the crank position then ignore all of the above. In this case with a stock ECU and no spark then my next move would be finding a known good distributor and swap them out to see if that solves the problem.
If the original Ecu cranks on a quarter turn but the new ECU doesn’t do you think it’s still wiring?

View: https://www.youtube.com/watch?v=7dQ5pPxvlRw. Computer has nothing to do with a no spark or cranking early situation. Its either the switch or the wiring. Watch this... No computer, it cranks it sparks... The ecu controls the timing of the spark, even if its bad the tfi will still generate a spark. I bought cars that ran with computers that where fuber before, they ran like dogs :poo: but, still able to fire if the base timing is right and most of the injectors are firing.
View: https://www.youtube.com/watch?v=7dQ5pPxvlRw

Something in the wiring or a failing part of the ignition switch system caused your issues with early cranking. The megasquirt if it fires with out the pip.. Either the timing map is off or the base timing is fubar would be my first guess the ecu swap should have no effect on it cranking early in the key cycle I'd suspect the ignition switch wiring or the fusible links off the the starter relay being damaged is the cause. but without probing wires your just guessing all depends on how you fixed the wiring from the fire. If its wired like stock its not the computers causing the problems you described.
  • Like
Reactions: 1 user
Or all signs leading to wiring then? I’m gonna get a used ECU wiring harness and try my luck with that. I don’t think it’s a computer problem I think it’s a wiring issue like you said. We will see, I just still don’t understand why it would’ve ran fine than stopped with no spark all of a sudden. The only thing I did was unplug the MAP sensor witch is the only change i could possibly think of. The LMR video i watched said all you had to do was plug it in and the car would run but other videos say I need to do timing. Maybe did I mess up the timing? Sorry i’m all over the board just don’t know.
Last edited:
Ok guys, i appreciate the help. With the new megasquirt PNP2 i get no spark. If I pull out the spout I get spark. Just wanted to clarify that.
I haven't played with that stuff in years but they used to have you do some wiring mods on it with a resistor on the spout, think it was 330 ohm. pretty sure that was a much older version though and you said it ran before.. If you bought from them best bet is make em earn that sale and give ya some tech support.. But its almost all ways in wiring, especially if your having issues with stock computers too.... too many ppl trusting 30yr harnesses these days, :poo: the amount I replaced on cars under a few years old wasn't even funny working for a dealer.
Funny you say that, I just found the resistor thing gonna be testin that tomorrow. I have called them earlier they **** up on the USB drive and sent me corrupt files to download and install so I couldn’t use their software they wanted me to use for diagnostics on their end. Feel like i’ve been through almost everything on this one so if the harness/spout resistor doesn’t work I’ll be starting back at ground 0 to dot my i’s and cross my T’s…