hitting the revlimiter

my cobra started to feel like it hits the rev limiter at 3500 rpm and the tach goes crazy and i hear the car sputtering but as soon as I let of the gas it stops .I changed the ignition coil ,TFI module even the distributor (i have the stock parts) and still have the same issue .This started after i moved my timing down a little because i was hearing piging it was at 14 degrees got it down to 12 then to ten with the same result .Any ideas what could be wrong the only thing i can think of is the spark plug wires the plugs were changed about 8000 miles ago with motorcraft stock replacements.
 
  • Sponsors (?)


HGFireHazard

Member
Apr 10, 2005
460
0
17
Michigan
Is the harmonic balancer in good shape? That's the only thing that I can think of. If you were adjusting the timing without getting the pinging to stop... that's what I would check.

I would say a bad tank of gas, but I don't think that accounts for the lack of power above a certain RPM, sounds like a timing issue.
 
Is the harmonic balancer in good shape? That's the only thing that I can think of. If you were adjusting the timing without getting the pinging to stop... that's what I would check.

I would say a bad tank of gas, but I don't think that accounts for the lack of power above a certain RPM, sounds like a timing issue.


I got the solid liquid filled harmonic balancer SFI certified I just bought new wires hopefully thats it because its definantly a timing issue its only happens when its over 3000 rpm. I'll keep you guys updated
 

BlownFiveLiter

have car, will race....wait, it doesn't run
15 Year Member
Nov 29, 1999
3,134
18
108
Chicagoland
Check the usual suspects: pull codes, check plugs & wires, cap & rotor, fuel pressure, vacuum leaks, TFI & PIP. Also, if you can, disconnect your MSD unit and use the stock ignition (if you mean it's like a 6A, 6AL, etc in your sig) since they have had a tendency to cause issues like these, and often require a good refurbishing from MSD.
 
Thanks for all the tips it ended up being the damm wires for the spark plugs I neglected them for so long I put almost 25,000 miles on them but since I rarely drive the car so I overlooked them I put ford 9mm wires on the old ones were the same just a different color .Two of the wires had spark marks on them which meant I was loosing spark in two cylinders . Thanks to all