In-Car Videos from the Track Last Night

sneaky98gt

10 Year Member
Apr 23, 2008
2,387
144
114
NC State University
Got back to the track for the first time in a couple of months. Didn't run a new best, but it did run pretty well for the trim it was in. I got 2 new 17x9 Cobra Rs to put my drag radials, so each wheel was roughly 8 pounds heavier than my old 17x8 wheels on which I ran my best pass. The DA was also about 500 feet worse than before, which normally accounts for around .1 and 1 mph on my car with the non-intercooled blower.

My best last night was a 12.72 @ 108 mph with a 1.89 60'. That's only .15 and 1.5 mph from my best, but with a worse 60', worse weather, about 30 pounds more rotationion weight, and more weight in the interior. So I was very happy with how it ran.

I only got a few videos from last night, none from outside the car because no one else went with me, but I did get to try out my new camera mount. It's basically just a bar with a slot cut in it to go in the headrest, and then a hole drilled at the other end for the camera to mount to. I was pretty happy with how well it worked, and I'll definitely be using it some more in the future.

YouTube - Testing the New Camera Mount at Rockingham

On the 1st, 2nd, and 4th videos, I was running Bob (tank_567) with his turbo 4.6 GT. His car was a ton faster than mine, but between him missing a gear one one pass, and "giving me a head start" on another :)rolleyes: :D), we had several really fun races. Maybe I can do a little better job keeping up next time I go. rubhands
 
  • Sponsors (?)


tank_567

Active Member
Mar 19, 2007
731
26
29
Raleigh, Nc
Hey now, Loved the video, had a blast. That last race Will got a big jump on me. Had a buddy in the car for the ride I will post videos soon. :nice:

BTW I think my best for that night was a [email protected] w/ a 2.01 60ft. and other than that I could not get a break I kept running crappy 60ft times 2.2 and I think the worst was a 2.5 something and will ran a [email protected]
 

Dark04GT

10 Year Member
Apr 27, 2008
758
67
59
NC
Looks like a good track with some good runs. The Army is moving me to NC in 2 months and I hope I can join in on some of the fun. (although I've got no blower, I'm going to get beat up!) :)
 

sneaky98gt

10 Year Member
Apr 23, 2008
2,387
144
114
NC State University
Thanks for the compliments guys! We had quite a good time out there.

That's freaking badass, Will! I'd rather my races with friends not be that close, but looks like fun!

Is this in reference to a certain forum member with a soon-to-be nitroused 5.0 that might have a little something for the Vette? :D

Alright Will I take it that you have called Circle D (or another company) and placed an order right? Gotta get that launch down a few tenths :D

Cool videos!

A converter would help a LOT, but it probably won't happen any time soon. Maybe sometime next year when I get another vehicle to DD. For now, gears, 3 more pounds of boost, water/meth injection, and a tune will have to do. :D

Hey now, Loved the video, had a blast. That last race Will got a big jump on me. Had a buddy in the car for the ride I will post videos soon. :nice:

BTW I think my best for that night was a [email protected] w/ a 2.01 60ft. and other than that I could not get a break I kept running crappy 60ft times 2.2 and I think the worst was a 2.5 something and will ran a [email protected]

Heck yea man, good time, and nice video as well! I loved the sound effect in the last run! :lol: I saw that something had happened, and I was literally about to mash a hole in the floorboard trying to keep you from coming around me. :rlaugh:

Looks like a good track with some good runs. The Army is moving me to NC in 2 months and I hope I can join in on some of the fun. (although I've got no blower, I'm going to get beat up!) :)

Sweet man, I'd love for a few more guys to go out with us. I'm in the drag strip club at NC State, but there's only one other guy that regularly goes with me to the track, and tank_567 was there this past time. I'd love to have a nice sized group of guys heading to the track together.

There's a lot of tracks in the area with lots of test-n-tunes, so I'm sure we'll be able to make it out sometime. Where will you be stationed? Bragg?

Awsome!!!!!! Though that civic almost had you lol. What did that g8 run? Nice runs between you and sneaky.

There was actually a Civic there running very low 11s (11.2 IIRC). The G8 went a best of around 11.5 at around 124 mph; I don't remember exactly. It is quite a nice car, and it really moves. And that is in FULL street trim, tires included, and no icing of the blower/intake or anything like that.
 

tank_567

Active Member
Mar 19, 2007
731
26
29
Raleigh, Nc
Awsome!!!!!! Though that civic almost had you lol.

Yeah he did till i got traction and put a bus length or two on him:rlaugh: I was running crappy 60ft all night 2.2-2.6 was the worst. Best of the night was a 1.9 and I have no idea how I got it.:notnice: Got a set of moser axles 31 diff and 3.55 gears ready to go in. I think I have maxed out the 245/45/17s on my car along w/ the stock gears(3.27) on my best time of [email protected] w/ a 1.80 60ft. I really wanted to hit low 11s with that setup, but its not going to happen w/o any traction.
 

Dark04GT

10 Year Member
Apr 27, 2008
758
67
59
NC
There's a lot of tracks in the area with lots of test-n-tunes, so I'm sure we'll be able to make it out sometime. Where will you be stationed? Bragg?

Yeah I'll be stationed at Bragg. I google mapped the track you guys were at and it is not far from where I'll be living. I'm excited to have a track that close, haven't been to a track since undergrad (4 years ago). :( But now => :)
 

sneaky98gt

10 Year Member
Apr 23, 2008
2,387
144
114
NC State University
Yeah I'll be stationed at Bragg. I google mapped the track you guys were at and it is not far from where I'll be living. I'm excited to have a track that close, haven't been to a track since undergrad (4 years ago). :( But now => :)

Yea, it's not far at all. Fayetteville Motorsports Park (another 1/4 mi drag strip) is also really close to Bragg, although I don't care much for it or the folks that run it.
 

Gearbanger 101

Straight Outta Locash
15 Year Member
Aug 10, 2002
9,457
1,378
234
Ontario, Canada
Nice vids. Will, sounds like you're getting a little bit of belt slip on the blower between the 1-2 shift. It's probably costing you a couple of tenths. Had the same problem with my Eaton. Dabbed a little VHT glue on the belt every couple of runs and it went away. :nice:
 

sneaky98gt

10 Year Member
Apr 23, 2008
2,387
144
114
NC State University
Nice vids. Will, sounds like you're getting a little bit of belt slip on the blower between the 1-2 shift. It's probably costing you a couple of tenths. Had the same problem with my Eaton. Dabbed a little VHT glue on the belt every couple of runs and it went away. :nice:

Hmm, I hear what you are hearing. Is it belt slip, or is it the torque converter locking up? It has always had that little hesitation right there, even before the blower.

Here, listen to this video beginning at :45. The run started in 3rd, but kicked back into 2nd gear. At :51, you can hear it doing the same thing (I think).

A question for you: in the first part of the original video, from :22 - :38, specifically at :27 and :32 (just before the gear changes, at 5500-6000 rpm), why does the boost gauge show it's making more boost? I have a leak somewhere between the gauge and the blower because it's only showing around 5.5-6 pounds of boost (when it should be showing a solid 7 in this weather), but that's not relevant because it has always done it. Especially in the 2-3 shift, it goes in the video from around 5.5 pounds of boost to almost 8. When I didn't have a leak, it would show 7ish and go up to around 9. Is this normal on a roots blower?
 

Gearbanger 101

Straight Outta Locash
15 Year Member
Aug 10, 2002
9,457
1,378
234
Ontario, Canada
You know, you could be right. Now that I think of it, I did hit the dyno again to fine tune some trans issues I was having between track outings (shift points and TC not unlocking when letting off the throttle, causing it to act as an engine brake upon deceleration.....very annoying!!!). Perhaps some of my issues between the 1-2 shift were cleared up then? Bottom line though, if the boost isn't stalling, then it's not a belt slip issue.

Mine was an issue however, since I'm running a 2 3/4" blower pulley on my M90. Even with the 8-rib set up, it's holding on for dear life to what little of the belt surface contact it's making. Lol

Your larger M112 probably doesn’t have that problem, since you’re able to run a much larger pulley (which allows you to maximize belt traction) and still move decent volumes of airflow.

Roots blowers will normally spike fairly quickly and may climb 1-2psi durning the last 1,000RPM or so of the tack. That's not a bad thing and is often quite normal..especially if you're running stock heads/cams/etc. It means it still measuring some amount of restriction, that's all.

It's watching them drop off at the last 1,000RPM of the tack that you don't want. That means that you aren't running enough blower and it's unable to keep up with the airflow demands of the engine.