Marcelo tuning adventure

  • Sponsors(?)


marcelo

Active Member
Feb 25, 2018
140
21
28
58
Quepos, Costa Rica, Central America
yesterday i drove about 180 miles to the track and back engine was running fine on highway cruising around 2ooo to 2200 rpm on the way back filled some gas and Engine started to make real troubles ..extreme idle hunt from 500 to 2000 rmp
 

marcelo

Active Member
Feb 25, 2018
140
21
28
58
Quepos, Costa Rica, Central America
ok this is weard.. this plugs in the Pic where new Autolits 3923..(i used the 3924 with Nitrous ..2 years the same plugs and never had a problem ....) as I said I installed some new NGKs (3524..BCPR5ES-11) I had .. put all back together..Distributor set by Hand and lets give a try .. man ...engine starts right away and runs smooth and nice revs up and down like nothing happened????!!! Bad Spark plugs caused all that troubles??
 

a91what

SendMeUrDataLog
Mod Dude
Apr 6, 2011
9,666
5,736
204
31
Hillsborough county
well the WOT fuel looks good and the porcelain is clean up top... looks like a decent plug to me burn wise..

other than the fact that you broke it....
 

marcelo

Active Member
Feb 25, 2018
140
21
28
58
Quepos, Costa Rica, Central America
hello .. back with some new stuff.. had to Install a new CAI .. remember my Plastic tube self build ... haha.. started to melt away .. so i needed a new one..cheapest from ebay 45$$ and the reducer for non MAF... bought on a bay auction for 3.50$ !!! best deal ever.. LMR sells the same stuff from BBK for no shame 70$!!! stainless exhaust reducer from 3.5 to 3"....so it was not that much $$ with all the Shipping and Taxes i have to pay here in Costa Rica ..also Nitrous Feed is in and all looks pretty nice ..next week have to go for Inspection and then building back for performance... 18.Nov next Race Day..
 

Attachments

marcelo

Active Member
Feb 25, 2018
140
21
28
58
Quepos, Costa Rica, Central America
Idle air control valve ..since time I had some doubts about the IAC i had installed ..I dont know if there different ones or all are the same.. as you can see in the Pic .this has the connector turning to the left side and original has connecter to the right side..now I ordered a new one from Standard AC21T..with connector turning to the right side..after install .. first time, I think, this valve is doing something..Idle drops like 100 rpm when disconnected and goes up again when connecting ... with the "old one" there was no change in RPM..
..
 

Attachments