Microsquirt not syncing up with tunerstudio

Gunny87

Active Member
Nov 29, 2015
49
7
28
57
Murray Utah
Installed it all yesterday went to Best Buy and got a serial port to USB adapter got the MS version (the $59.95 version) TunerStudio plugged all the cables in, pulled up TS on the laptop, clicked on create new project, clicked on firmware-detect, cycled the key to on, fuel pump primes, does it's search, and then says no controller found! moved the cable to all 3 USB ports on my laptop and the same thing is happening!!! double and triple check all connections but no luck!!! the MS is working, the car will start but won't idle and I'm sure that's because all the basic settings need to be calibrated via TS! NEED HELP PLEASE!

The car is bone stock 87 GT AOD, I did convert it to Mass Air a year ago and Explorer 19 lb injectors but other than that stock and has been running great, I wanted to change to the MS before I install the new engine I have ready to go in and get familiar with tuning so when I make the switch I'll hopefully know what I'm doing, the new engine is a 306 with GT40 heads, intake with 70 mm throttle body, and E cam, and will be using 24 lb injectors, and in the near future adding supercharger so as you can see the MS and TS will be playing a big roll in the cars future so really need this to work!!

Help!
 
  • Sponsors(?)


Gunny87

Active Member
Nov 29, 2015
49
7
28
57
Murray Utah
When I first plugged it in it did say it was installing the drivers but I noticed that as I was starting to pull up TS and from what is happening I'm guessing it's a cable issue, so if I did something wrong how can I fix that? I'm no computer expert (I'm 55 yrs old) so if I did something wrong I don't know how to fix it.

Yes I did turn the key on before hitting detect, trust me I tried many times to get it to work and got very frustrated!
 

a91what

SendMeUrDataLog
Mod Dude
Apr 6, 2011
9,998
6,166
204
31
Hillsborough county
sometimes it does not work and you have to create the project and then find the ECU.. my suggestion is to restart the laptop and try again.
 

Gunny87

Active Member
Nov 29, 2015
49
7
28
57
Murray Utah
Ok I played around with it and got it to connect however now it's saying "TS does not have a configuration to support the found firmware MS2/Extra commms340vU Required Serial Signature: MS2Extra comms340vU (see pictures) not sure if I should click on these? do I need to get updates for TS first? sorry this is not working smooth as I thought it would I just don't want to click the wrong thing!
20190714_105405.jpg
20190714_105720.jpg
 

Gunny87

Active Member
Nov 29, 2015
49
7
28
57
Murray Utah
you want the newest firmware available to you. for a ms2 it will be 3.4.2
so where do I find this? when I tried the update it asked me to select the the one I wanted but don't know where to find the file, this is not proving to be at all an intuitive program, at least not to me.
 

a91what

SendMeUrDataLog
Mod Dude
Apr 6, 2011
9,998
6,166
204
31
Hillsborough county
You need to find out what firmware you are currently using. The firmware number is at the top of the screen when you are connected to the ECU.

You have to download the firmware from the website and place it in a file you can find on your PC, you may want to read the manual found at msextra

The tuning is quite intuitive once you get started but with any system you must first have an understanding of the basics. I can supply pictures of needed.
 
Last edited:

Gunny87

Active Member
Nov 29, 2015
49
7
28
57
Murray Utah
so I was able to get it all working but I had to go buy a 150 ft Ethernet cable and run that out too the car so I could get internet service to download the correct files so now it's working ish not running all that well so I'l have to play with it some more! really wish there were better YouTube videos out there on how to do the initial set up and tuning on a stock 5.0, all the good videos are from guys with turbos and they are just showing what they have done not really instructional how to vids, and for the most part there's no instructions!
SendMeUrDataLog I appreciate your help
thanks