Shuddering

RaggedGT

Not a very good Mod
Mod Dude
Jul 20, 2014
4,231
2,812
183
34
Taylorsville ky
www.stangnet.com
A few of you guys know, over the last year or so I have been trying to put my 1994 GT back to driver status.
The main reason the car was parked for so long was a leaking Aode transmission with reverse issues got replaced with a used aode with only one forward gear.
The car is mostly stock-
•stock fuel pump
•stock injectors
•stock intake
•stock throttle body
•E303 cam-which it has had for several years
•typical headers-X pipe and two chambers

The car runs pig rich at times, randomly dies, surging idle at times, and slow to rev when warm.

I replaced and reran a lot of the vacuum lines,I haven’t found a leak anywhere. I have done the base idle reset, as well as replace the iac and throttle position sensor over the last year. Along with the temp sensor and a healthy cleaning of the maf.

I have been through @jrichker ’s checklist several times with not much change.

Where do I go from here guys? What would you suggest?

The other part to my extremely long line of questioning- the Aode transmission is a fresh rebuild ,less than 10 miles on it. New converter, fresh fluid at the correct level. Only things different are a Transgo shift kit and an aftermarket transmission cooler.
When driving the car,as long as I am leaning on it pretty good-the car pulls strong and up shifts like a champ. But under part throttle, light throttle-it will buck and shudder , almost to the point of bogging down and killing the engine and will only downshift under hard acceleration.

Am I having running issues and transmission issues-or do you think my poorly running engine is causing the transmission issues?

I’m lost guys-and a bit overwhelmed lol any ideas would be greatly appreciated
 
  • Sponsors (?)


CarMichael Angelo

I don't like your attitude, let me fix that.
SN Certified Technician
Nov 29, 1999
11,046
11,926
234
61
Birmingham, al
A few of you guys know, over the last year or so I have been trying to put my 1994 GT back to driver status.
The main reason the car was parked for so long was a leaking Aode transmission with reverse issues got replaced with a used aode with only one forward gear.
The car is mostly stock-
•stock fuel pump
•stock injectors
•stock intake
•stock throttle body
•E303 cam-which it has had for several years
•typical headers-X pipe and two chambers

The car runs pig rich at times, randomly dies, surging idle at times, and slow to rev when warm.

I replaced and reran a lot of the vacuum lines,I haven’t found a leak anywhere. I have done the base idle reset, as well as replace the iac and throttle position sensor over the last year. Along with the temp sensor and a healthy cleaning of the maf.

I have been through @jrichker ’s checklist several times with not much change.

Where do I go from here guys? What would you suggest?

The other part to my extremely long line of questioning- the Aode transmission is a fresh rebuild ,less than 10 miles on it. New converter, fresh fluid at the correct level. Only things different are a Transgo shift kit and an aftermarket transmission cooler.
When driving the car,as long as I am leaning on it pretty good-the car pulls strong and up shifts like a champ. But under part throttle, light throttle-it will buck and shudder , almost to the point of bogging down and killing the engine and will only downshift under hard acceleration.

Am I having running issues and transmission issues-or do you think my poorly running engine is causing the transmission issues?

I’m lost guys-and a bit overwhelmed lol any ideas would be greatly appreciated
I'm saying you are having OD or LU issues on the trans..you should be in my car when I forget to disengage the locked up converter..
 
  • Like
Reactions: RaggedGT

90sickfox

I didn't really have an issue with the stink...
SN Certified Technician
Mar 2, 2015
4,269
3,662
183
41
I can remember an issue with torque converter shudder on the mustang GTs and the Crown victorias. It would usually happen around 40 to 45mph. I've fixed several with a flu if d and filter change and the addition of Lucas transmission treatment.

That wasn't on bra d new transmissions or fresh rebuilds.
 
  • Like
Reactions: RaggedGT

RaggedGT

Not a very good Mod
Mod Dude
Jul 20, 2014
4,231
2,812
183
34
Taylorsville ky
www.stangnet.com
Alright guys,if I can have your ear again- I made some adjustments to the idle-to the Mlps-adjusted the shifter and fluid level.And I drove it further away from the house-that was a bit sketchy lol.
It drives better, but still has the shudder/bog at part throttle. But the car will not idle below 2K Rpms while in gear and I’d put money on that being my shudder/bog problems... At idle in park it hovers around 1K Rpms, and getting it to do that took forever(thanks @jrichker ) how do I set the idle for in gear/driving?
 

Similar threads