1966 neutral safety switch vs transmission issue?

sawphds

Member
May 29, 2019
2
1
13
39
Charlotte
I got an automatic ‘66 convertible not too long ago. It’s starts and runs good most of the time, but occasionally won’t start. But if you put it in neutral and push it forward or backwards and put it back into park, it then will start. Occasionally, it will start but not shift into gear, or only shifts into drive. Then turn it off and push it again and then start it again and then it will shift into any gear again. Could this all be linked to the neutral safety switch? It has a new starter, battery, fuel injection etc, so I know it’s not that. Just curious if the switch could cause all that or do I have a tranny problem? Thanks in advance.
 
  • Sponsors(?)


08GT500

Active Member
Jul 12, 2018
384
43
38
Massachusetts
Hi, The NSS would explain all you posted with exception of it not going into gear (sticky shifter pin?). Fuel Injection..Is this is just a Motor mod, or a different Motor, Tranny transplant?
Either way, locate the issue(s) by process of elimination. Sounds like the NSS is involved, in some way, whether that’s your only issue is a mystery at this point. May simply be out of adjustment, or a shifter issue. I’d Pull & inspect the Switch. Check for cracks & proper function. Check the Plug & Socket, wiring, clean.
If it’s a 66’ C4, It's located on the right (from the Driver's side) where the shaft is for the gearshift, between the transmission and the shift lever, the shift lever shaft passes through it. Follow the wires... You’ll have to adjust it, so it starts in Park & Neutral.
Good luck! John
 

sawphds

Member
May 29, 2019
2
1
13
39
Charlotte
Thanks man, yeah NSS is on it’s way. Will see what it does afterwards. Originally was a 200. Bought it with the 289 replaced in it. Just was mentioning the new stuff so people didn’t ask about that for not starting. Will look at the shifter pin afterwards.
 
  • Like
Reactions: 08GT500