2005 V6 Mustang Trouble

Legendlime2005

New Member
Aug 10, 2017
1
0
1
31
Hi, Thanks in advance for any help..

I have a 2005 v6 Legend Lime 5-speed mustang. Just passed 70k miles. No engine upgrades. Just Exterior pieces.

Today I was making a trip for work, About 16 highway miles and 5 intercity miles. When I made to my last stop, (Fed Ex) I noticed as I was pulling in the Parking spot my Rpms started to increase while I wasnt touching the gas (Clutch was also in so the car was not moving faster). I shut it off and went into the store. When I came back out the car started up fine but the Wrench symbol came up along with a Check engine light.

When I tried to reverse out of the parking spot i would give it gas but it would barely move. It would not go over 1500 rpm's or about 4 mph. I drove once around the lot and re parked the car. After a few minutes I re tried it and same problem. Although it was idling fine when i gave it gas it did nothing. So I went under the hood to look over everything Which everything looked normal. I tried disconnecting the battery to reset the cpu but no luck. the wrench and check engine light immediately came back.


The Engine codes read p2112 and p2104.

I ran to a nearby store and got a few things and started to work in the parking lot. I opened the throttle body and cleaned it the best i could but the inner flap would not move easily. I cleaned it very well with cleaner and wiped it down.. I also took off the MAF sensor and cleaned it too. Now when i try to start it it will barely start then immediately die...

Is it the TPS? Or possibly the fuel filter? Or the whole throttle do you think? I've worked in a body shop most of my life so most of my experience is fixing dents not mechanical issues.

Ive read most places that its usually the TPS but would it cause the vehicle not to start? And would it happen so sudden like this? Or is it the entire faulty throttle?


On a side note im curious if anyone thinks my hood scoop has anything to do with it. I have a cervini style hood with two large hood scoops. Would the incoming water affect this at all if some did get in?

Ive had the car for about 8 years and bought it used with 20k miles on it and this is the first issue I have had with it at all.

Any input would really help me out! Thanks alot guys I appreciate it!!
 
Last edited by a moderator:
  • Sponsors(?)