Suspension 2006 GT Guidance please, retightening rear suspension

Earthworm

New Member
Nov 2, 2017
4
0
1
34
Good Day Everyone,

I am in need of some guidance. Aren't we all?
I would appreciate some direction as to not make this issue worse and possibly correct it.

Long story short, I had shop put in UCA, LCA's and panhard bar. All non-adjustable BMR.
And after about a month, when I braked hard I would hear a clunk. Hard to tell from where, and shop couldn't find anything.

Now I get a clunk/thud when putting car in reverse. Sometimes when braking hard. Steering feels restrictive.
And make a clunk when I let food off brake putting into park. Much more noticeable today. And when I turned left into a spot.
Sounds for sure coming from back seat area.

I am thinking that they did not tighten the suspension with it on the ground or loaded.
My plan was to grab some dollys and see if I can crawl under there to loosen all the bolts and then torque down.

Is there anything else I should try to check? And any recomendations on how to swear less when doing this?


Car is 2006 GT A4, CAI, Tuner, Subframe connectors, UCA, LCA, panhard rod bar, 3:73 gears.

Thank you much!
 
  • Sponsors(?)


Earthworm

New Member
Nov 2, 2017
4
0
1
34
Thanks for the reply. Where should I place the 4 jack stand? What would be best?

I bought a protractor to check pinion angle as I read that could cause my issue. As well as needing to torque it back down.
 

Red_LX

I’m not much help unless you’re looking for ****!
Mod Dude
Nov 29, 1999
5,862
68
129
39
Morgantown, WV...where couches meet their doom
Did you put in an aftermarket UCA with the factory mount? If so that's probably causing your clunk. The factory mount has a hole larger than the bolt- it's apparently not obvious with the factory arm and rubber bushing but apparently very noticeable once you put in an aftermarket UCA with a poly bushing. You need to either pick up some anti-clunk washers (easiest route) or get an aftermarket upper arm mount (more difficult, requires removing the rear seat and dropping the gas tank some)
 

Earthworm

New Member
Nov 2, 2017
4
0
1
34
Yes factory mount, that sounds like my issue thank you! I ordered anti clunking washers. Correct me if I am wrong, but those will connect the UCA to the factory mount?

I am going to order a new bolt for that section on the other bolt that connects to rear end.

Thank you