2007 4.0 V-6, Wonky oil pressure.

cbxer55

Active Member
Jan 25, 2020
205
41
38
59
Oklahoma
Yesterday, driving to work, all the sudden my oil pressure "gauge" dropped to zero while idling. As soon as I revved it up, boom, back to normal. Every time I hit idle, it dropped to zero. Then returned to normal once the revs hit over 1000. On the way home from work, didn't happen. I suspect the sensor is going out. I just bought the car in November, it has near 116,000 now. Runs great. Well cared for by previous owner.
 
  • Sponsors(?)


cbxer55

Active Member
Jan 25, 2020
205
41
38
59
Oklahoma
Coming home from work, problem didn't reappear. Drove it Sunday, problem happened after about 30 minutes driving. Shut off, restarted, problem went away. For sure the sensor is bad.

But, I guess I'm wasting my time here.
 

David Young

Active Member
Sep 16, 2012
157
15
38
67
Clinton, Tennessee
You could get a bunch of B.S. thrown at you from people who can't answer your question. The problem is most people don't have a oil pressure gauge. I have the factory oil pressure gauge and I don't pay much attention to it. If you have an aftermarket oil pressure gauge, I would probably be changing the sensor or (and) the gauge.

Maybe you found out why the last owner sold it :(
 

cbxer55

Active Member
Jan 25, 2020
205
41
38
59
Oklahoma
The factory gauge works for what it is. And oil pumps don't act like on/off switches. Oil pressure remains good until idle, where the needle just suddenly swings to zero, yet the engine runs and runs and runs. I let it sit in my garage yesterday when I came back from a Sunday drive, oil pressure zero. Engine idled for 10 minutes without fault. Shut it off, waited a minute, restarted it, oil pressure was back to normal. 100% certain it's just the stupid sending unit. I just need to find out where it is so I can see if I want to bother changing it. LOL!!

I've got two other Fords, a 98 3.0 Ranger and a 04 Lightning. I notice the temperature gauge on all three acts like a gauge, slowly going up, moving down a hair when the heater is turned on, etc. My Ranger, when the battery needed to be replaced twice, the gauge reflected it with the needle pointing considerably lower than it normally does. The boost gauge on my Lightning works correctly. So I don't consider the oil pressure gauge to be any different.

Also, it's not the previous owners fault. I bought the car November 15th. It only started doing this last Friday.
 
Last edited:

David Young

Active Member
Sep 16, 2012
157
15
38
67
Clinton, Tennessee
I hope your right. Many years ago I had a car that did the same thing your Mustang is doing. It did it for years. I sold it and the motor was still good, when the next person sold it. Then we don't know where the car ended up at after he sold it. It was still running great.

I have read, when the crankshaft bearings get worn out the oil pressure will drop, specially at idle. With the miles you have, the motor would have been abused and ran dry on oil for a while. I'm no mechanic. Good luck and let us know if it was the sensor. :)
 
  • Like
Reactions: cbxer55

cbxer55

Active Member
Jan 25, 2020
205
41
38
59
Oklahoma
I hope your right. Many years ago I had a car that did the same thing your Mustang is doing. It did it for years. I sold it and the motor was still good, when the next person sold it. Then we don't know where the car ended up at after he sold it. It was still running great.

I have read, when the crankshaft bearings get worn out the oil pressure will drop, specially at idle. With the miles you have, the motor would have been abused and ran dry on oil for a while. I'm no mechanic. Good luck and let us know if it was the sensor. :)
Worn crank bearings may make the oil pressure low, but not a sudden drop from full to zero, like turning off a switch. And a sudden gain back to normal off idle, like turning on a switch.

Anyhow, I don't believe 115,000 is high. My Ranger is headed to 168,000 this week. Oil pressure is great on that 3.0. I've had it 20 years.

Like I said, once I find the sensor, I'll determine if I want to bother fixing it. I just changed the oil about 500 miles ago. So if I do fix it, it'll have to wait for the next oil change. ;-)
 
  • Like
Reactions: David Young

David Young

Active Member
Sep 16, 2012
157
15
38
67
Clinton, Tennessee
Are you using Fram oil filters? I hope not :(. If you do I've read, you have a 'good chance' of having oil pressure problems with Fram oil filters. People have fix by going with a different brand :). Just wondering...…………...
 

cbxer55

Active Member
Jan 25, 2020
205
41
38
59
Oklahoma
No, I don't use Fram oil filters on all my vehicles. See below for the exception. Tell the truth, don't know what kind it is. Just had it changed at the local Valvoline place a few weeks ago. Haven't bothered to look and see the brand name, it's white.

But, I do change the oil on my Ranger all the time and do use the Fram oil filters with the grippy end. Never had an issue with them on that vehicle. Been using them on that Ranger for 20 years.
 

cbxer55

Active Member
Jan 25, 2020
205
41
38
59
Oklahoma
Drove it for over an hour yesterday, around my favorite stretch of curvy road, oil pressure never wavered. Drove it to work yesterday, took the long way in, same. Drove it home, took the long way, same result. So it's an intermittent problem. They're the worst kind.

Drove it a good 100 miles today, oil pressure good, even idling. So wtf?
 
Last edited:

rbohm

SN Certified Technician
Apr 12, 2002
6,622
531
204
61
tucson,az
replace teh sensor and clean the electrical conections, and give them a coat of dielectric grease. chances are the sensor is going bad, and coupled with a bad connection its giving the PCM faulty readings.
 

cbxer55

Active Member
Jan 25, 2020
205
41
38
59
Oklahoma
replace teh sensor and clean the electrical conections, and give them a coat of dielectric grease. chances are the sensor is going bad, and coupled with a bad connection its giving the PCM faulty readings.
I know this and would have already. But as I said, the problem has reoccurred. It happened that one day, and that one day only. If it happens again, I'll certainly look into it. I don't know where the oil pressure sensor is located. I had a really bad coolant leak at the heater hose where it attaches to the thermostat housing, stupid plastic parts. Anyhow, I had almost a gallon of coolant all over the engine by the time I got home and discovered it had happened. So I considered the possibility that some coolant got on the connections and was effing with them. But still found it odd the low oil pressure only happened after idling for about 30 seconds. And as soon as it was off idle, the oil pressure returned. So coolant on the connection is likely not the culprit. As you say, the sensor is possibly going bad or the connection is dirty.
 

cbxer55

Active Member
Jan 25, 2020
205
41
38
59
Oklahoma
This problem happened on January 25th and has not happened again since. Weird. I wonder about something. Had a coolant leak where the heater hose attaches to the thermostat housing. Fixed that. But the motor got pretty soaked down by it, coolant everywhere. I wonder if some coolant got into the connector and made it act wonky?
 
Thread starter Similar threads Forum Replies Date
R 2007 Roush Stage 3 The Welcome Wagon 0
L New to this site just bought a 2007 Roush 427 Stage 3 Mustang GT The Welcome Wagon 1
D Electrical issues 2007 GT 2005 - 2009 Specific Tech 1
S What's it Worth? 2007 GT Premium Modified What is it Worth?!?!? 1
B Paint and Body 2007 Driver side door 2005 - 2014 S-197 Mustang -General/Talk- 1
W HELP: 2007 Vert Leaking Above Passenger Door 2005 - 2009 Specific Tech 0
S how many miles can I get out of a 2007 4.0 liter engine? 2005 - 2014 S-197 Mustang -General/Talk- 3
G 2007 Mustang GT 2005 - 2009 Specific Tech 1
D Selling advice for 2007 California Special Convertible What is it Worth?!?!? 1
D Swap 2000 4.6 3v with a 2007 4.6 3v 1996 - 2004 SN95 Mustang -General/Talk- 1
C For Sale 2007 GT500 Partout: Pittsburgh, PA S197 Mustangs For Sale (2005-14) 1
V SOLD 2007 4.0l V6 Convertible (Premium) with Pony Package. Low miles. S197 Mustangs For Sale (2005-14) 1
D Gas milage drops for 2007 GT 2005 - 2009 Specific Tech 3
darien87 2007 GT overheats when A/C is on (even at freeway speed) 2005 - 2009 Specific Tech 8
C Progress Thread Introduction/Preview to my Custom 2007 Mustang 2005 - 2014 S-197 Mustang -General/Talk- 1
M 2007 GT Evap Hose ID for newb 2005 - 2009 Specific Tech 0
WildFire07 Engine Engine Stalls with AC on 2007 Mustang GT 4.6L 2005 - 2009 Specific Tech 20
C Engine What size wrench for 2007 oil pan drain plug? 2005 - 2014 Specific V6 Tech 0
M Worth Buying 2007 GT Premium? 2005 - 2014 S-197 Mustang -General/Talk- 3
LetsDance3166 2007 GT/CS 6-speed conversion 2010 - 2014 Specific Tech 0
M SOLD 2007 Mustang GT low miles one owner S197 Mustangs For Sale (2005-14) 1
E Replacing the Shaker 500 CD radio 2005 - 2014 S-197 Mustang -General/Talk- 0
onefaststang 2007 3v cam options 2005 - 2009 Specific Tech 12
0 2007 OEM HOOD 2005 - 2014 S-197 Mustang -General/Talk- 1
E Drivetrain 2007 mustang gt manual shifting issue!!!! 2005 - 2009 Specific Tech 3
Misneachail 2007 Ford Mustang v6 convertible problems extedning from brake light switch replacement 2005 - 2009 Specific Tech 0
K 2007 Ford Mustang gt 2005 - 2014 S-197 Mustang -General/Talk- 0
A 2007 conv. Windows dont work 2005 - 2014 S-197 Mustang -General/Talk- 0
S New to the forum looking for info on a 2007 California Special 2005 - 2014 S-197 Mustang -General/Talk- 1
J 2007 v6 - Convertible top goes down, won’t come back up 2005 - 2014 Specific V6 Tech 2
P 2007 Mustang GT No Windshield Fluid Cant Hear Pump 2005 - 2009 Specific Tech 2
N Hi from PA - Alloy 2007 GT The Welcome Wagon 2
S 2007 V6 Manual - Turns Over - No Start 2005 - 2009 Specific Tech 4
0 2007 GT - TCS light 2005 - 2009 Specific Tech 3
R 2007 gt 2005 - 2014 S-197 Mustang -General/Talk- 1
J 2007 v6 cooling fans/electric windows causing engine stumble 2005 - 2009 Specific Tech 5
0 2007 Shelby GT The Welcome Wagon 0
A 2007 Shelby GT500 wide body kit? 2005 - 2014 S-197 Mustang -General/Talk- 1
G Drivetrain 2007 GT/CS Trans/shift trouble 2005 - 2009 Specific Tech 0
G Drivetrain 2007 GT/CS 2005 - 2009 Specific Tech 0
H 2007 GT/CS uneven front height 2005 - 2009 Specific Tech 4
R 2007 Shelby GT500 - Front Strut Tower Brace 2007 - 2014 Shelby GT500 Tech 0
F Engine V6 2007 extra heat under hood when off 2005 - 2014 Specific V6 Tech 0
D 2007 gt supercharger decisions, 2005 - 2014 S-197 Mustang -General/Talk- 1
E 2007 Dash Lights and Brake Lights Stuck 2005 - 2014 S-197 Mustang -General/Talk- 0
T Paint and Body 2007 V6 Convertible - Rain water leaking under dash? 2005 - 2009 Specific Tech 5
M 2007 GT - Stereo continually thinks I’m loading a CD 2005 - 2014 S-197 Mustang -General/Talk- 1
P 2007 GT Grinding/creaking noise in rear when driving 2005 - 2014 S-197 Mustang -General/Talk- 0
D 2007 V6 Auto, NO Crank NO Start... 2005 - 2014 S-197 Mustang -General/Talk- 1
K For Sale 2007 Mustang GT parts Engine and Power Adder 3
Similar threads