Electrical 90-93 cluster in a 1987

Lawbreaker5.0

Member
Feb 20, 2009
543
2
18
Texas
I bought someone else's project :notnice: A 1987 mustang with a 87 thunderbird turbo coupe motor. It wasnt drivable and needed a fuel pump to get her to start. It had the 91 cluster connected but the tach didn't work among other things. I start investaging more and realize non of the wires were swapped. I did a quick google search and not much out there but i did read it can be done.

So....

Has anyone actually ever swapped clusters from a 90+ into a 87-89? I've searched over and over and the the article i see is very vague saying it can be done if you swap the wires....... Well i'm in the middle of it and i can't seem to get this thing figured out. There are multiple wires that i can't move over. the right connector, I'm left with Y/BK-Signal unit lamp to fuel signal relay, DG/LG coolant temp relay feed, PK/Y washer fluid low indicator, R/W switch to warning lamp. I might be forgetting one or two. I can take pics tomorrow and double check my work.


The oil pressure gauge moves to the middle of the gauge and then when you crank the car it drops to below 0 off the gauge. The Fuel gauge registers at 3/4 and then when you crank the car and start it goes up Past F and off the screen. I don't know if the temp gauge works. The battery gauge looks like its working. The Cel light is on and I was able to read codes of 58,81,82,84 but if I start the car and let it idle the engine revs up to 3k (before shutting it off). The AFR gauge starts at 15ish and drops all the way to 0, then back instantly to 17.

B33C2087-369C-4248-A30A-B78F6237C8BA.jpeg
 
  • Sponsors (?)


90sickfox

Wasn't a pretty sight...and I've got big hands
SN Certified Technician
Mar 2, 2015
6,555
5,630
203
45
It sounds like that car has multiple issues. The turbo couoe stopped production in 88 but the dash was wired like the 84 to 86 mustangs. The fuel pump sender is specific to 86 and reads opposite of a normal 87 sender.

That gauge cluster is going to be a nightmare to figure out. You won't know if it's rhe wire swap, the cluster, or another issue with the car. Going back to basics is the correct way. You need the 4 cylinder cluster so it should be cheap and easy to find. Grap the surround too.

Pull the code off the computer first. The code will let you know what year and type of car it came out of. The dash and engine harness has to match the year range for that code. The PO may have installed a bunch of mismatched parts or done some hacks to try and make stuff work.
 
  • Agree
Reactions: 1 user