Drivetrain AOD upshift while decelerating

foxbodybill89

Member
Jan 19, 2020
28
4
13
31
Sioux Falls, SD
For a few years now my 89 has had an annoying tendency, when slowing down to come to a stoplight, etc. it will shift down to first but while continuing to brake to a full stop it will suddenly shift back up to 2nd then down to first again at about 15-20 mph. I've readjusted the TV cable with no change, it does kick down well and otherwise behave during normal driving. It does seem to do this since I had put a new BBK throttle body on a few years ago, but idle and everything else are adjusted correctly that I can tell. I had found an issue with bad idle caused by the BBK TPS so I put a new Motorcraft one on which fixed a lot, but not this. Also has a newer Motorcraft IAC and all intake-related sensors when I swapped in the Explorer intake. I don't see anything for this specific symptom in the shop manual so hoping someone has some troubleshooting tips.
 
  • Sponsors(?)


KRUISR

Well-Known Member
Apr 16, 2015
417
140
63
50
Did you adjust the TV cable since installing the BBK throttle body? Is there anything done to your trans (shift kit, torque converter, fluid change) recently?
 

foxbodybill89

Member
Jan 19, 2020
28
4
13
31
Sioux Falls, SD
All of this since the TB was installed, I readjusted everything correctly when I put it in. Stock reman trans was put in about 7 years ago, it had shifted fine after that.
 

KRUISR

Well-Known Member
Apr 16, 2015
417
140
63
50
You should be able to disconnect TV cable from TB and move it freely. A quick question, when TV cable is disconnected from TB, how far from the hole (towards the firewall) is the connector sitting?

Rereading post #1... When the car downshifts to 1st and then up to 2nd, what RPM does it hit on that first downshift to 1st?