Calling all PMS users. New parts installed runs like crap!

Kdubslugga

Active Member
Jun 7, 2003
1,515
4
38
38
Akron, OH
Visit site
Ok so I had my car tuned by Anderson Ford Motorsport, and the car ran amazing with there tune. But the more horsepower bug bit me again, and I added a systemax intake. I also added 50lb injectors an Abaco DBX mass air meter and a Kirban AFPR. The car is going back to Anderson when I can, But right now i gotta get the thing running decent enough, right now it runs horrible. The car has a bad surging idle, will die all the time without giving it gas, its throwing a check engine light and the code is a mass air voltage out of range. So im thinkin it has a VAC leak possible lower intake gasket didnt seal. Also the pms always reads 10 degrees on startup, when the car stalls out the reading will go all over the place ive had -22 degrees 7 degrees 30 degrees, is this normal or what? Also on first try car starts right up but then will die, after a few tries you have to hold the gas for it to start, Anyway clues on this one guys?
 
  • Sponsors(?)


Grn92LX

Fidanza Man!
Founding Member
Jan 14, 2001
6,769
50
129
New York
Visit site
Try ADDING fuel in the cold temp menu and SUBTRACT fuel on start up. Playing with that should get the car to start up and idle fine.

try +20 - +30 for cold temp and try -30 for start up (cranking) fuel
 

DonMaximo

Member
Sep 25, 2003
217
5
19
Lewisville, Texas
If I understand you correctly, you've changed the injectors and MAF.

Is the MAF calibrated for the 50# injectors ?
if not, that could be a problem.

If you installed a new MAF, and your EEC (computer) is using the MAF transfer function from the original PMS tune, it's not a surprise that you're having problems. In fact, the surging idle is probably due to you running rich... as a result of changing the MAF.

Another thing, is that anytime you change a MAF or the MAF function within the EEC, your should be clearing KAMs by disconnecting the battery for 5 minutes...stomping on the brake (drain capacitors), and reconnect the battery.

"IF your MAF is calibrated for 50# injectors....
You can try to clear the KAMs and take your car out for a drive (20-30 minutes)... the EEC will relearn KAMs and "maybe" it will run better.

Otherwise, I would suggest putting your original equipment back on the car, clearing the KAMs, and then only install these goodies prior to getting a proper tune with someone who can modify settings within your EEC.

Again, from what little I know... if timing was not changed, then timing should not need to be fixed.

Good luck !
 

7upstang91

10 Year Member
May 30, 2008
936
124
74
Florida
Ok so I had my car tuned by Anderson Ford Motorsport, and the car ran amazing with there tune. But the more horsepower bug bit me again, and I added a systemax intake. I also added 50lb injectors an Abaco DBX mass air meter and a Kirban AFPR. The car is going back to Anderson when I can, But right now i gotta get the thing running decent enough, right now it runs horrible. The car has a bad surging idle, will die all the time without giving it gas, its throwing a check engine light and the code is a mass air voltage out of range. So im thinkin it has a VAC leak possible lower intake gasket didnt seal. Also the pms always reads 10 degrees on startup, when the car stalls out the reading will go all over the place ive had -22 degrees 7 degrees 30 degrees, is this normal or what? Also on first try car starts right up but then will die, after a few tries you have to hold the gas for it to start, Anyway clues on this one guys?

Dang, mine 331 is doing a similar thing. Surging from 600rpm to 1500rpm?? Did you try to change the plugs? I was going to try that first.:shrug:
 

Kdubslugga

Active Member
Jun 7, 2003
1,515
4
38
38
Akron, OH
Visit site
I know its something I just did, cause the thing ran great before i did the swap. I think what im gonna do is just put a new lower intake gasket set on, and just kinda do process of elimination, I used fel pro 1250s and im not a big fan of the paper gasket, would def like a thicker gasket.
 

7upstang91

10 Year Member
May 30, 2008
936
124
74
Florida
I know its something I just did, cause the thing ran great before i did the swap. I think what im gonna do is just put a new lower intake gasket set on, and just kinda do process of elimination, I used fel pro 1250s and im not a big fan of the paper gasket, would def like a thicker gasket.

Same here. I do not blame you. Could you pm me if you find out the problem? I would like to help you but I have enough projects, but I am going to tackle this one next. I'll let you know if I find any thing else.
 

Kdubslugga

Active Member
Jun 7, 2003
1,515
4
38
38
Akron, OH
Visit site
Well i got the car running long enough to throw some codes today. Code 66 and a code 31. Code 66 is a mass air code which makes sense cause if it had a vac leak i could see it throwing this code. Code 31 confused me, it is an EVP or EGR code, i tested to see if the egr held vacuum it did not, i took the egr off inspected it, and the rubber diaphram is not seated right around the pintle which im assuming is causing a good vacuum leak. Im hopeful this fixes the problem! Ill let ya know