Desperate help needed

BlueChappy570

New Member
Jul 22, 2020
5
0
1
51
Port St. Lucie
2005 Mustang Gt premium, 5 Speed manual, 143K miles, Roush CAI, MSD Coils, fuel injectors 3 yrs old, BBK catted X-Pipe, Muffler delete…

So, I drive to Walmart the other day and everything was fine. I start my car afterwards and I hear a valve tick. It was time for an oil change so I thought that may be why the ticking was there. I pull out of the parking spot, and as I press the gas, it stuttered so bad, the car was almost bucking…

I start limping it home and after 2 minutes of that, it ran decently. It still was not at full power, maybe 80% power, but the bucking and huge hesitation was gone.

I run the codes and got a bunch. See pictures.

After reading some forums, I see that one of the codes could be caused by bad diodes from the alternator. I replaced the alternator and cleaned the codes. Car still did the same thing. Idled great, but as soon as I go to drive it, it hesitates and bucks. I
90CA33C5-791D-49E5-B0BA-C5B5012854ED.jpeg
changed the Cam Positioning Sensor on Bank 1 (passenger side), still same thing. I changed my oil, MAF Sensor, Fuel Filter. Still same thing… idles great… as soon as I go into first gear and give it gas, it grumbles, hesitates, and bucks.

Please help….
 

Attachments

  • 4E3372A9-6BBA-4BB8-B884-A243E783A01A.jpeg
    4E3372A9-6BBA-4BB8-B884-A243E783A01A.jpeg
    519.5 KB · Views: 16
  • 81664726-8B81-4756-8E60-82F95A64991B.jpeg
    81664726-8B81-4756-8E60-82F95A64991B.jpeg
    523.8 KB · Views: 20
  • A91F8B70-A115-44EC-B76C-F005A3039A67.jpeg
    A91F8B70-A115-44EC-B76C-F005A3039A67.jpeg
    531 KB · Views: 18
  • E4834B74-6DD3-4C53-8762-191513B01792.jpeg
    E4834B74-6DD3-4C53-8762-191513B01792.jpeg
    542.4 KB · Views: 17
  • 8FA231F0-C9E4-4E65-AE68-41C3F4B0F03E.jpeg
    8FA231F0-C9E4-4E65-AE68-41C3F4B0F03E.jpeg
    539.5 KB · Views: 19
  • B7E1EF0A-5326-4A14-935C-696C60F23603.jpeg
    B7E1EF0A-5326-4A14-935C-696C60F23603.jpeg
    543.6 KB · Views: 14
  • 7E24826A-3C32-41FB-A8EA-FE4A98C22A61.jpeg
    7E24826A-3C32-41FB-A8EA-FE4A98C22A61.jpeg
    541.3 KB · Views: 19
  • 77872C84-717B-455D-885C-DE8BA0196E48.jpeg
    77872C84-717B-455D-885C-DE8BA0196E48.jpeg
    543.1 KB · Views: 18
  • 006EDF6A-B846-45E5-9324-FA216B86E3F5.jpeg
    006EDF6A-B846-45E5-9324-FA216B86E3F5.jpeg
    513.3 KB · Views: 19
  • Sponsors (?)


Bullitt95

15 Year Member
Jun 13, 2007
1,638
81
79
Cyprus
www.angelfire.com
The valve timing components seem to have a design life of about 150k miles under normal use so they're definitely due for replacement. Don't use anything else but Ford Performance items:



You can Google the part numbers to search for the best prices.

I'd also strongly recommend that you replace the oil pump at the same time. The '13-14 GT500 unit is an inexpensive upgrade and fits directly. Just add a new 4.6 3V oil pump pick up tube with screen to complete the installation.