Engine tick and vibration

010310V8

New Member
May 14, 2019
2
0
1
31
Chandler, AZ
I have a 2010 GT manual with 140,000 miles and I have started to notice a few things. I understand it is a high mileage car and will start to develop issues but I could use some help pin pointing what to tackle.

Issue- Ticking noise, oil leak, and engine vibration at 2000 RPM.

Any assistance would be greatly appreciated.
Thank you!
 
Last edited:
  • Sponsors(?)


racerraj

Founding Member
Dec 17, 2001
493
32
39
Dickson, TN
Ticking noise on mine was rockers/lifters. Vibration only at 2k? Perhaps the harmonica balancer is slightly off balance? Oil leak from where? Or what area?
 

010310V8

New Member
May 14, 2019
2
0
1
31
Chandler, AZ
Ticking noise on mine was rockers/lifters. Vibration only at 2k? Perhaps the harmonica balancer is slightly off balance? Oil leak from where? Or what area?
For your rockers/lifters did you need to replace them or just re torque them down? The vibration is subtle but becomes more pronounced at 2000 RPM. I was assuming it may have something to do with the flywheel.
The oil appears to coming from the oil filter but I have done hundreds of oil changes and doubt I installed it wrong.
 

racerraj

Founding Member
Dec 17, 2001
493
32
39
Dickson, TN
I replaced them. The rollers on the lifters were bad. Scored the cam, but I was able to polish the lobe. Happens more on the passenger side, oil goes there last. I replaced the lifers while I had the rockers off, just to be sure they weren't a problem. I hope to get caught up with the Honey Do Home update by Fall and replace all the rockers and lifters. Balancer, Clutch, Flywheel and even misfire could cause the vibration. I don't recall that being a common "this is the fix" problem. Oil Filter - Long ago, the filter I pulled off a car my sister had left the gasket on the block. So when I put the new filter on, it was double gasketed. That leak, but it was a very noticeable leak, I fixed it right away. It would be nice if changing the filer would fix it.
 

JmP6889928

You might slide out if you are going too fast.
May 18, 2019
2,169
2,743
133
63
Southwest Michigan
I believe that has a dual mass flywheel and it's probably going bad. I had the same thing at 85K on my v6 and I changed it over to a single mass flywheel and all vibrations went away.