Foxbody Mustang Cruise Control information, location, wiring diagrams

Mustang5L5

Put lubricant all over the balls
Mod Dude
Feb 18, 2001
39,465
15,317
224
Done a little research into this and figured what I learned should be put into a thread and added to the tech sticky. As you can imagine, nobody really gives much thought to cruise control on these cars, so many searched threads had dead ends. So many this will help someone out down the road.

This will cover 86-93 Mustang cruise, and is incomplete as i can't investigate every scenario.

Cruise control component locations:

The servo mounts in the same location for all years 86-93. Two predrilled holes exist inside the driver's side fender to mount the servo. One vac line runs to the vacuum tree and has a check-valve inline. A cable exists the servo into the engine bay and connects to the throttle body arm. A wiring harness exits the servo and enters the interior of the car and connects to the cruise control amplifier. Another vac line enters the interior and connects to a vac switch on the brake pedal arm. This arm vents to atmosphere when the brake pedal is pressed.

(click thumbnails to enlarge)
FB75F87C-7582-4FB0-ABB5-6DB88D5A515D.jpeg

The cruise control cable can be removed from the servo by way of two bolts. The cable extends into the engine bay, and connects to the throttle body.
1612453911014.png


The amplifier was mounted in two spots. 86-88 (possibly earlier) had the amplifier mounted to the brake pedal assembly. The mount holes for the later style 89+ bracket exist in the 87-89 cars (I believe for the 2.3 fan controller) so you can mount the amp either way here.
AEEEBE40-17D2-4A4F-A1D5-82CBACC024A3.jpeg

89-93 had the amplifier connects to the LH cowl area under the dash. The mount holes exist on the 86-88 if you choose to mount an 89+ amp with this style bracket. You’ll likely need the dash off to actually get to it however

7D780CAB-5C88-4465-B61F-EB287331D05B.jpeg

There are two harness plugged into the amplifier. One harness connects to the servo and the other is the body harness that gets fed from the steering switch and VSS and other inputs. Wire pinouts/colors/ID in the next post

Cruise control Amplifiers:

I've identified at least two different cruise control amplifiers at this time. There may be additional P/N's. E9 refers to a 1989 engineering part number

E9ZF-9D843-BA (Yellow/white box)
E9ZF-9D843-AA (Black box)
At this time, the differences are unknown.

Suspected but not confirmed 80-86 unit
E0AF- 9D844-AA(black box)

Photo of E9ZF-9D843-AA black unit with 89-93 mount bracket
1611332344510.png

Photo of early 86-88 style mount bracket (P/N unknown)
1611332451780.png
Cruise control pedal components:

Pedal assemblies in cars with cruise control have additional components added. These parts are bolted on, and can be swapped to non-cruise assemblies. They consist of a brake pedal vac dump switch and mount, and a clutch switch and mount. The AOD's only have the brake pedal switch. The clutch switch plug on the dash harness is jumped out. Both cars feature a plastic bump stop that contacts the brake pedal switch that mounts on the brake pedal arm.


1611331602201.png


Part numbers I've found:

Clutch pedal release switch and mount:
E1DB-9F645-AC (1981- )
E9ZB-9F645-BA (1989-1993)
F4ZZ-9A837-A (1994+)

The above switches all interchange, and likely you'll find the F4 part more commonly.

Brake pedal vacuum dump depressor (black plastic tab on brake pedal
E62C-9C962-AB


Column harness

This info is incomplete. 85-89 cars feature a contact plate and a brush assembly. Non-cruise cars will only have 2 contact points for the horn, while cruise cars have a 3-finger brush. The part number for the 85-89 brush is E5ZZ-9C899-B and E6ZZ-9C899-B At this time I do not have info for the 90+ harnesses, but assume there may be a difference


1611331679303.png


1990-1992 cars use a similar "brush" with 3 fingers.

FOZZ-9C899-B 1990
F1ZZ-9C899-A 1991-1992 (superceeds prior part number)


1611335275348.png

1993 Cars use an unobtaining clockspring. F3ZC-14A664-AB. Unsure if there are cruise/non-cruise differences

1611335380634.png
 
Last edited:
  • Like
Reactions: 2 users
  • Sponsors (?)


Mustang5L5

Put lubricant all over the balls
Mod Dude
Feb 18, 2001
39,465
15,317
224
Here are the wiring diagrams by year. For the most part they are identical with some minor differences 91-93 has a wire color change, so those are listed separate in the next post.

86-88. VSS is only used for cruise control equipped cars during this years. Non-cruise do not have a VSS equipped and will need it added. The wiring is clipped to the trans -member.
A531B6C6-A368-4306-9AE5-E3CF3E460877.jpeg






1989 is the same except the VSS signal is split and also used by the Mass Air ECU. Essentially the CC portion of the wiring is the same.
6DA6D93D-373A-47E2-89FC-F834DDC9D517.jpeg





1990 (2 images below) is the same as '89 other than some detail on how the EEC monitors the VSS on the 2.3L. All 5.0's monitor.
E05487D4-0DE6-46B9-9993-2F0F5F454E2E.jpeg

61C31B5C-AA4F-4A40-8971-D454E05DD319.jpeg




Connector pinouts for 86-90
CF7A3EF4-D8CF-4401-B81F-81C727FBF3E0.jpeg
 
Last edited:
  • Like
Reactions: 1 user

Mustang5L5

Put lubricant all over the balls
Mod Dude
Feb 18, 2001
39,465
15,317
224
1991-93 seems to have a change in wire colors in the body harness. The servo wiring stays the same, but colors on the body to amplifier wiring do change. I believe the function of the wire stays the same, just the color change.

The wiring diagrams change through the EVTM's slightly to show different layouts. 92-93 just show how the stop lights are integrated. FYI, if you run LED brake lights, the cruise may be inop. You may have to run load resistors to simulate a load so that CC can operate.

One unrelated change you can see is that ALL 2.3L use the VSS for the EEC in 1991. Prior to that, only Cali 2.3L monitored the VSS

91 diagram
D1E7B8EB-4EDB-42E6-8840-C1B17BE7BAF5.jpeg
463F4BD5-A24E-4957-B179-DA56BC282D3E.jpeg




This is the 92-93 Diagram. Its identical other than detailing how the stop lights are integrated
ADF94178-D2EF-43E1-A117-C13CDBE96A2B.jpeg

DBB6AF7C-B6C3-4203-A092-69B4BDD09A54.jpeg



Connector pinout. This applies to 91-93 only as the wire colors on the 86-90 differ slightly
51C49BD8-FBF1-4D74-83A1-877C608670F2.jpeg
 
Last edited:
  • Like
Reactions: 2 users

General karthief

wonder how much it would cost to ship you a pair
Mod Dude
Aug 25, 2016
23,699
8,760
203
EDIT: POST BORROWED BY MUSTANG5L5 to add more content. Sorry General


Cruise control brake cancel vacuum dump valve

One common failure mode of the cruise system is misadjustment of the vacuum dump valve on the brake pedal

1654870520452.png


The above is from an 87 thunderbird, but fox mustang is similar. Tje valve is ALWAYS OPEN to atmosphere unless the brake pedal arm is in contact with the yellow plunger on the bottom, which closes the valve. This allows the servo to build and hold vacuum, which is how it moves the throttle blade open and close.

When you tap the brake pedal, the vacuum dump opens and bleeds off all vacuum preventing the servo from being able to control the system. Often times, folks will replace a booster or change out the pedals (AOD to T5 swap) and not adjust this correctly. If oyu reach around to the back where the vacuum line is, you should be able to push the valve towards the brake pedal which will fully depress the plunger and close the valve. Often, its too far away leaving it completely or partially open.

If you suspect a leak, remove it and test it by blowing through it while activating the plunger.
 
Last edited by a moderator:
  • Like
Reactions: 1 user

Wayne Waldrep

Before I post a pic, do you have one of yours?
15 Year Member
Apr 14, 2003
1,260
690
143
Awesome! I've been begging for info on this. My cruise slowly stopped working right then altogether. Never had a response to help questions so when I can, I'm going to read all this. I have a whole folder (digital) of info on cruise control. I grabbed every diagram and post I could find but nothing helped me.
Thanks Mike!
 

Wayne Waldrep

Before I post a pic, do you have one of yours?
15 Year Member
Apr 14, 2003
1,260
690
143
I haven't read all this yet but i skimmed past a sentence on the VSS. Hoping you can post info on the relationship of this sensor to the CC and any means of troubleshooting it. I'm thinking this may be part of my trouble. Now it's not even coming on so there's something else as well.
 

Mustang5L5

Put lubricant all over the balls
Mod Dude
Feb 18, 2001
39,465
15,317
224
Cruise control uses the VSS to be able to tell of its maintaining speed. Without a VSS signal it will default to off.

after 1989, the ECU also used the VSS signal, so if this sensor/signal were to fail, the ECU would show a code 29
 
  • Useful
Reactions: 1 user

Mustang5L5

Put lubricant all over the balls
Mod Dude
Feb 18, 2001
39,465
15,317
224
Troubleshooting procedure.


Description and Operation

The speed control system is composed of On-Off, Set-Acc, Coast and Resume switches. The system contains vacuum hoses, servo (throttle actuator) assembly, speed sensor, amplifier, check valve assembly, and depending on model and year, a clutch switch, a manual lever position switch, stop light switch, or vacuum dump valve, an actuator (servo) and an actuator cable.

To operate speed control system, engine must be running and vehicle speed must exceed 30 mph. When On-Off switch is actuated, the system is ready to accept a set speed signal. When vehicle speed stabilizes (above 30 mph), and the On switch is engaged, the operator may depress or release the Set-Acc button. This speed will be maintained until a new speed has been set, brake pedal has been depressed, or the system is turned off.
The vehicle speed may be reduced by applying the brake or clutch pedal and then resetting the speed using the method outlined above or by depressing the COAST switch. When the vehicle has slowed to the desired speed, the COAST switch is released and the new speed is set automatically. If the vehicle speed is reduced below 30 mph (48 km/h), the operator must manually increase the speed and reset the system.

Switch Testing

Testing and Inspection

Disconnect connector at the amplifier assembly, refer to SCHEMATIC DIAGRAMS/ELECTRICAL AND ELECTRONIC DIAGRAMS. Perform the following checks:

1. Connect a voltmeter, part No. 014-00407 or equivalent between the light blue-black lead and ground. Depress the On button and check for battery voltage.
2. Turn ignition Off and connect an ohmmeter between the light blue-black hash lead and ground.
3. Rotate steering wheel throughout its full range while making the following checks:

1. Depress Off button and check for a reading between 0 and 1 ohm.
2. Depress Set button and check for a reading between 714 and 646 ohms.
3. Depress Coast button and check for a reading between 126 and 114 ohms.
4. On models which incorporate Resume, depress Resume button, check for a reading between 2310 and 2090 ohms.

4. If resistance values are within specification but needle fluctuates, remove steering wheel and clean the brushes. Apply a light coat of lubricant ESA-M1C189A or equivalent to the slip rings. If resistance values are above the allowable limits, check the switches and ground circuit.
5. Reconnect the connector at the amplifier.



Cable Adjustment;

1. Remove the cable adjusting clip from the cable housing.
2. Pull lightly on the cable until all of the slack is taken out.
3. Maintain light pressure on cable, then install the cable adjusting clip and snap into place.


Servo testing: Also make sure that you have good vacuum at the servo.

Testing and Inspection

1. Separate the eight pin connector from the amplifier.
2. Connect an ohmmeter between the orange/yellow (circuit 144) and the grey/black (circuit 145) leads at the eight pin connector, refer to SCHEMATIC DIAGRAMS/ELECTRICAL AND ELECTRONIC DIAGRAMS. Resistance should measure 40-75 ohms.
3. Connect an ohmmeter between the orange/yellow (circuit 144) and the white/pink (circuit 146) leads at the connector. Resistance should measure 100-150 ohms.
4. Connect an ohmmeter between the purple/light blue (circuit 147) and Yellow/Red (circuit 148) leads. Resistance should measure 20,000--30,000 ohms.
5. Connect an ohmmeter between the purple/light blue (circuit 147) and brown/light green (circuit 149) leads. Resistance should measure 40,000--60,000 ohms.
6. If proper resistance is not obtained check the wiring and servo separately for damage and replace or service as required.
 
  • Wow
  • Useful
  • Like
Reactions: 2 users

foxbodybill89

Active Member
Jan 19, 2020
122
58
38
So, I asked a question on here last year when wiring in my Dakota Digital dash. The cluster has a cruise control light I'd like to make functional that just needs a 12v signal when the cruise is on but I could not figure out any wires I could tap for that. I have the EVTM book and have studied it thoroughly, the wire I did tap only flashes the light momentarily when I press the set accel or off buttons, I'm guessing all the voltages in the system are momentary triggers not constant.
 

Wayne Waldrep

Before I post a pic, do you have one of yours?
15 Year Member
Apr 14, 2003
1,260
690
143
So, I asked a question on here last year when wiring in my Dakota Digital dash. The cluster has a cruise control light I'd like to make functional that just needs a 12v signal when the cruise is on but I could not figure out any wires I could tap for that. I have the EVTM book and have studied it thoroughly, the wire I did tap only flashes the light momentarily when I press the set accel or off buttons, I'm guessing all the voltages in the system are momentary triggers not constant.
I'm pretty sure one of them will be constant.
 

Mustang5L5

Put lubricant all over the balls
Mod Dude
Feb 18, 2001
39,465
15,317
224
Another point to make.

make sure your steering wheel contacts are free of contamination/corrosion/oxidation. You can unplug the harness at the column and use a multimeter to test continuity by pressing the buttons and seeing if you get the proper values listed above in the diagrams.

on this harness, the connection was poor. A few mins with a piece of sandpaper and the connection was must more robust. Definitely something to check if your cruise isn’t working. You can pull the column trim and unplug the blue/purple/black harness to test

8D4813CB-DCB7-4B2B-973A-FFAAE3F9DECF.jpeg





Here is the part number for the 87-89 steering whee contact plate

E53C-3L503-AA

992F6F3F-8A1E-4EE1-9127-7F92C6D593AC.jpeg
 
Last edited:
  • Like
  • Useful
Reactions: 1 users

Mustang5L5

Put lubricant all over the balls
Mod Dude
Feb 18, 2001
39,465
15,317
224
I’m having an issue in which, when I press coast, the car accelerates instead of slowing down. Any ideas?

test the switches first. The cruise module receives its signal from the switches based off resistance. The values need to be a specific range to register a command
4526D109-9DA8-4A53-ACF8-E981EC1A3FE6.jpeg

Pull the column trim and located the cruise control wiring and unplug it. Wire colors differ by year.

I’ll need to put a wire color test matrix together, but if you pull the column harness out, there are three wires.

on 85-89 the colors are purple, black and blue.

horn: solid continuity purple to black
Cruise OFF: solid continuity blue to black
Cruise ON: solid continuity purple to blue
Coast : 120ohms blue to black
Accel : 680 ohms blue to black
Resume: 2200 ohms blue to black

Sounds like when you hit coast, the resistance value might be near 680ohms vs the 120ohms you need. Might indicate corrosion on the contact wheel/pin which is increasing the resistance.

the same test would apply to 90-93 cars but I don’t know the three wire colors. The EVTM is actually off in terms of the colors they state should be in the harness. Regardless of the wire colors, the above values are what should ring out of you test the switches. I would test them at the column harness, to take into account how good the contact is on the contact plate on the pre-93 cars

edit: looks like the 90-92 cars, substitute purple for a yellow wire
 
Last edited:

IgottaV8

New Member
Jan 31, 2021
2
0
1
test the switches first. The cruise module receives its signal from the switches based off resistance. The values need to be a specific range to register a command
4526D109-9DA8-4A53-ACF8-E981EC1A3FE6.jpeg

Pull the column trim and located the cruise control wiring and unplug it. Wire colors differ by year.

I’ll need to put a wire color test matrix together, but if you pull the column harness out, there are three wires.

on 85-89 the colors are purple, black and blue.

horn: solid continuity purple to black
Cruise OFF: solid continuity blue to black
Cruise ON: solid continuity purple to blue
Coast : 120ohms blue to black
Accel : 680 ohms blue to black
Resume: 2200 ohms blue to black

Sounds like when you hit coast, the resistance value might be near 680ohms vs the 120ohms you need. Might indicate corrosion on the contact wheel/pin which is increasing the resistance.

the same test would apply to 90-93 cars but I don’t know the three wire colors. The EVTM is actually off in terms of the colors they state should be in the harness. Regardless of the wire colors, the above values are what should ring out of you test the switches. I would test them at the column harness, to take into account how good the contact is on the contact plate on the pre-93 cars

edit: looks like the 90-92 cars, substitute purple for a yellow wire
Thank you I will check next chance I get.