HELP MY CAR IS RUNNING TERRIBLY!

thatcarguymatt

New Member
Jul 7, 2020
1
0
1
24
NJ
Hi Everyone,

New to the group. I have an 03 Mustang GT, it has about 118k miles on it. A little while back I was driving the car on the highway and I heard a loud bang followed by crazy missfires. I got the car towed to my mechanic. Spark plug blew out of the head so he Heli Coiled it. along with replacing all the plugs, and coils. I also had the fuel pump done earlier this year.

Recently my car has been running weird. It will pull fine under light throttle most of the time. and if i slowly apply more gas its usually ok. HOWEVER. when the car is under more load, like high gear slower speed, and i try to accelerate, it missfires like crazy and has no power, then it will catch, and fire correctly for a second and pull fine then back to miss. Its just not smooth linear power as it should be.
CODES
P0113
P0102
P0455
P0457

It seems like its running ok. But I want to fix it so its running as it should be, I am still daily driving it at this time about 30 miles a day. MY GAS MILEAGE SUCKS TOO!

Any tips on what it is or how to fix much appreciated
 
  • Sponsors(?)


MattMan02GT

Active Member
Jul 24, 2018
100
8
28
32
Albany, NY
The last two are EVAP system leak codes. Have you checked your gas cap to ensure it has a tight seal? Or even put a little grease on it to check?

Another big issue with these cars at this age is there fuel filler neck grommet. This seals around the filler neck where it slides into the tank. Has yours ever been replaced? If you smell gas for a while after you fill your tank all the wall up it's a good indicator yours is dry rotted and leaking.