Scan tool unable to connect to computer


New Member
Jul 30, 2007
I have a 1995 Cobra, and the dealer tried to connect their scan tool to my car and they were not able to read any codes or have their tool read anything from the ECU. They also checked all the fuses which are all good.

Any ideas? They said the next step is to trace wiring and etc which would take lots of hours and money.

The car runs great, have no issues with it at all. Engine is 100% stock, no mods.

The only thing that is weird is the temp gauge goes to max about every other time i drive (car isnt overheating though), and the oil pressure gauge is always pegged high. Not sure if its related to the ECU.

Nonetheless, any ideas on why the scan tool wont connect to my ECU?

  • Sponsors (?)

First of all, did they use the (correct) connector under the hood behind the pass. side strut tower to connect the scanner? Or did they try the connector under the steering column, which actually isn't connected to anything?

Secondly, the temperature spike could be due to a pocket of air that, for some reason, never managed to escape the upper intake. You might want to change-out the temp. sensor in the intake (driver's side, near the back below the fuel rail).

For the oil pressure, don't worry about it. The stock gauge is essentially a dummy indicator, the output voltage of the sensor doesn't actually vary, its just an on/off switch. So as long as its showing something, you should be fine. But it would not be a bad idea to upgrade to a "real" oil pressure gauge. I'm in the same boat.
Like mentioned...sounds like the wrong tool..Tell us it wasn't a Ford dealership...:D

Your gages going wacky could be a simple ground problem...our gages are electric so if not grounded or a short/loose connection, you get what your seeing.
Check the condition of the ground strap on the drivers motor mount to the fenderwell, t may be inside a Black plastic tube. Check the condition bolt where the strap and Neg cable connect to the block, is it all rusted up??. Check the Green ground screw by the battery...and the Neg cable... is the cable Green with crud or in good shape??
How old is the battery?? This alos will give bogus gage reading... oddly the gages tend to read high, when there's a ground problem... Been here had that...
I had the same problem not reading for a while with my matco scan tool. I didn't use it for a while and I had the battery disconnected a couple of times over the period of a month. one day I thought I would try it again and it worked! Other than time and having the battery disconnected it seemed to have cleared itself.
I've had similar problems before with the oil pressure guage, and it turned out that the wire to the sending unit was pinched behind the Power Steering/AC bracket. I'd bet either your sending units have gone bad or the wires are grounded somewhere.

have a buddy look at the guages while you disconnect the sending units, then ground the wire to the block (key has to be on, it won't shock you). If the guage goes to zero when you unhook the sender, and pegs when you ground the plug, the sender is bad. If it stays pegged with the sender unplugged, you probably have a grounded wire somewhere.

I would bet on the grounded wire issue, the Temp sending unit and oil press sending unit are on the same side of the motor and run next to each other joining along the top of the driver side of the intake... (underneath your upper :( )
Humm...I never had any problems out of my scanner. As far as the guages if the temp. is pegged and the car is not on the side of the road smoking then its ok. My temp and oil pressure guages read astronomical numbers a lot of the time. The stock gauges suck!!!
Comp issue was due to one of the connector wires being bad at the base of the connector under the hood. Wasnt to hard to spot and fix.

Still working on the temp and oil gauge issues. Ill post when i figure it out.

Thank you for all the help and replies.