1900 rpm at first idle/first start 88GT

elamorwey

New Member
Mar 1, 2022
5
0
1
Hello, this is my first time on this forum and site so i really dont know if im
doing this right. i want to learn most importantly but here’s where im getting stuck on,
I have an 88 GT 5speed hatchback, been doing a restoration on it, but most importantly the engine. went from a bone stock 302, to rebuilding the bottom end, new bearings, rods and flattop pistons with valve reliefs, E303 cam, added GT40 3 bar heads, cobra intake, 70mm tb, egr and smog delete, 24# injectors, along with shorty equal length headers and catted x pipe and well the main sauce which is the megasquirt 2 with innovate wideband. i got it all set up and running, have it at 12 degrees base timing, got the preloaded map adjusted to the initial specs needed to start the vehicle and boom! it idles at 1900-2100 rpm cold start and stays there at closed loop idle as well. i also noticed it sort of stumbles in a way while in 12 degrees base timing so i adjusted to 20 and it smooths out really good, but still idles at 2000 rpm. ive been playing around with tuner studio to get it to idle correctly but for the life of me i cannot correct the idle and im
pretty much stuck. also car will stall as soon as it fired until i switched the iac setting from “inverted” to “normal”. my question is, am i overlooking anything or did i do something wrong? i really dont know what else to do, im a newbie when it comes to tuner studio :/ any help is greatly appreciated, thank you guys!
 
  • Sponsors (?)


a91what

SendMeUrDataLog
Mod Dude
Apr 6, 2011
10,684
6,882
214
Some ms2pnp need the setting on inverted some of the newer ones it needs set to normal. What you need to do is a test on the idle valve, you can do this in the "warm up idle pwm" or in test modes. And sweep the valve from 30% to 90% if the rpm goes down with increased pwm% then you need to swap the valve direction. This test will also let you see how much pwm% gets you the idle you want.
 
  • Like
Reactions: 1 user

elamorwey

New Member
Mar 1, 2022
5
0
1
Some ms2pnp need the setting on inverted some of the newer ones it needs set to normal. What you need to do is a test on the idle valve, you can do this in the "warm up idle pwm" or in test modes. And sweep the valve from 30% to 90% if the rpm goes down with increased pwm% then you need to swap the valve direction. This test will also let you see how much pwm% gets you the idle you want.
thank you for replying! and i did use the test mode a couple times, i had it at increased up to 40% pw and it would make the idle go down
by swapping the valve direction do you mean changing it back to “inverted” mode on TS since i currently have it on “normal” or the actual valve lol? also do i need to have the iac at a specific Hz? i have the oem iac valve installed
 

a91what

SendMeUrDataLog
Mod Dude
Apr 6, 2011
10,684
6,882
214
okay i will change the frequency around that range and test it out. thank you! and i didn’t quite catch to what you said yes to, should i change the setting on tuner studio for the iac direction (normal/inverted) or the actual valve itself?
Yes, swap the idle valve direction.

Typical forum responses will be given in the order that questions are asked.

If you have not yet, go to the digital tuning forum sticky and watch my videos on idle setup.
 

elamorwey

New Member
Mar 1, 2022
5
0
1
Yes, swap the idle valve direction.

Typical forum responses will be given in the order that questions are asked.

If you have not yet, go to the digital tuning forum sticky and watch my videos on idle setup.
hello! i got home finally and tested it leaving at inverted mode how you said, but now the car wont idle or even stay on unless i give it a tiny bit of gas. also i have my timing at 14* (i followed the procedure to match it to TS) and set FRP at 39 psi vacuum off. ive been using the test mode for the iac to see but it wont affect the idle

and ahhh okay okay that makes sense, thank you for clearing that out! and okay i will check them out in a bit.