Engine 89 mustang lx 2.3 Starting problems

Kkylon0

New Member
Aug 16, 2018
5
0
1
25
Des moines
Hey I’m new here and just got my second foxbody
I found a clean one with low miles and I’m the second owner
I bought it knowing it didn’t start and I thought I would a easy and simple fix (might still be)
The person I got it from said a fuel line was broken and that’s why it did not run
So I found and “fixed” the fuel lines
They were the return and pressure line right before the metal lines ran up to the fuel pressure regulator and other thing I don’t know
I changed all the basic tune up ignition components including the icm on the distributor
And had a hard time getting it all lined back up
And it still doesn’t start
It cranks and blows smoke out off the throttle body while cranking
Does anybody know what i did wrong and if I did the fuel lines right
All Hazing is accepted as long as your helpful
Thanks

Will post pictures of my setup next day
 
  • Sponsors(?)


RaggedGT

check back later..
Mod Dude
Jul 20, 2014
4,194
2,824
193
35
Taylorsville ky
www.stangnet.com
Hard to say about the fuel lines without being able to see them.. Have you verified you have fuel and spark?
Checked the firing order? Did you remove the distributor?
Welcome to Stangnet
 

Kkylon0

New Member
Aug 16, 2018
5
0
1
25
Des moines
Hard to say about the fuel lines without being able to see them.. Have you verified you have fuel and spark?
Checked the firing order? Did you remove the distributor?
Welcome to Stangnet
Thanks for the welcome
It does have spark and some what fuel, just didn’t know if I need to route the pressure fuel line through the rail pressure regulator first or what?
Firing order 1342 but I’ll double check that definitely !
I did remove the dizzy to replace the icm then like a hundred more times to re time at TDC
I’ll double check everything and get the pics up here ASAP!
 

Kkylon0

New Member
Aug 16, 2018
5
0
1
25
Des moines
Hard to say about the fuel lines without being able to see them.. Have you verified you have fuel and spark?
Checked the firing order? Did you remove the distributor?
Welcome to Stangnet
Thanks for the welcome
It does have spark and some what fuel just didn’t know if I need to route the pressure fuel line through the rail pressure regulator first or what
Firing order 1342
I’ll double check the dizzy and make sure it’s on track
6F622BA3-1A0F-42BD-BC99-67907237D481.jpeg
DB30D182-C9D3-4F3C-8C75-6F3EBDBB6497.jpeg
6F934FDE-2329-452A-BAE8-606B8347BD57.jpeg
5F8A6F01-38F6-4E99-94F7-E3C98A8D61E1.jpeg
F1332D11-2011-4FAF-AFC2-DC19E00B0F22.jpeg
 
Last edited by a moderator:

Kkylon0

New Member
Aug 16, 2018
5
0
1
25
Des moines
Here’s the setup on the pictures above
#1-just a blurry picture I took on accident
#2- is a picture of where I routed the high pressure line to the back of the fuel rail (which sounds wrong when I say it but I could be wrong) right below the dipstick
#3-isn’t where the pressure and return line snapped off
And a where I did the quick fix to get her started
#4-where I connected the new
Lines to the return and feed
#5- just a better pic of the feee