Electrical 95 Cobra - Multiple electrical issues

ngiotta

New Member
Jan 29, 2019
9
0
1
California
Hello everyone!

Just bought a 95 Cobra a couple of days ago, that seems to be a bit of an electrical basketcase. These electrical components don't work or are malfunctioning:
  • Radiator fan (no low or high speed - fuse is fine though)
  • Cruise control
  • Dome lights don't turn on when either door is opened or the dimmer switch is rotated all the way to the left. They do work with the manual buttons on the dome itself.
  • Dash clock
  • Power port near shifter

  • Radio works
  • Instrument cluster lights work
  • Headlights work
  • Tail lights work
  • Windows work
  • Locks work
  • Cigarette lighter in console works
Not really sure what's going on with the gremlins in this one or if one thing or multiple thing causes all of those issues. Anyone else have similar problems, and if so, what was the issue?
 
  • Sponsors(?)


02 281 GT

Agreed...My wife has great Boobs
10 Year Member
Feb 3, 2009
1,808
1,053
164
Wichita Falls, TX
The first thing I would check is fuses. The switches on either side of the dome light are for the map lights. These are separate from the actual dome light in the middle.
 

ngiotta

New Member
Jan 29, 2019
9
0
1
California
Ok. I'm a total rube. The bulb in the middle is missing completely. I guess that solves that mystery, although, considering the other stuff that's wrong with the car, it is likely missing because it was staying on. The fuses all looked good, so I'm not sure what's going on with the power port, cruise control, etc. My main concern is the radiator fan now, but from what I've read on that, some people have replaced everything and it still doesn't work. I think I should try to jump the battery to the connector to see if the fan itself works, but there's 3 terminals. Anyone know which one gets negative and which gets positive?