cooling fan problem 3.8 liter

bakerd

New Member
Aug 31, 2020
3
0
1
44
erie pa
i have a 95 3.8 bought as is. no cooling fan or a/c comp. or temp gauge. replaced fan switch. sending unit. ccrm. still nothing. when fan switch unplugged fan comes on. when testing plug to ground 4.77 volts and fan turns off. when key is turned on the temp gauge creeps below cold. once in a while the clutch on ac will click.if its a ground issue where to i check? cleaned all under hood and engine ground
 
  • Sponsors(?)


bakerd

New Member
Aug 31, 2020
3
0
1
44
erie pa
1. Welcome to the Forums
2. This is the area where we post for tech help.

Do you mean that the A/C and Cooling fan do not work or are missing from the car?
they do not work. cooling fan will run when switch is unplugged. has 4.77 volts to ground and when testing voltage to ground, fan shuts off. new switch, ccrm, sending unit. temp gauge creeps below cold when key is turned on. all other gauges good. ive cleaned grounds under the hood and engine ground. occasionally i will hear the ac clutch engage briefly. bought the car like this and it cracked radiator by previous owner.
 

bakerd

New Member
Aug 31, 2020
3
0
1
44
erie pa
they do not work. cooling fan will run when switch is unplugged. has 4.77 volts to ground and when testing voltage to ground, fan shuts off. new switch, ccrm, sending unit. temp gauge creeps below cold when key is turned on. all other gauges good. ive cleaned grounds under the hood and engine ground. occasionally i will hear the ac clutch engage briefly. bought the car like this and it cracked radiator by previous owner.