Medusa Megasquirt.... help lol

  • Sponsors(?)


Blucifer99

I only understand every 3rd word
Jul 15, 2018
441
28
38
35
Port Mcnicoll Ontario
No problem, we all start somewhere. You should poke around the digital tuning forum a bit and see what some of the other guys are working with. Lots of knowledge on this board.
Anyways about the tune he currently has. Its not safe for the car at all.. I made some safer changes to his tune just incase he got itchy and wanted to start it. But the tune as of right now. I dont feel its decent enough for a start.. Hes gonna need ve scaled to suit the low imp injectors and possibly a safer timing table.. He has my fresh timing table from our first tune.. Which was a better place then he was first off.. His timing table had no rhyme or smoothness at all. Jumped from 17.9 at idle and held 31 all the way to redline. My thoughts are that someone just guessed at a timing table.. Also a bunch of other. Settings were totally backwards.. I did make some "safer" changes but like i said his tune is far far from ideal and it does need ur eyes on it steve to make it "as safe as possible" for what he has. He will be posting a copy of his tune once hes near the tuning laptop that has everything on it.. Ill be on the phone with him to walk him thru the process of how to load a copy of his tune on here. Hes old school and not good with computers lmfao. But stayed tuned... Pun intended haha
 
Last edited:
  • Haha
Reactions: Wilky-Medusa 2.0
Jun 15, 2019
58
5
18
45
lake george, ny
Anyways about the tune he currently has. Its not safe for the car at all.. I made some safer changes to his tune just incase he got itchy and wanted to start it. But the tune as of right now. I dont feel its decent enough for a start.. Hes gonna need ve scaled to suit the low imp injectors and possibly a safer timing table.. He has my fresh timing table from our first tune.. Which was a better place then he was first off.. His timing table had no rhyme or smoothness at all. Jumped from 17.9 at idle and held 31 all the way to redline. My thoughts are that someone just guessed at a timing table.. Also a bunch of other. Settings were totally backwards.. I did make some "safer" changes but like i said his tune is far far from ideal and it does need ur eyes on it steve to make it "as safe as possible" for what he has. He will be posting a copy of his tune once hes near the tuning laptop that has everything on it.. Ill be on the phone with him to walk him thru the process of how to load a copy of his tune on here. Hes old school and not good with computers lmfao. But stayed tuned... Pun intended haha
 

Attachments

  • Like
Reactions: Blucifer99

Blucifer99

I only understand every 3rd word
Jul 15, 2018
441
28
38
35
Port Mcnicoll Ontario
And steve.. theres no datalog yet with the 95lb low imp injectors. Hes only got a short datalog with the siemens 60lbs. But that datalogs useless cause of the bogus settings that he had in his tune.. We gotta make this tune safe enough so he can fire up. Get a good datalog of it idling then go from there..

also heres a picture of what medusas running i know its not a description of parts... but you can get a pretty idea from the pic that Shes a beast
 

Attachments

  • Clever
Reactions: Wilky-Medusa 2.0

Blucifer99

I only understand every 3rd word
Jul 15, 2018
441
28
38
35
Port Mcnicoll Ontario
Hey will.. I went thru your tune and finished what i started... i noticed i didnt fix the afterstart enrichments and warmup enrichments back to decent settings.. your afterstart enrichments were way off the charts.. same with your Warm ups.. also your tps based accel enrichments had some screwy info in there too.. .. now we still gotta figure out a decent Ve table for your injectors.. so bare with us.. and that isnt my strong suit ill be honest about that haha.. i had a hell of a time tryin to figure out my own, but this stuff is all do able with the amount of knowledge thats on this forum... so if steve could put his magic touch on this tune,. that would be swell. and then after he does his magic your gonna need to fire this thing up and take a datalog from the beginning all the way up to fully warm.. without that datalog we are all shooting blind
 

Attachments

a91what

SendMeUrDataLog
Mod Dude
Apr 6, 2011
8,634
5,058
204
30
Hillsborough county
I'm working on it, I want you to put the 60lb back in the car, the low impedance injectors need a resistor box. If this were a ms3 or was built for them in mind then they would be fine. We dont want to burn out the injector drivers.

I will take care of the tune, just get those injectors swapped out.
 
  • Like
Reactions: Blucifer99

Blucifer99

I only understand every 3rd word
Jul 15, 2018
441
28
38
35
Port Mcnicoll Ontario
Medusa update..

60lb siemens deka reinstalled... New rev.1.0.0medusa tune is loaded... Now were just waiting on Willy to get his timing light so we can go thru the regular routine of calibrating tables/tps/sensors/wideband/ then Verifying timing... so whenever he gets his timing light we will be doing the first start with a clean tune.. so fingers crossed nothings outta wack .. Stay tuned..
 
Jun 15, 2019
58
5
18
45
lake george, ny
Medusa update..

60lb siemens deka reinstalled... New rev.1.0.0medusa tune is loaded... Now were just waiting on Willy to get his timing light so we can go thru the regular routine of calibrating tables/tps/sensors/wideband/ then Verifying timing... so whenever he gets his timing light we will be doing the first start with a clean tune.. so fingers crossed nothings outta wack .. Stay tuned..
im trying to find log
 

Blucifer99

I only understand every 3rd word
Jul 15, 2018
441
28
38
35
Port Mcnicoll Ontario
somethings totally up with his timing... i got him to do just a cranking test with the timing light.. and while it was cranking he set the base timing to 10 degrees.. and it still wouldnt run on its own.. and that datalog is all over the place.... everything is all over the place.. idle valve pulse with and timing.... i duno man i think maybe those low imp injectors already have done there damage LOL.. cause i see all kinds of wrong in that datalog.. Steve your gonna have to step in on this one for sure cause somehow were gonna need to test that ms to see if the drivers are still good
 
Last edited: