Mustang v6 AC not working - please help

Alex3385

New Member
Jun 21, 2019
2
0
1
34
seattle
Hi,

I have a Mustang 2013 with 45k miles - few days back the AC stopped blowing cold air. I took it to Pepboys and they said there is no leakage and it is the compressor not engaging. I do get air from the AC vent but it is not cold. Also I do not hear/feel the clicking or starting AC noise when I push the AC button.
The shop said I need to get the entire compressor changed (along with dryer kit and expansion valve) - this was estimated to cost $2k.

This is a high cost and I wanted to get fellow members advice on whether there could be anything else going on which I should look into..

Thanks in advance
 
  • Sponsors(?)


Alex3385

New Member
Jun 21, 2019
2
0
1
34
seattle
Hi,

I have a Mustang 2013 with 45k miles - few days back the AC stopped blowing cold air. I took it to Pepboys and they said there is no leakage and it is the compressor not engaging. I do get air from the AC vent but it is not cold. Also I do not hear/feel the clicking or starting AC noise when I push the AC button.
The shop said I need to get the entire compressor changed (along with dryer kit and expansion valve) - this was estimated to cost $2k.

This is a high cost and I wanted to get fellow members advice on whether there could be anything else going on which I should look into..

Thanks in advance
While doing some research on this forum, I came across the paper clip jump start technique - should I try doing that and filling up freon to see if that works?