Need some advice!!!

Jan 6, 2019
2
0
1
24
Missouri
#1
Bought a 2006 gt from a shady used car lot. It has preformance upgrades. When i got it i had to put a new alternator and battery in as they were bad then had a new head unit put in.

About 5 days ago the gas guage started to fail. 2 days ago I actually ran out of gas on the highway. Once i filled it up the gas guage functions fine but 2 times has gone to E then back to accurate fuel reading.

*Today check engine light came on, system too lean, both banks. Car runs perfectly fine though.

*i just noticed that if i do over 110mph the ABS and traction control ligt illuminate for a split second and go off, and my radio resets(bluetooth disconnects). I tested this 3 times to make sure it wasnt just a one time thing.

Im going to see if i have any vaccum leaks tomorrow, but maybe a fuel pressure issue or electrical short?

Im now broke and this is goimg to cost me some money i bet. Any ideas? Advice very welcome!!!
 
Last edited:
  • Sponsors (?)

Jan 6, 2019
2
0
1
24
Missouri
#2
After driving last night ive found its when fhe rpm's go high is when the the abs and traction control illuminate.
 
Last edited:

Red_LX

I’m not much help unless you’re looking for ****!
Mod Dude
Nov 29, 1999
5,789
55
129
38
Morgantown, WV...where couches meet their doom
#3
Unfortunately these could be signs of water damage to the smart junction box (located in the passenger footwell). Very common on these cars as the cowl drains can become plugged with leaves and debris, and water fills up in the cowl until it spills into the passenger compartment- eventually it can cause shorts in the smart junction box and all sorts of electrical gremlins.