Electrical Parasitic Draw? Not Sure

  • Sponsors(?)


R82148V

Active Member
May 26, 2020
112
34
38
.....
Just picked up this Alt from PA Performance and the 4 gauge wire kit. Black matte powder coated. Was going to do 95 amps but figured do it once and do it right so I got the 130 amp. Crazy how beefier it is than stock. I'll let you know how the install goes.

1653569942943.jpeg
 
  • Like
Reactions: 1 user

R82148V

Active Member
May 26, 2020
112
34
38
.....
LAST UPDATE!

Installed the new 130 alt with included wiring kit and upgraded 4 gauge power wire. There is no more amp draw with the key off!
An unexpected extra bonus with the new Alt too. The engine seems to idle a lot better and smoother. I always had a slight uneven idle. Sort of like it was missing slightly and just sporadic slight sputtering. The idle would never even out or come down under 900 - 1k rpm until is was fully at temp and even then it was never even. This new stronger alt seems to have cured all this and right at start up too. Totally smooth, even and a better RPM, well before full warm up too. The engine idle just sounds and feels right.. Hard to explain. I don't know if this is only a coincidence or what. Perhaps the ECM or other components were not getting full power as what it was calling for? I dunno, but this new alt made a difference all around.

Thank you everyone for hearing me out and all your time!

Till next time..... :SN:
 
  • Like
Reactions: 1 user

General karthief

wonder how much it would cost to ship you a pair
Mod Dude
Aug 25, 2016
23,103
8,442
203
polk county florida
I've run into idle issues that where linked to the charging system before, these computer cars a very susceptible to voltage issues.
 
  • Like
Reactions: 1 users