This car was created in hell, help me thanks.

revhead347

Just rub Vaseline all over
15 Year Member
Jun 14, 2004
8,572
1,313
214
40
Acworth, GA
Had a similar problem running extremely rich "all of a sudden". Turned out the wire shorted at the junction to the O2 sensor. I would check all the wiring related to the O2 and any other sensors.

Come to think of it, I had the exact same problem at one time. Unplugging the O2 harness works too. It'll throw a check engine light, but it will take the O2s out of the equation.

Kurt
 
  • Sponsors(?)


08GT500

Active Member
Jul 12, 2018
892
139
53
50
Massachusetts
D0123 and Kurt’s Iidea of disconnecting the 02 sensors temporary is a great idea, I’ve run into the same 02 harness plug corrosion/bad connections causing intermittent running conditions, they look fine until pulled apart.
Your Motor idle/run better when cold, get worse when hot? I recall you mentioning it was test driven cold, so you didn’t get to see the issues when hot.
The MAF & TPS are used, but 02 sensors & a few others are temporarily unused (open loop) until the operating temp is reached,the remaining sensory data inputs/outputs then come online as the ECT relays coolant temps to the EEC..(closed loop).
Good reads...

Meant to ask, any internal motor mod’s you know of, e.g. Aftermarket Cam, Heads, etc? If uncertain, did the motor run with an equal sounding lope at idle- when it ran its best? Still wondering why the chipset’s in the EEC.
Shop still have the car, back home yet, did they find anything useful?
Best of luck!
John
 
  • Like
Reactions: Yellow5.094

Yellow5.094

Member
Oct 6, 2020
14
2
13
22
Michigan
Long story short, they had it 180° out. I got it out of there they re-funded me my original money, I tore it down on my own and exhaust valve on cylinder 1 wasnt seating all the way.
As well fuel injectors all fell apart as they came out so the orings were bad just creating vacuum leaks at the injectors.
Wasn’t getting spark from original ford ignition wiring harness still haven’t found answer. I’ve decided to go with Flotek 180 heads, Anderson cam and gt40 intakes ported on the rebuild . Wish me luck, thanks

Maxton.