Fuel Weird ping at high RPM/ high load

daniel_heigher

New Member
Jul 4, 2019
5
0
1
26
California
Hey everyone, this'll be my second post to the forum (and probably not the last). Anyway, I've got a pinging sound coming from my 2002 gt's engine ONLY after peak torque in 3rd/4th gear WOT (5spd manual). I observe my fuel pressure going down by about 4psi (totaling 36psi) every time this happens, and if I let off slightly the sound goes away. Daily driving doesn't seem to be affected, and I'm using 91 octane fuel.

I should note that the car is pretty much stock, except a k&n cold air intake. The fuel pump died awhile back and I replaced it with a Napa fuel pump and cleaned the tank out, the fuel filter was replaced with a motorcraft filter at the same time.

Any input appreciated, thanks! :)
IMG_20200323_152944.jpg
 
  • Sponsors(?)


wmburns

SN Certified Technician
Aug 14, 2009
5,849
506
204
Houston Texas
HOW are you measuring fuel pressure? With an external gauge or as reported by the PCM via the FRPS?

What are are Long Term fuel trims (LTFT) and Short Term Fuel Trims (STFT) doing when this problem occurs? IF there's a fuel delivery problem one would expect to see STFT climb (adding fuel) as the fuel pressure drops.

Have you confirmed that the battery charging system voltage is being maintained during this problem?

checked the voltage at the inertia switch (11.95v), and am so far still confused!
With the motor running there should be at least 14 volts at the battery. With 11.95 volts at the IFS this says that 2 volts have been lost in the wiring. 2 volts is a lot.

Here's some information on how to measure voltage drop. More importantly how to use the voltage drop testing method to determine WHERE the voltage is being lost.

Howto perform charging system voltage drop test

Finally there's a Ford TSB about a value noise coming from cylinder #8 in 2002 model year PI Romeo motors. Sometimes it's easier to hear the noise through the left hand fender well.

The noise is caused by not enough coolant flowing around the rear valve stems causing the valves to "stick" in the guides.

The fix is to install the redesigned PI heads that are included in 2003+ model year.

I have a 2002 Town Car with this problem. Sometimes you have to know what you are listening for to hear it. Other times you can hear it from across the parking lot. For the Town Car to replace the heads requires the motor to be removed. I'm planning on driving the the car until it sh*ts the bed and then I will deal with it.

Seems that you may be wise to avoid heavy 3rd and 4th gear WOT pulls if you want maximum life from a motor with a design defect.
 
Last edited:

daniel_heigher

New Member
Jul 4, 2019
5
0
1
26
California
HOW are you measuring fuel pressure? With an external gauge or as reported by the PCM via the FRPS?

What are are Long Term fuel trims (LTFT) and Short Term Fuel Trims (STFT) doing when this problem occurs? IF there's a fuel delivery problem one would expect to see STFT climb (adding fuel) as the fuel pressure drops.

Have you confirmed that the battery charging system voltage is being maintained during this problem?


With the motor running there should be at least 14 volts at the battery. With 11.95 volts at the IFS this says that 2 volts have been lost in the wiring. 2 volts is a lot.

Here's some information on how to measure voltage drop. More importantly how to use the voltage drop testing method to determine WHERE the voltage is being lost.

Howto perform charging system voltage drop test

Finally there's a Ford TSB about a value noise coming from cylinder #8 in 2002 model year PI Romeo motors. Sometimes it's easier to hear the noise through the left hand fender well.

The noise is caused by not enough coolant flowing around the rear valve stems causing the valves to "stick" in the guides.

The fix is to install the redesigned PI heads that are included in 2003+ model year.

I have a 2002 Town Car with this problem. Sometimes you have to know what you are listening for to hear it. Other times you can hear it from across the parking lot. For the Town Car to replace the heads requires the motor to be removed. I'm planning on driving the the car until it sh*ts the bed and then I will deal with it.

Seems that you may be wise to avoid heavy 3rd and 4th gear WOT pulls if you want maximum life from a motor with a design defect.
Thanks for the reply, hopefully I don't have the valve stick problem, as since i have an x in my vin, that should mean it's a Windsor, right? I measured my fuel pressure via a bluetooth obd adapter as well as the app 'torque'. I will check its values for fuel trim and post another reply later on. Also, thanks for the info about voltage drop, I tested the voltage with the ignition on, engine off. So the battery was right around 12.68 volts, which means 11.95 is still a pretty good drop and I will try and investigate for corroded or bad wires.

Again, thanks for the advice and hopefully I don't need new heads.
 

wmburns

SN Certified Technician
Aug 14, 2009
5,849
506
204
Houston Texas
as since i have an x in my vin, that should mean it's a Windsor, right?
No that is not correct. All 1999-2004 Mustang GT's have an "X" VIN code. Only the 1999-2000 model year Mustangs have the Windsor motors.

What matters is the model year. 2001-2002 Model year 4.6 SOHC are affected. 2003+ are not affected.