Code 95 Question/help Fp Relay Wiring

outdorsman

Active User
Jun 2, 2013
20
1
14
28
Hey all, currently my car has a code 95 KOEO. I've been trying to trace down the problem for 2 weeks now. I swapped relays and they click and all. My car had been running fine and it came out of nowhere. I can hear my pump priming and I can actually drive the car fine.

I tried checking voltage on the relay wiring but it was giving me weird readings. I had to go to work so I couldn't continue on that. I will attempt again.

I found something that peaked my interest. My car is a 1987 4 cyl coupe converted to 5.0 using a 1989 wiring harness and computer. So it has a 1987 Body harness and 1989 Engine harness. The ecu already has a wire going to PIN 19 but I don't know from where, would I still need to splice into my fuel pump relay wiring and and splice into the wire going into pin 19 on the ecu? I have heard this can cause a code 95.

My code 95 only comes on when I'm driving, it will go away when you turn off the car. It won't have it for a few miles and then itll pop back up. I have swapped fuel pressure regulators and fuel pump relays.

Any other things to check? All the threads I found were dead ends where no one posts solutions.
 
  • Sponsors(?)


Mustang5L5

i'm familiar with penetration
Mod Dude
Feb 18, 2001
32,843
8,994
224
Massachusetts
The wire that monitors the fuel pump wasn't present in the 87-88 cars. It's usually added when these cars are Mass air swapped. Since you have a mix of harnesses, I would just run a new wire from the relay to pin 19 and call it a day.
 

jrichker

StangNet's favorite TOOL
SN Certified Technician
Mar 10, 2000
27,357
2,824
234
74
Dublin GA
lowendmac.com
Code 96 for 86-90 model 5.0 Mustang – KOEO- Fuel pump monitor circuit shows no power - Fuel pump relay or battery power feed was open - Power / Fuel Pump Circuits. The fuel pump lost power at some time while the ignition switch was in the run position. The main power feed to the pump is what is losing power.

Look for a failing fuel pump relay, bad connections or broken wiring. The fuel pump relay is located under the passenger seat. On Mass Air Conversions, the signal lead that tells the computer that the fuel pump has power may not have been wired correctly.
See http://www.stangnet.com/tech/maf/massairconversion.html


Look for power at the fuel pump - the fuel pump has a connector at the rear of the car with a pink/black wire and a black wire that goes to the fuel pump. The pink/black wire should be hot when the test connector is jumpered to the test position. . To trick the fuel pump into running, find the ECC test connector and jump the connector in the lower RH corner to ground.
attachment.php?attachmentid=68357&stc=1&d=1322348015.gif


86-90 Models:
Using the diagram, check the red/black wire from the fuel pump relay: you should see 12 volts or so. If not, check the inertia switch: on a hatch it is on the drivers side by the taillight. Look for a black rubber plug that pops out: if you don't find it, then loosen up the plastic trim. Check for voltage on both sides of the switch. If there is voltage on both sides, then check the Pink/black wire on the fuel pump relay: it is the power feed to the fuel pump. Good voltage there, then the fuel pump body to tank wiring harness connector is the likely culprit since it is getting power. No voltage there, check the Orange/Lt blue wire, it is the power feed to the fuel pump relay & has a fuse link in it. Good voltage there & at the Pink/black wire, swap the relay.

Keep in mind that the relay wiring and socket can also cause intermittent problems. Clean the relay socket with non-flammable brake parts cleaner or electrical contact cleaner. If you find damaged wiring at the relay socket, replacement pigtail socket assemblies are available at the auto parts stores. Be sure to solder the wires and cover the solder joints with heat shrink tubing if you replace the relay socket.


fuel-pump-wiring-89-90-5-0-mustang-jpg.55493.jpg
 

Attachments

outdorsman

Active User
Jun 2, 2013
20
1
14
28
I'll try checking voltage again. I was getting weird readings when I tried it this morning. I tried jumping the fuel pump on and succeeded on that, i then tried to measure voltage on the pink/black wire and received no solid readings, like it kept fluctuating. I tried measuring voltage on the orange/lt blue wire and received abnormal and unstable readings. Also, would all that apply to the code 95? I ask cause you said code 96?

It just is weird to me, the 1987 mustangs did not have a Fuel Pump Monitor wire correct? So why did this code 95 take 9 months after the swap to pop up? Ill try and add the additional wire as well but I don't want to cut up my harness anymore than I have to. All i've done since this started was install some longtube headers. The car runs and drives. If they didnt have the wire then where does the wire on pin 19 on my engine harness go to?
 

outdorsman

Active User
Jun 2, 2013
20
1
14
28
Losing my mind over this car. Everyone in the family detests it and wants it gone lol.

Anyway I tried checking voltage. Don't know if my meter is messed up or something but I'm not getting the 12v on any wire at all. It just gives me random numbers. TI just don't see how thats right considering the car turns on and runs, idles, everything. Just that CEL annoys the :poo: out of me because I know it may be causing a lean condition or whatever.

Just tested my meter on a wall outlet and it works. So i'm guessing my wiring is all screwed up on my car? That's all I'm really gathering

Car is a 1987 Ford Mustang originally a 4 cylinder car.
I used a 1989 Wiring Harness


302 Stock Bottom end
GT40 3 bar heads
GT40 Intake
Trickflow Stage 1 Cam
Flow Tech Longtubes
Pro-m MAF
24 lb injectors
stock rails and fpr
Walbro 255
3g Alternator upgrade
 
Last edited:

outdorsman

Active User
Jun 2, 2013
20
1
14
28
There is a pink black wire on the fp relay, but its not like the ones ive seen having two of them coming out from the same pin. This is a 1987 Car so I know they didn't come with the FPM wire from the factory.

I just checked voltage again and I think I got the hang of it. I'm getting voltage on both sides of the inertia switch, at the orange/lt blue wire, at the pink/black wire, and at the red/black wire. So what now. It says to switch relays? I've done that and the problem still came up so I returned the relay I replaced it with.


If the lack of a fpm wire is the issue, I just dont understand why it didn't come up in the past year I've daily driven this car.
 

General karthief

wonder how much it would cost to ship you a pair
Mod Dude
Aug 25, 2016
16,300
5,195
193
polk county florida
Can't answer that.
89 computer will have that wire (pink/black) from relay to pin 19, 87 didn't from what I read, check to see if the p/b wire go's to the pin 19 with your tester, make sure everything is unpluged from computer and batt is disco'd
Is this mas air?
 

outdorsman

Active User
Jun 2, 2013
20
1
14
28
Yes Mass Air, Pro-m MAF. I used the entire 1989 engine harness for the swap and kept the 87 dash and body harness
 

General karthief

wonder how much it would cost to ship you a pair
Mod Dude
Aug 25, 2016
16,300
5,195
193
polk county florida
I understand the 87/89 wiring addition, what I am trying to determine is if the p/b wire from the relay is in fact connected to your computer, I understand there is a p/b wire there and it probably will need an additional wire added.
Bear with me and we will get this sorted out.
 

outdorsman

Active User
Jun 2, 2013
20
1
14
28
So I ran the wire and the code is still there. I also found out I had a few more codes, code 29, code 33, code 41. I took care of the 41, replaced the pass o2 sensor. code 29 is there because my longtubes melted my VSS which I will replace later. Code 33, my egr isn't hooked up.

I still have a code 67 Neutral safety switch and the code 95. I hear the code 67 is common on auto-5 spd swaps which my car is.

So i'm at a loss of what to check now. How can I trace the wire at pin 19? Would that really cause this issue?

Would this code cause any driveability issues? If not, i'ma just drive it...
 

General karthief

wonder how much it would cost to ship you a pair
Mod Dude
Aug 25, 2016
16,300
5,195
193
polk county florida
Let me do a little research on this, maybe consult with another member and I'll get be to you, as far as drivability, I don't know, you say it runs and drives good despite the codes so use your own judgement on that.
 

outdorsman

Active User
Jun 2, 2013
20
1
14
28
Just took the car for a 25 mile cruise and the engine light did not pop up anymore. I'll dump codes tomorrow morning just to check.
 

outdorsman

Active User
Jun 2, 2013
20
1
14
28
I did add the wire but the code was still popping up. I had taken it for a drive and it came up immediately even with the FPM wire. It wasn't til I fixed my o2 sensor issue that it seems I have no issues no more. Tomorrowwill be the real test, cause its raining today, so I'll be staying indoors.
 

outdorsman

Active User
Jun 2, 2013
20
1
14
28
And the code remains, As well as having developed code 66 and code 91 now.... I hate this car. I'll be checking it further this weekend. Last thing I need is for the MAF to be toast...
 

Mustang5L5

i'm familiar with penetration
Mod Dude
Feb 18, 2001
32,843
8,994
224
Massachusetts
If your car is a swap, verifybthe o2 sensor loop is the correct for the year of ECU and harness you have.

If you jump out the plug under the dash, and still have 67, then my bet is the wiring isn't matching up somewhere as the NSS wiring did change in 1988 and 1987s were wired differently.

You may just have to jump it out somewhere to clear the code 67 and regain idle quality
 
Last edited:

outdorsman

Active User
Jun 2, 2013
20
1
14
28
Okay so I found out if I press in the clutch the code 67 goes away. Now the only code that still remains is the code 95. I got rid of the code 66, it was pretty embarassing but I found out the MAF plug wasn't plugged in all the way. Lol my bad
 
Thread starter Similar threads Forum Replies Date
J Please Help with codes and FP question....... Fox 5.0 Mustang Tech 14
W 88 GT pulled codes please help (also TPS question) Fox 5.0 Mustang Tech 1
striker911 Sorry, this is not a normal code question. Need help please. SN95 V6 Mustang Tech 7
R Question About Some Fault Codes Check Engine Light Please HELP SN95 4.6L Mustang Tech 3
T Code 92 question - searched it no luck - please help Fox 5.0 Mustang Tech 10
91GTstroked Engine Code 29 vehicle speed sensor question Fox 5.0 Mustang Tech 5
9 Engine 2003 Gt Problem And Obdii Code Question SN95 4.6L Mustang Tech 3
BlakeusMaximus Question On A Ford Obd-1 Code Reader Fox 5.0 Mustang Tech 8
S New Member - Spark Plug Question (289) 1965 - 1973 Classic Mustangs -General/Talk- 5
68GT2+2 68 Gt J Code Questions 1965 - 1973 Classic Mustangs -General/Talk- 4
doobismaximus Code Questions 1994 - 1995 Specific Tech 7
J Crazy Question On P0174 Code 1996 - 2004 SN95 Mustang -General/Talk- 8
J Question On P0174 Code 1996 - 2004 SN95 Mustang -General/Talk- 2
9 PATS question about coded key SN95 V6 Mustang Tech 4
E A question about computer codes SN95 V6 Mustang Tech 1
Q P0411 code and Seafoam question SVT Tech Forum 1
T EEC-IV Code Questions Fox 5.0 Mustang Tech 1
kpack5982 c-4 question and code 67 question Fox 5.0 Mustang Tech 4
M 1969 Mach 1 390 S Code Questions Regional Forums and Event Information 0
Slo5Oh89 Reading Codes Question. Fox 5.0 Mustang Tech 3
StreetDreamsGT KOER codes 44 & 94, just one quick question about them... Fox 5.0 Mustang Tech 12
V 1966 A code question Classic Mustang Specific Tech 8
Luis911 Code 33, questions Fox 5.0 Mustang Tech 4
R Code 19 Question Fox 5.0 Mustang Tech 1
R Codes Question Fox 5.0 Mustang Tech 2
AnthonyR23 War on Trouble Codes! Few Questions: Fox 5.0 Mustang Tech 8
S Question about codes Fox 5.0 Mustang Tech 3
L Engine code question Classic Mustang Specific Tech 5
T weird engine codes and questions Fox 5.0 Mustang Tech 1
Cobra_Dusten Check engine light, pulled codes, have questions Fox 5.0 Mustang Tech 7
S P0340 Code & Question SN95 4.6L Mustang Tech 1
V OBD2 code P0357 questions SN95 4.6L Mustang Tech 6
1 CODES got a few questions 1994 - 1995 Specific Tech 4
M 65 289 A-code (Cam and Valvetrain) Questions Classic Mustang Specific Tech 20
marine_2003 Code Question SN95 4.6L Mustang Tech 2
W VIN number paint code and interior advice question Fox 5.0 Mustang Tech 8
O Stock axle ID code question Fox 5.0 Mustang Tech 0
bretamo Vacuum Line Question - Color Codes Fox 5.0 Mustang Tech 5
I KOEO CODE QUESTION Fox 5.0 Mustang Tech 0
dcurtis Code Question???????? Fox 5.0 Mustang Tech 3
K 1969 Mach 1 M-code Question? 1965 - 1973 Classic Mustangs -General/Talk- 2
D code question 2.3L (N/A & Turbo) Tech 0
89_FakeSnake Question on code 94 Fox 5.0 Mustang Tech 1
WhiteDevil A couple questions about trouble codes 1994 - 1995 Specific Tech 2
5 Stupid question about air bag trouble codes Fox 5.0 Mustang Tech 1
R 65 A Code Engine Questions (restore to orig) Classic Mustang Specific Tech 6
jhonda Got a code question for yall like everybody else Fox 5.0 Mustang Tech 2
93 LX Pulled Codes and have questions. Fox 5.0 Mustang Tech 6
ninety15.0 O2 code question! Fox 5.0 Mustang Tech 1
kpack5982 Coolant and Code question Fox 5.0 Mustang Tech 1
Similar threads